Modify

Opened 4 days ago

Closed 3 days ago

#19954 closed defect (fixed)

Shortcuts captured while renaming a layer

Reported by: gaben Owned by: Don-vip
Priority: normal Milestone: 20.10
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by gaben)

What steps will reproduce the problem?

  1. Open a layer
  2. Double click on the layer's name
  3. Start typing something while you hold the Shift key

What is the expected result?

Interrupt free label edit.

What happens instead?

For example, when you type capital v it appears in the label, but the validator also runs, because the default shortcut is Shift+V.

Please provide any additional information below. Attach a screenshot if possible.

System independent, plugins not affecting this.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-17 00:52:48 +0200 (Sat, 17 Oct 2020)
Build-Date:2020-10-17 01:30:59
Revision:17218
Relative:URL: ^/trunk

Attachments (0)

Change History (4)

comment:1 Changed 4 days ago by gaben

Description: modified (diff)

comment:2 Changed 4 days ago by skyper

I have a similar problem with the relation panel filter box, see #19120.

comment:3 Changed 3 days ago by Don-vip

Milestone: 20.10
Owner: changed from team to Don-vip
Status: newassigned

comment:4 Changed 3 days ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 17235/josm:

fix #19120 - fix #19954 - Disable Shift shortcuts in text fields

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.