Modify

Opened 15 months ago

Closed 15 months ago

Last modified 14 months ago

#19952 closed enhancement (fixed)

Restructure sports_centre preset by sport type

Reported by: gaben Owned by: team
Priority: normal Milestone: 20.11
Component: Internal preset Version:
Keywords: Cc:

Description (last modified by gaben)

What steps will reproduce the problem?

A sports_centre has multiple sports. What do you do?

  1. select the first sport from the preset's dropdown list
  2. the rest needed to type by hand
  3. don't forget the semicolon

What is the expected result?

The sport input should be intuitive. I propose to change the preset structure to represent sport types by the classification, for example, athletics, ball, table etc. and replace dropdown with tickboxes. In this case, they can easily be recognised and added if there are more.

This wiki page is a good starting point https://en.wikipedia.org/wiki/List_of_sports

What happens instead?

Currently with only a single dropdown, adding a sport is 'hard' and slow for sure.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-17 00:52:48 +0200 (Sat, 17 Oct 2020)
Build-Date:2020-10-17 01:30:59
Revision:17218
Relative:URL: ^/trunk

Attachments (0)

Change History (13)

comment:1 Changed 15 months ago by gaben

What do you think?

comment:2 Changed 15 months ago by gaben

Description: modified (diff)

comment:3 Changed 15 months ago by skyper

How about simply changing the combo into a multiselect?

Rearranging the values to form groups and adding icons are possible further improvements

Check boxes will not work as each will add a separate tag to the object.

comment:4 in reply to:  3 Changed 15 months ago by gaben

It's a possible intermediate step, good idea.

Rearranging the values to form groups and adding icons are possible further improvements

Exactly, this is what I want :)

Maybe other presets can be grouped, too. Like restaurant cuisines: asian, european etc. based on geographic location, or recycling preset with icons.

comment:5 Changed 15 months ago by skyper

I was thinking about adding icons to the multiselect values like in the general tower preset for tower:type. Additionally, the values could be rearranged in the multiselect and all individual presets below.

More tags and preset links would be nice for stadium and sports_centre, like address, wikipedia …

comment:6 Changed 15 months ago by Klumbumbus

Groups are not so good because you will "always" search in the wrong group as some sports could be counted to different groups. Alphabetical order of all sports is better.

comment:7 Changed 15 months ago by gaben

Which sport do you think about?

comment:8 Changed 15 months ago by Klumbumbus

That depends on which groups are chosen. I'm pretty sure there will always be cases which you could count to different groups. Just one example: Polo. Is it riding sports or ball sports?

comment:9 Changed 15 months ago by skyper

Ok, no grouping in the multiselect values, but how about grouping the single presets and duplicating single presets to places in several groups if appropriate? Should be no problem with chunk.

Last edited 15 months ago by skyper (previous) (diff)

comment:10 in reply to:  8 Changed 15 months ago by gaben

Replying to Klumbumbus:

Just one example: Polo. Is it riding sports or ball sports?

Thanks, this is a good example, both. But is it going to be in the presets?

Maybe I can make a screen draft how I think the preset should look like. Then you can share your thoughts.

comment:11 Changed 15 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 17286/josm:

fix #19952 - Change sport combo to multiselect, update ignorelist

comment:12 Changed 15 months ago by Klumbumbus

Milestone: 20.10

comment:13 Changed 14 months ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.