Modify

Opened 16 months ago

Closed 14 months ago

Last modified 14 months ago

#19906 closed defect (fixed)

Create areas tool: bottom toolbar unusable to view offset measurement

Reported by: Squizie3 Owned by: Squizie3
Priority: normal Milestone: 20.11
Component: Core Version: latest
Keywords: template_report status_bar measurement create_areas tool regression Cc: GerdP

Description (last modified by Squizie3)

This bug is very similar to #19887: after the update to stable release 17084 which included the enhancement #19830, you can't properly view the measurement of the action you're doing anymore, instead the length of the way you're performing the action on is shown. While for the parallel ways tool this should now be fixed, I discovered the bug also exists for the create areas tool (and maybe even more tools). The create areas tool works correctly for it's default tool behaviour, but not when you need to perform actions using the Ctrl button pressed.

What steps will reproduce the problem?

Create areas tool:

  1. Make sure you are in 'expert mode' in JOSM's preferences
  2. Activate the create areas tool in the sidebar
  3. Press the Ctrl key (to move nodes or line segments, instead of the default tool's behaviour)
  4. Start moving a random object, being it a node you're moving alongside one of it's connecting lines, or a line segment
  5. Watch the bottom status bar's measurement box flicker

What is the expected result?

Showing the offset measurement of the action you're doing.

What happens instead?

The offset measurement flickers and is constantly overwritten by the way's length.

Please provide any additional information below. Attach a screenshot if possible.

Please take a look at #19887 for a very similar problem, that should now have been resolved.

Update: At first, I included the rotate & scale tool in this ticket too, but it turned out to be a different issue so I now split this off to ticket #20101.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 nl) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 831 MB / 1820 MB (596 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1280x768 (scaling 1.0x1.0)
Maximum Screen Size: 1280x768
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=%UserProfile%\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\56\1ee8cfb8-7bd2a134, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=NULL,2048m, -Djnlpx.splashport=7488, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm.jnlp, -Djnlpx.jvm=<java.home>\bin\javaw.exe]
Dataset consistency test: No problems found

Plugins:
+ FastDraw (35499)
+ PicLayer (35405)
+ buildings_tools (35563)
+ log4j (35092)
+ measurement (35405)
+ pbf (35446)
+ public_transport (35405)
+ reverter (35556)
+ routing (35405)
+ splinex (35454)
+ turnrestrictions (35515)
+ utilsplugin2 (35487)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransportV2&zip=1

Attachments (0)

Change History (15)

comment:1 Changed 16 months ago by GerdP

Owner: changed from team to GerdP
Status: newassigned

comment:2 Changed 16 months ago by GerdP

Owner: changed from GerdP to Squizie3
Status: assignedneedinfo

I cannot yet reproduce the expected behaviour for rotation tool or scaling tool with r16812 (started with skip-plugins). Can you tell me a version that showed the expected behaviour? The changes for #19830 should not have any influence on the angle field in the status line. I see you have the measurement plugin installed, maybe you refer to its panel?

I am working on a fix for the Create areas tool.

comment:3 Changed 16 months ago by GerdP

In 17157/josm:

see #19906: Scale, rotate & create areas tool: bottom toolbar unusable to view angle/scale factor/offset measurement

  • Let Create areas tool manage the distance field in the status line
  • enable autoupdate of the distance field in MapMode.exitMode()

comment:4 Changed 16 months ago by Squizie3

Thanks GerdP for the fix of the create areas tool. I will update you on the scale and rotation as soon as possible, hopefully in a few days, when I have a little time to install and check it in a previous version.

comment:5 Changed 15 months ago by Klumbumbus

There is another problem, probably a regression of a fix :)

  1. draw a way with some nodes
  2. move mouse after last node
  3. statusbar shows length of not-yet-drawn-next-segment "rubber band" (correct)
  4. hit s to switch to select mode and end drawing
  5. status bar shows last length of snipped away rubber band instead of the whole way length

comment:6 Changed 15 months ago by GerdP

In 17295/josm:

see #19906: Scale, rotate & create areas tool: bottom toolbar unusable to view angle/scale factor/offset measurement
update statusline when exiting DrawAction

comment:7 Changed 15 months ago by GerdP

@Squizie3: I guess you didn't find any older version that worked as you proposed?

comment:8 Changed 15 months ago by anonymous

@GerdP not yet sorry, I forgot about checking it. I will update you in one of the coming days if I can find it or not.
-Squizie3 (wasn't logged in)

Last edited 15 months ago by Squizie3 (previous) (diff)

comment:9 Changed 14 months ago by Don-vip

What's the status of this ticket?

comment:10 Changed 14 months ago by GerdP

Maybe you remember an older version that worked as described for rotation or scale?

comment:11 Changed 14 months ago by GerdP

In case that nobody knows an old version we can change the ticket from defect to enhancement.

comment:12 Changed 14 months ago by Don-vip

Milestone: 20.1020.11

I didn't read the ticket sorry. Looks like it can wait next release.

comment:13 Changed 14 months ago by Squizie3

Description: modified (diff)
Keywords: scale rotate removed
Milestone: 20.1120.10
Resolution: fixed
Status: needinfoclosed
Summary: Scale, rotate & create areas tool: bottom toolbar unusable to view angle/scale factor/offset measurementCreate areas tool: bottom toolbar unusable to view offset measurement

comment:14 Changed 14 months ago by Squizie3

Thanks all for the cooperation! It turned out I couldn't find any previous versions showing the stated behaviour of the rotate & scale tools, so my memory probably confused it with another program or plugin. Therefore I split it off to a new ticket #20101 as an enhancement, and changed this ticket to only include the create areas tool. Since @GerdP already implemented the fixes needed for the create areas tool, I now marked this bug fixed.

comment:15 Changed 14 months ago by Don-vip

Milestone: 20.1020.11

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Squizie3.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.