Modify

Opened 7 weeks ago

Closed 7 weeks ago

Last modified 6 weeks ago

#19892 closed defect (fixed)

The layer "Poznań: Orthophotomap Bieżąca (aerial image)" not working in JOSM but working everywhere else...

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: External imagery source Version: tested
Keywords: template_report Cc:

Description

Something is extremely wrong with the layer "Poznań: Orthophotomap Bieżąca (aerial image)"https://josm.openstreetmap.de/wiki/Maps/Poland#Pozna:OrthophotomapBiecaaerialimage. You can see that its working here https://josm.openstreetmap.de/mapsview?entry=Pozna%C5%84%3A%20Orthophotomap%20Bie%C5%BC%C4%85ca%20%28aerial%20image%29 but in JOSM all I get is the error 400. This tester also confirms that the map is working https://ideditor.github.io/imagery-index/index.html just paste in there this:

{
    "type": "Feature",
    "properties": {
        "name": "Poznań: Orthophotomap Bieżąca (aerial image)",
        "type": "wms",
        "url": "http://wms2.geopoz.poznan.pl/geoserver/gwc/service/wms?LAYERS=ortogpkg:ortofotomapa_biezaca&STYLES=&FORMAT=image/jpeg&SRS={proj}&WIDTH={width}&HEIGHT={height}&BBOX={bbox}&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap",
        "license_url": "https://www.geopoz.pl/bip/index.php?t=200&id=2449",
        "privacy_policy_url": "https://www.geopoz.pl/portal/index.php?t=200&id=5142",
        "id": "poznan-ortofotomapaBiezaca",
        "country_code": "PL",
        "best": true,
        "start_date": "2018",
        "available_projections": [
            "CRS:84",
            "EPSG:2177",
            "EPSG:2180",
            "EPSG:3857",
            "EPSG:4326"
        ],
        "attribution": {
            "text": "Zarząd Geodezji i Katastru Miejskiego GEOPOZ",
            "html": "https://www.geopoz.pl/",
            "required": true
        }
    },
"geometry": {
    "type": "Polygon",
    "coordinates": [
      [
        [
          16.72794,
          52.48838
        ],
        [
          16.86925,
          52.48982
        ],
        [
          16.86879,
          52.50779
        ],
        [
          16.93948,
          52.50845
        ],
        [
          16.93926,
          52.51743
        ],
        [
          16.98639,
          52.51784
        ],
        [
          16.98784,
          52.45494
        ],
        [
          17.03491,
          52.45534
        ],
        [
          17.0353,
          52.43736
        ],
        [
          17.08235,
          52.43774
        ],
        [
          17.0831,
          52.4018
        ],
        [
          17.0596,
          52.40161
        ],
        [
          17.06129,
          52.32075
        ],
        [
          17.01438,
          52.32035
        ],
        [
          17.01518,
          52.28441
        ],
        [
          16.96829,
          52.28401
        ],
        [
          16.96787,
          52.30198
        ],
        [
          16.89752,
          52.30134
        ],
        [
          16.89662,
          52.33728
        ],
        [
          16.80273,
          52.33638
        ],
        [
          16.80176,
          52.37232
        ],
        [
          16.77828,
          52.3721
        ],
        [
          16.77603,
          52.45294
        ],
        [
          16.72897,
          52.45244
        ],
        [
          16.72794,
          52.48838
        ]
      ]
    ]
  }
} 

What steps will reproduce the problem?

  1. Open JOSM
  2. Add the mentioned layer for Poznań
  3. See the error HTTP 400

What is the expected result?

Not able to use the latest layer for Poznań, Poland

What happens instead?

Getting an error HTTP 400

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-10-03 13:42:38 +0200 (Sat, 03 Oct 2020)
Build-Date:2020-10-04 01:30:47
Revision:17084
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17084 pl) Windows 10 64-Bit
OS Build number: Windows 10 Education 2004 (19041)
Memory Usage: 1132 MB / 1820 MB (365 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=%UserProfile%\Downloads\josm.jnlp, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=NULL,2048m, -Djnlpx.splashport=50771, -Djnlpx.jvm=<java.home>\bin\javaw.exe]
Dataset consistency test: No problems found

Plugins:
+ PicLayer (35405)
+ indoorhelper (20bf8a3-dirty)

Map paint styles:
- <josm.pref>\styles\sit.mapcss

Last errors/warnings:
- 05251,511 W: java.net.UnknownHostException: wms2
- 05251,511 W: Already here java.net.UnknownHostException: wms2
- 05251,618 W: java.net.UnknownHostException: wms2
- 05251,620 W: java.net.UnknownHostException: wms2
- 05251,726 W: java.net.UnknownHostException: wms2
- 05251,728 W: java.net.UnknownHostException: wms2
- 05251,833 W: java.net.UnknownHostException: wms2
- 05251,835 W: java.net.UnknownHostException: wms2
- 05251,942 W: java.net.UnknownHostException: wms2
- 05251,942 E: java.net.UnknownHostException: wms2

Attachments (4)

Zrzut ekranu 2020-10-07 142009.png (2.0 MB) - added by anonymous 7 weeks ago.
19892a.PNG (176.4 KB) - added by Klumbumbus 7 weeks ago.
19892b.PNG (480.5 KB) - added by Klumbumbus 7 weeks ago.
19705c.gif (6.1 MB) - added by Klumbumbus 7 weeks ago.

Change History (19)

Changed 7 weeks ago by anonymous

comment:1 Changed 7 weeks ago by skyper

Component: CoreCore imagery
Version: latesttested

comment:2 Changed 7 weeks ago by simon04

http://wms2.geopoz.poznan.pl/geoserver/gwc/service/wms?LAYERS=ortogpkg:ortofotomapa_biezaca&STYLES=&FORMAT=image/jpeg&SRS=EPSG:3857&WIDTH=512&HEIGHT=512&BBOX=0.0000000,-0.0000000,4891.9698103,4891.9698102&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap fails with

HTTP/1.1 400
400: The requested tile dimensions 512x512 do not match those of the grid set (256x256)

Setting the advanced preference imagery.wms.imageSize to 256 resolves this issue.

EDIT: You may configure the tile size via Help/Preferences/Imagery#Settings as well…

Last edited 7 weeks ago by simon04 (previous) (diff)

comment:3 Changed 7 weeks ago by anonymous

Is there any way to set this in the layer so that everyone without this knowledge could have it working straight away? If so could you implement it, unfortunately I don't know the ropes yet

comment:4 Changed 7 weeks ago by stoecker

That error message is really interesting. Why does a WMS complain about the size of the downloaded area. Probably because this is only a cache server.

I think this should be switched either to WMTS or TMS.

comment:5 Changed 7 weeks ago by Klumbumbus

Component: Core imageryExternal imagery source
Resolution: fixed
Status: newclosed

comment:6 Changed 7 weeks ago by anonymous

Component: External imagery sourceCore imagery

There seems to be a similar problem with the layer Geoportal 2: High Resolution Orthophotomap (aerial image) https://josm.openstreetmap.de/wiki/Maps/Poland#Geoportal2:HighResolutionOrthophotomapaerialimage, it switching it to WMTS fixes it but that also caused a desync with editor-layer-index https://github.com/osmlab/editor-layer-index

comment:7 Changed 7 weeks ago by Klumbumbus

"Geoportal 2: High Resolution Orthophotomap (aerial image)" worked as wms in JOSM too but you needed to change the projection in your JOSM to one of the two supported ones as automatic reprojection to mercartor didn't work. I agree that wmts is better in this case as it directly works with mercator projection. Possible solutions for the desync:

  • change it to wmts in ELI too (if iD supports wmts, I'm not sure about this atm)
  • ignore the desync

comment:8 Changed 7 weeks ago by Klumbumbus

Component: Core imageryExternal imagery source

comment:10 Changed 7 weeks ago by anonymous

ELI is limited to wms

comment:11 Changed 7 weeks ago by simon04

In 17094/josm:

see #19892 - Extend TemplatedWMSTileSourceTest.testGetTileUrl

comment:12 Changed 7 weeks ago by Klumbumbus

Layer names should be english (for translation): https://josm.openstreetmap.de/wiki/Maps/Poland?action=diff&version=172

comment:13 in reply to:  7 ; Changed 7 weeks ago by stoecker

Replying to Klumbumbus:

"Geoportal 2: High Resolution Orthophotomap (aerial image)" worked as wms in JOSM too but you needed to change the projection in your JOSM to one of the two supported ones as automatic reprojection to mercartor didn't work. I agree that wmts is better in this case as it directly works with mercator projection.

Can you explain that? Reprojection is a step after the tile access. It should be independent.

comment:14 in reply to:  13 Changed 7 weeks ago by Klumbumbus

Replying to stoecker:

Can you explain that?

The tiles appear at the wrong place on lower zoom or get totally mixed up on each zoom step at higher zoom.

Changed 7 weeks ago by Klumbumbus

Attachment: 19892a.PNG added

Changed 7 weeks ago by Klumbumbus

Attachment: 19892b.PNG added

Changed 7 weeks ago by Klumbumbus

Attachment: 19705c.gif added

comment:15 Changed 6 weeks ago by Klumbumbus

ignored for now

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.