Modify

Opened 10 years ago

Closed 10 years ago

#1987 closed defect (fixed)

Exception after Upgrade from 1178 to 1212

Reported by: anonymous Owned by: framm
Priority: major Milestone:
Component: unspecified Version: latest
Keywords: Cc:

Description

Using josm-tested.jar.

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1212
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1212
Last Changed Date: 2009-01-06 18:06:36 +0100 (Tue, 06 Jan 2009)

Plugins: measurement;openstreetbugs;slippymap;validator;wmsplugin
Plugin measurement Version: 12598
Plugin openstreetbugs Version: 12590
Plugin slippymap Version: 12780
Plugin validator Version: 12279
Plugin wmsplugin Version: 12439

java.lang.RuntimeException: java.lang.reflect.InvocationTargetException

at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:146)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:95)
at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(Unknown Source)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

Caused by: java.lang.reflect.InvocationTargetException

at java.awt.EventQueue.invokeAndWait(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable.closeDialog(PleaseWaitRunnable.java:142)
... 4 more

Caused by: org.openstreetmap.josm.plugins.PluginException: Ein Fehler ist in dem Plugin validator aufgetreten.

at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:33)
at org.openstreetmap.josm.Main.setMapFrame(Main.java:166)
at org.openstreetmap.josm.Main.addLayer(Main.java:344)
at org.openstreetmap.josm.actions.NewAction.actionPerformed(NewAction.java:22)
at org.openstreetmap.josm.Main.editLayer(Main.java:356)
at org.openstreetmap.josm.actions.downloadtasks.DownloadOsmTask$Task.finish(DownloadOsmTask.java:62)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$4.run(PleaseWaitRunnable.java:128)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.Dialog$1.run(Unknown Source)
at java.awt.Dialog$3.run(Unknown Source)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Unknown Source)
at java.awt.Component.show(Unknown Source)
at java.awt.Component.setVisible(Unknown Source)
at java.awt.Window.setVisible(Unknown Source)
at java.awt.Dialog.setVisible(Unknown Source)
at org.openstreetmap.josm.gui.PleaseWaitRunnable$3.run(PleaseWaitRunnable.java:78)
at java.awt.event.InvocationEvent.dispatch(Unknown Source)
at java.awt.EventQueue.dispatchEvent(Unknown Source)
at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
at java.awt.EventDispatchThread.run(Unknown Source)

Caused by: java.lang.reflect.InvocationTargetException

at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.openstreetmap.josm.plugins.PluginProxy.mapFrameInitialized(PluginProxy.java:30)
... 28 more

Caused by: java.lang.NoSuchMethodError: org.openstreetmap.josm.gui.MapFrame.addToggleDialog(Lorg/openstreetmap/josm/gui/dialogs/ToggleDialog;)V

at org.openstreetmap.josm.plugins.validator.OSMValidatorPlugin.mapFrameInitialized(OSMValidatorPlugin.java:158)
... 33 more

Attachments (0)

Change History (1)

comment:1 Changed 10 years ago by anonymous

Resolution: fixed
Status: newclosed

Duplicate #1883.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.