Modify

Opened 9 months ago

Closed 9 months ago

Last modified 9 months ago

#19832 closed defect (fixed)

[PATCH] ivy pointing at non-existant jacoco

Reported by: taylor.smock Owned by: team
Priority: normal Milestone: 20.09
Component: Core Version:
Keywords: Cc:

Description (last modified by taylor.smock)

Buildfile: /Users/tsmock/workspace/josm/core/build.xml

init-properties:

init-ivy:
      [get] Destination already exists (skipping): /Users/tsmock/workspace/josm/core/tools/ivy/ivy-2.5.0.jar

resolve:
[ivy:resolve] :: Apache Ivy 2.4.0 - 20141213170938 :: http://ant.apache.org/ivy/ ::
[ivy:resolve] :: loading settings :: file = /Users/tsmock/workspace/josm/core/ivysettings.xml
WARNING: An illegal reflective access operation has occurred
WARNING: Illegal reflective access by org.apache.ivy.util.url.IvyAuthenticator (file:/usr/local/Cellar/ant/1.10.8_1/libexec/lib/ivy-2.4.0.jar) to field java.net.Authenticator.theAuthenticator
WARNING: Please consider reporting this to the maintainers of org.apache.ivy.util.url.IvyAuthenticator
WARNING: Use --illegal-access=warn to enable warnings of further illegal reflective access operations
WARNING: All illegal access operations will be denied in a future release
[ivy:resolve] 
[ivy:resolve] :: problems summary ::
[ivy:resolve] :::: WARNINGS
[ivy:resolve]           module not found: org.jacoco#org.jacoco.ant;0.8.6-SNAPSHOT
[ivy:resolve]   ==== josm-nexus: tried
[ivy:resolve]     https://josm.openstreetmap.de/nexus/content/repositories/public/org/jacoco/org.jacoco.ant/0.8.6-SNAPSHOT/org.jacoco.ant-0.8.6-SNAPSHOT.pom
[ivy:resolve]     -- artifact org.jacoco#org.jacoco.ant;0.8.6-SNAPSHOT!org.jacoco.ant.jar:
[ivy:resolve]     https://josm.openstreetmap.de/nexus/content/repositories/public/org/jacoco/org.jacoco.ant/0.8.6-SNAPSHOT/org.jacoco.ant-0.8.6-SNAPSHOT-nodeps.jar
[ivy:resolve]   ==== jcenter: tried
[ivy:resolve]     https://jcenter.bintray.com/org/jacoco/org.jacoco.ant/0.8.6-SNAPSHOT/org.jacoco.ant-0.8.6-SNAPSHOT.pom
[ivy:resolve]     -- artifact org.jacoco#org.jacoco.ant;0.8.6-SNAPSHOT!org.jacoco.ant.jar:
[ivy:resolve]     https://jcenter.bintray.com/org/jacoco/org.jacoco.ant/0.8.6-SNAPSHOT/org.jacoco.ant-0.8.6-SNAPSHOT-nodeps.jar
[ivy:resolve]   ==== oss-sonatype-snapshots: tried
[ivy:resolve]     https://oss.sonatype.org/content/repositories/snapshots/org/jacoco/org.jacoco.ant/0.8.6-SNAPSHOT/org.jacoco.ant-0.8.6-SNAPSHOT.pom
[ivy:resolve]     -- artifact org.jacoco#org.jacoco.ant;0.8.6-SNAPSHOT!org.jacoco.ant.jar:
[ivy:resolve]     https://oss.sonatype.org/content/repositories/snapshots/org/jacoco/org.jacoco.ant/0.8.6-SNAPSHOT/org.jacoco.ant-0.8.6-SNAPSHOT-nodeps.jar
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]           ::          UNRESOLVED DEPENDENCIES         ::
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve]           :: org.jacoco#org.jacoco.ant;0.8.6-SNAPSHOT: not found
[ivy:resolve]           ::::::::::::::::::::::::::::::::::::::::::::::
[ivy:resolve] 
[ivy:resolve] :: USE VERBOSE OR DEBUG MESSAGE LEVEL FOR MORE DETAILS

The root cause is that we no longer have a 0.8.6-SNAPSHOT located at https://josm.openstreetmap.de/nexus/content/repositories/public/org/jacoco/org.jacoco.ant/ .

Attachments (1)

19832.patch (775 bytes) - added by taylor.smock 9 months ago.

Download all attachments as: .zip

Change History (5)

Changed 9 months ago by taylor.smock

Attachment: 19832.patch added

comment:1 Changed 9 months ago by francois2

I had the same issue, and the patch fixed it! Thanks

comment:2 Changed 9 months ago by taylor.smock

Description: modified (diff)

comment:3 Changed 9 months ago by stoecker

Resolution: fixed
Status: newclosed

In 17057/josm:

fix #19832 - fix version, remove -SNAPSHOT

comment:4 Changed 9 months ago by stoecker

Milestone: 20.09

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.