Modify

Opened 4 weeks ago

Closed 3 weeks ago

Last modified 2 weeks ago

#19828 closed defect (fixed)

`cycleway:left/right=opposite*` are invalid values

Reported by: skyper Owned by: team
Priority: normal Milestone: 20.09
Component: Internal preset Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Have a way selected
  2. Open preset Highway/Ways/Cycle Lane/Track
  3. Look at the values for cycleway:left and cycleway:right

What is the expected result?

lane, track, share_busway, shared_lane and separate

What happens instead?

Invalid opposite* values and separate is missing

Please provide any additional information below. Attach a screenshot if possible.

opposite* was not intended for cycleway:left/right=*. The wiki states this for quite some time. As it is not clear what cycleway:left=opposite_lane means without oneway=1/-1, validator warnings with fixes might not be easy. See also Talk:Key:cycleway:left#Why opposite_lane is supposed to be invalid value?

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-19 20:27:13 +0200 (Sat, 19 Sep 2020)
Revision:17046
Build-Date:2020-09-20 01:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (0)

Change History (4)

comment:1 Changed 3 weeks ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 17067/josm:

fix #19828 - Remove cycleway:left|right=opposite_lane|opposite_track|opposite, add cycleway=separate and cycleway:left|right=separate

comment:2 Changed 3 weeks ago by Klumbumbus

Milestone: 20.09

comment:3 Changed 2 weeks ago by anonymous

opposite* was not intended for cycleway:left/right=*.

The value "opposite" was not intended for cycleway:left/right=*. Not "opposite_lane" or "opposite_track".

The ​wiki states this for quite some time.

It was uncommented and undiscussed insertion two years ago.

As it is not clear what cycleway:left=opposite_lane means without oneway=1/-1,

Yes, the road with cycleway:left=opposite_lane should have oneway=yes tag. This doesn't mean this tag is invalid in all cases.

See also ​Talk:Key:cycleway:left#Why opposite_lane is supposed to be invalid value?

Interesting - it clearly states that cycleway:left=opposite_lane was deprecated by one user - Cmuelle8.

I personally can't see any problems with cycleway:left|right=opposite_lane. It is as clear as cycleway:left|right=lane, but with reversed direction.

comment:4 in reply to:  3 Changed 2 weeks ago by anonymous

Replying to anonym:

Interesting - it clearly states that cycleway:left=opposite_lane was deprecated by one user - Cmuelle8.

I personally can't see any problems with cycleway:left|right=opposite_lane. It is as clear as cycleway:left|right=lane, but with reversed direction.

Obviously you have not read the talk page. The tag value mixes two semantically different things _and_, in addition, is unclear and unintuitive about a reference direction "opposite" should be applied to. Let alone the differt meaning wrt left-hand/right-hand traffic systems.

cycleway:left=opposite_lane was deprecated from the start, i.e. from the introduction of cycleway:left key it has been made clear in the wiki that opposite* values are not to be used with that key, for the reasons mentioned on the talk page.

There has never been any intention to use all legacy cycleway values with the cycleway:* suffixed variants, _because_ the suffixed variants aimed at removing fuzziness/imprecision of the old scheme. It had been reiterating the shortcomings of the unaffixed version. That's why the documentation specified rather early which of the legacy tag values were unwanted, i.e. before these tag values were used with the suffix variants.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.