Modify

Opened 5 weeks ago

Closed 3 weeks ago

#19813 closed defect (fixed)

Multiselect presets doesn't work properly

Reported by: gaben Owned by: Don-vip
Priority: normal Milestone: 20.09
Component: Core Version:
Keywords: template_report regression Cc: simon04

Description

What steps will reproduce the problem?

  1. Add a node with a combo choice in the presets (eg. amenity=restaurant)
  2. Open preset editor, select at least two items, apply
  3. Reopen the preset

What is the expected result?

The selection remains on the items, no override possible.

What happens instead?

Next time you open the preset, anything you click on will override existing tags, so data loss is possible.

Please provide any additional information below. Attach a screenshot if possible.

Plugins not affecting this, reproducible on both Win and Linux.
If an object has only a single value, the whole list is greyed out and not modifiable by the preset.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-09-17 21:42:16 +0200 (Thu, 17 Sep 2020)
Build-Date:2020-09-18 01:30:49
Revision:17036
Relative:URL: ^/trunk

Identification: JOSM/1.5 (17036 hu) Windows 10 64-Bit
OS Build number: Windows 10 Pro for Workstations 2004 (19041)
Memory Usage: 813 MB / 1820 MB (346 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1200 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1200
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
VM arguments: [-Djava.security.manager, -Djava.security.policy=file:<java.home>\lib\security\javaws.policy, -DtrustProxy=true, -Djnlpx.home=<java.home>\bin, -Djnlpx.origFilenameArg=%UserProfile%\AppData\LocalLow\Sun\Java\Deployment\cache\6.0\31\583aa85f-56e18fc1, -Djnlpx.remove=false, -Djava.util.Arrays.useLegacyMergeSort=true, -Djnlpx.heapsize=NULL,2048m, -Djnlpx.splashport=55776, -Djnlp.application.href=https://josm.openstreetmap.de/download/josm-latest.jnlp, -Djnlpx.jvm=<java.home>\bin\javaw.exe]
Dataset consistency test: No problems found

Attachments (0)

Change History (9)

comment:1 Changed 5 weeks ago by Klumbumbus

Keywords: regression added

comment:2 in reply to:  1 Changed 3 weeks ago by Don-vip

Replying to Klumbumbus:

You added the regression keyword, do you know the last version for which it worked?

comment:3 Changed 3 weeks ago by Klumbumbus

No, I was just pretty sure that it worked in the past.
BTW: welcome back :)

comment:4 in reply to:  3 Changed 3 weeks ago by Don-vip

Replying to Klumbumbus:

BTW: welcome back :)

Thanks! I'm glad to see all of you have continued to work on JOSM during my absence :) I need to catch up with everything you did :) Nice icons!

comment:5 Changed 3 weeks ago by Klumbumbus

Last edited 3 weeks ago by Klumbumbus (previous) (diff)

comment:6 Changed 3 weeks ago by Don-vip

Milestone: 20.09
Owner: changed from team to Don-vip
Status: newassigned

comment:7 Changed 3 weeks ago by Don-vip

Cc: simon04 added

comment:8 Changed 3 weeks ago by gaben

Fun fact, just hours before your comment checked where are you or why you left :) Welcome back.

comment:9 Changed 3 weeks ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 17077/josm:

fix #19813 - see #16031 - fix selection of Multiselect presets (regression from r16687:16688)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.