Modify

Opened 2 years ago

Closed 2 weeks ago

Last modified 2 weeks ago

#16031 closed defect (fixed)

[PATCH] use_last_as_default="true" doesn't work as it supposed to

Reported by: Alexander-II Owned by: team
Priority: normal Milestone: 20.06
Component: Core Version: latest
Keywords: template_report, preset Cc:

Description

What steps will reproduce the problem?

  1. Add to JOSM https://josm.openstreetmap.de/wiki/Presets/ParkingLanes preset
  2. Download map data
  3. Select any line
  4. Click on Same on both sides of street menu item
  5. Select parallel in space type combo box
  6. Click Apply Preset
  7. Select the other line
  8. Click on Same on both sides of street menu item
  9. Look at the space type combo box

What is the expected result?

Space type field contains parallel value

What happens instead?

Space type field is empty

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2018-02-27 19:44:48 +0100 (Tue, 27 Feb 2018)
Revision:13473
Redirecting:to URL 'https://josm.openstreetmap.de/svn/trunk':
Build-Date:2018-02-27 18:47:44
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (13473 ru) Mac OS X 10.13.3
OS Build number: Mac OS X 10.13.3 (17D102)
Memory Usage: 541 MB / 2560 MB (149 MB allocated, but free)
Java version: 9.0.4+11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69677504 1280x800
Maximum Screen Size: 1280x800
Dataset consistency test: No problems found

Plugins:
+ CADTools (1007)
+ Create_grid_of_ways (33856)
+ FastDraw (33731)
+ PicLayer (34021)
+ buildings_tools (34040)
+ imagery_offset_db (33774)
+ reltoolbox (33708)
+ reverter (34036)
+ splinex (33844)
+ tageditor (33806)
+ tagging-preset-tester (33898)
+ todo (30303)
+ turnlanes-tagging (260)
+ undelete (33980)
+ utilsplugin2 (33991)
+ wikipedia (34079)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/AdvertisingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Animal_facilities&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/public_bookcase&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Simple_Indoor_Tagging&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Payment_Method_RU&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Drinks&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/contact(socialnetworks_IMs)&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Manholes&zip=1
+ https://raw.githubusercontent.com/ruosm-presets/literan-moscow/master/russian_shops.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/StreetCabinet&zip=1
+ ${HOME}/Documents/osm/josm-presets/parking_lanes.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/AdvertisingStyle&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Bench&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/RU-SubwayEntranceLabeling&zip=1

Validator rules:
+ https://raw.githubusercontent.com/zetx16/Josm-validator/master/ru-housenumber.validator.mapcss
+ http://www.openrailwaymap.org/validator/openrailwaymap.validator.mapcss
+ https://raw.githubusercontent.com/stefan-a-bauer/josm-validators/master/mtb.validator.mapcss
+ https://raw.githubusercontent.com/zetx16/Josm-HnumbValidator/master/ru-housenumber.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/MissingWeekdays&zip=1

Last errors/warnings:
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: java.io.IOException: Attribution is not loaded yet
- W: Region [WMS_BLOCK_v2] Resetting cache
- W: Region [WMTS_BLOCK_v2] Resetting cache

Attachments (1)

16031.patch (2.0 KB) - added by mikko.lukas 2 weeks ago.
Fixed multiselect and combo ignoring use_last_as_default="true" in preset XML-file

Download all attachments as: .zip

Change History (9)

comment:1 Changed 2 weeks ago by anonymous

I experience the same issue, while trying to develop my own preset.

The issue is two years old. Have anybody looked into this?

comment:2 Changed 2 weeks ago by anonymous

It seems the source code is not even handling that attribute for selects and combos.

Changed 2 weeks ago by mikko.lukas

Attachment: 16031.patch added

Fixed multiselect and combo ignoring use_last_as_default="true" in preset XML-file

comment:3 Changed 2 weeks ago by mikko.lukas

Summary: use_last_as_default="true" doesn't work as it supposed to[PATCH] use_last_as_default="true" doesn't work as it supposed to

comment:4 Changed 2 weeks ago by simon04

Resolution: fixed
Status: newclosed

In 16687/josm:

fix #16031 - Presets: make use_last_as_default="true" work (patch by mikko.lukas)

comment:5 Changed 2 weeks ago by simon04

In 16688/josm:

see #16031 - Extract ComboMultiSelect.getItemToSelect

comment:6 Changed 2 weeks ago by simon04

In 16691/josm:

see #16031 - Add ComboTest.testUseLastAsDefault

comment:7 Changed 2 weeks ago by simon04

Component: External presetCore
Milestone: 20.06

comment:8 Changed 2 weeks ago by simon04

In 16693/josm:

see #16031 - Fix ComboTest.testUseLastAsDefault

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.