Modify

Opened 2 years ago

Closed 23 months ago

#19807 closed defect (fixed)

At the second data-upload: comment- and source-text will not be updated

Reported by: wolfgang8 Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report upload comment Cc:

Description

What steps will reproduce the problem?

  1. Upload OSM-data the first time with comment- and source-text.
  2. Make some changes with the same data in the same JOSM-session.
  3. Upload OSM-data the second time and change the proposed comment- and source-text of the first upload.

What is the expected result?

The changed comment- and source-text from the secound upload should be in the changeset.

What happens instead?

The changed comment- and source-text of the first upload are stored in the changeset.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-30 12:44:04 +0200 (Thu, 30 Jul 2020)
Build-Date:2020-07-31 01:30:49
Revision:16812
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16812 de) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 985 MB / 989 MB (241 MB allocated, but free)
Java version: 1.8.0_111-b14, Oracle Corporation, Java HotSpot(TM) Client VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (35405)
+ FastDraw (35499)
+ FixAddresses (35343)
+ OpeningHoursEditor (35414)
+ PicLayer (35405)
+ alignways (35474)
+ apache-commons (35524)
+ buildings_tools (35500)
+ changeset-viewer (22)
+ ejml (35313)
+ geotools (35169)
+ graphview (35405)
+ jaxb (35092)
+ jts (35122)
+ opendata (35513)
+ reltoolbox (35529)
+ reverter (35499)
+ terracer (35499)
+ undelete (35521)
+ utilsplugin2 (35487)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewParkingFeatures&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/A.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/Communication_Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/MobilePhoneBaseStations&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml
+ <josm.pref>\xmas.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1

Map paint styles:
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Postcode&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
+ <josm.pref>\Kartenstile\addr_unit.mapcss
+ <josm.pref>\Kartenstile\ChangeFontSize.mapcss

Last errors/warnings:
- W: Already here java.net.UnknownHostException: a.tile.openstreetmap.org
- W: Already here java.net.UnknownHostException: b.tile.openstreetmap.org
- W: java.net.UnknownHostException: api.openstreetmap.org
- W: Already here java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Verbindung zum OSM-Server fehlgeschlagen. Bitte überprüfen Sie Ihre Internetverbindung.. Ursache: java.net.UnknownHostException: api.openstreetmap.org
- W: java.net.UnknownHostException: api.openstreetmap.org
- W: Already here java.net.UnknownHostException: api.openstreetmap.org
- E: java.net.UnknownHostException: api.openstreetmap.org
- W: org.openstreetmap.josm.io.OsmTransferException: Verbindung zum OSM-Server fehlgeschlagen. Bitte überprüfen Sie Ihre Internetverbindung.. Ursache: java.net.UnknownHostException: api.openstreetmap.org

Attachments (3)

Screen01.jpg (90.1 KB) - added by wolfgang8 2 years ago.
Upload-dialog
Screen02.jpg (251.5 KB) - added by wolfgang8 2 years ago.
changeset-list
Screen03.jpg (163.4 KB) - added by wolfgang8 2 years ago.

Download all attachments as: .zip

Change History (7)

Changed 2 years ago by wolfgang8

Attachment: Screen01.jpg added

Upload-dialog

Changed 2 years ago by wolfgang8

Attachment: Screen02.jpg added

changeset-list

comment:1 Changed 2 years ago by skyper

Keywords: upload comment added

Similar to #18101.

comment:2 Changed 2 years ago by anonymous

I have updated to josm version 17084.
But now, there is another issue. I fill in the changed comment- and source-text, but the note-text doesn't disappear. See attached screenshot (Screen03.jpg).

Changed 2 years ago by wolfgang8

Attachment: Screen03.jpg added

comment:3 Changed 2 years ago by wolfgang8

The problem seems to be fixed. It did not occur for a long time. (JOSM-Version 17428)

Thanks, wolfgang8

comment:4 Changed 23 months ago by wolfgang8

Resolution: fixed
Status: newclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.