Modify

Opened 3 years ago

Last modified 20 months ago

#18101 new defect

Josm doesn't send the changeset comment

Reported by: StephaneP Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report upload changeset comment history combo Cc:

Description (last modified by StephaneP)

What steps will reproduce the problem?

  1. Do some editing
  2. Open the upload window to send the changeset
  3. write a changeset comment

What is the expected result?

Josm send the changeset with the comment

What happens instead?

Josm warns me for no changeset comment. If I send the changeset there is no comment.


Please provide any additional information below. Attach a screenshot if possible.

The first changeset without the comment is here https://www.openstreetmap.org/changeset/73930545

After Josm sent the changeset without the comment, I've moved only one way, then tried to send the changeset without touching the comment, and it sent....succesfully: https://www.openstreetmap.org/changeset/73930576

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-08-27 00:41:35 +0200 (Tue, 27 Aug 2019)
Build-Date:2019-08-27 01:30:52
Revision:15323
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15323 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 1809 (17763)
Memory Usage: 5546 MB / 14564 MB (730 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080, \Display1 2560x1440
Maximum Screen Size: 2560x1440
Dataset consistency test: No problems found

Plugins:
+ DirectUpload (35041)
+ Mapillary (1.5.18)
+ OpeningHoursEditor (34977)
+ PicLayer (35104)
+ PolygonCutOut (v0.7)
+ apache-commons (34908)
+ apache-http (34908)
+ cadastre-fr (34977)
+ changeset-viewer (22)
+ continuosDownload (82)
+ contourmerge (v0.1.4)
+ ejml (35049)
+ geojson (124)
+ geotools (34908)
+ imagery-xml-bounds (35100)
+ javafx-windows
+ jaxb (35014)
+ jna (34908)
+ jts (35064)
+ measurement (35051)
+ opendata (35102)
+ photo_geotagging (34908)
+ photoadjust (34977)
+ poly (34991)
+ reverter (35084)
+ tag2link (35070)
+ tageditor (34977)
+ todo (30306)
+ turnlanes-tagging (281)
+ turnrestrictions (34977)
+ undelete (34977)
+ utilsplugin2 (35098)

Tagging presets:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/FR.zip

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/RecyclingMaterials&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/MaxspeedIcons&zip=1
- https://raw.githubusercontent.com/species/josm-preset-traffic_sign_direction/master/direction.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip
- http://kolesar.turistautak.hu/osm/opencellid/api/styles/measurements.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_features_ryg&zip=1

Last errors/warnings:
- E: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.actions.TagSourceAction
- E: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.actions.TagSourceAction
- E: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.actions.TagSourceAction
- E: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.actions.TagSourceAction
- E: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.actions.TagSourceAction
- E: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.actions.TagSourceAction
- E: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.actions.TagSourceAction
- E: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.actions.TagSourceAction
- E: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.actions.TagSourceAction
- E: java.lang.ClassNotFoundException: org.openstreetmap.josm.plugins.utilsplugin2.actions.TagSourceAction

Attachments (2)

bug_comment.png (215.3 KB) - added by StephaneP 3 years ago.
changeset comment.jpg (69.7 KB) - added by StephaneP 3 years ago.

Download all attachments as: .zip

Change History (14)

Changed 3 years ago by StephaneP

Attachment: bug_comment.png added

comment:1 Changed 3 years ago by StephaneP

Description: modified (diff)

comment:2 Changed 3 years ago by Don-vip

Keywords: upload changeset comment added

comment:3 Changed 3 years ago by StephaneP

I have to add that this is not the first time I've encountered this bug. But I can't reproduce it "on demand".

comment:4 Changed 3 years ago by Don-vip

Not an easy bug... I have no clue about what is going wrong here :(

Changed 3 years ago by StephaneP

Attachment: changeset comment.jpg added

comment:5 Changed 3 years ago by StephaneP

More strange behavior: Sometime, Josm doesn't send the correct changeset comment, but the previous one.

This is my last comment:

and my latest changeset on osm: "correction name incorrects" https://www.openstreetmap.org/changeset/79303917

It's really strange, and it seems I'm the only one encoutering this.

comment:6 Changed 3 years ago by Don-vip

Keywords: history combo added

comment:7 Changed 3 years ago by simon04

It could (just guessing) be that the text isn't set before another element is focused. Thus, typing in a new comment and hitting Ctrl+Enter immediately afterwards could trigger this behaviour.

comment:8 Changed 23 months ago by StephaneP

I got this bug today:
I moved a shop (Dzumac) but the changeset comment is empty : https://www.openstreetmap.org/changeset/101617086
And the next changeset comment is "moving Dzumac": https://www.openstreetmap.org/changeset/101631091

I don't use Ctrl+Enter to send the changeset.

I don't understand why I'm the only one encountering this bug. Maybe because I use a clipboard manager (ClipCache Pro)?

Last edited 23 months ago by StephaneP (previous) (diff)

comment:9 Changed 23 months ago by GerdP

How do you fill the changeset comment?

comment:10 in reply to:  9 Changed 23 months ago by StephaneP

Replying to GerdP:

How do you fill the changeset comment?

I write it with my keyboard (no copy paste)

comment:11 Changed 23 months ago by GerdP

I can't put my finger on it but I think I also saw this problem once many months ago. I found a CS comment that I wrote for a previous CS and I was sure that I wrote a new comment. I blamed myself, assumed that I somehow recalled the history.

Maybe #20134 is related?

comment:12 Changed 20 months ago by skyper

Related: #19630, #20604, #20690

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain team.
as The resolution will be set.
to The owner will be changed from team to the specified user.
The owner will change to StephaneP
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket
The owner will be changed from team to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.