Modify

Opened 7 weeks ago

Closed 2 weeks ago

#19761 closed defect (duplicate)

DataIntegrityProblemException: Deleted node referenced - Trying to delete node or way outside downloaded area

Reported by: anonymous Owned by: team
Priority: normal Milestone:
Component: Core Version: tested
Keywords: template_report conflict Cc:

Description

What steps will reproduce the problem?

  1. Select node
  2. Press 'Delete'

What is the expected result?

Node is deleted

What happens instead?

Error window

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-30 12:44:04 +0200 (Thu, 30 Jul 2020)
Build-Date:2020-07-31 01:30:49
Revision:16812
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16812 en_AU) Windows 10 64-Bit
OS Build number: Windows 10 Home 1909 (18363)
Memory Usage: 385 MB / 1820 MB (67 MB allocated, but free)
Java version: 1.8.0_261-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0), \Display1 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32

Dataset consistency test:
[DELETED REFERENCED] {Way id=839481937 version=1 MVT nodes=[{Node id=7833673087 version=1 V lat=33.8394809,lon=35.4852874}, {Node id=7833673085 version=1 MVD lat=33.83957734941691,lon=35.485231780985636}]} refers to deleted primitive {Node id=7833673085 version=1 MVD lat=33.83957734941691,lon=35.485231780985636}


Plugins:
+ ImproveWay (29)
+ Mapillary (1.5.23)
+ ShapeTools (1240)
+ apache-commons (35362)
+ apache-http (35092)
+ auto_tools (73)
+ buildings_tools (35500)
+ changeset-viewer (22)
+ contourmerge (v0.1.6)
+ imagery_offset_db (35405)
+ javafx-windows (35458)
+ jna (35092)
+ josm-batch-downloader (1.0.2)
+ mapathoner (1.0.7)
+ mapwithai (1.6.1)
+ measurement (35405)
+ merge-overlap (35248)
+ terracer (35499)
+ undelete (35499)
+ utilsplugin2 (35487)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/JP-Tsunami&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BAR-damage-assessment&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/JP-Desaster&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/JP-Tsunami&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/BAR-damage-assessment&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1

Last errors/warnings:
- W: Unknown remote control parameter max_zoom, skipping it
- W: Unknown remote control parameter title, skipping it
- W: Unknown remote control parameter max_zoom, skipping it
- W: Unknown remote control parameter title, skipping it
- E: Error header: Precondition failed: Node 7833673085 is still used by ways 839481937.
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=412, Error Header=<Precondition failed: Node 7833673085 is still used by ways 839481937.>
- E: Object still in use - <html><strong>Failed</strong> to delete <strong>node 7833673085</strong>. It is still referred to by way 839481937.<br>Please load the way, remove the reference to the node, and upload again.<br><br>Click <strong>Prepare conflict resolution</strong> to load them now.<br>If necessary JOSM will create conflicts which you can resolve in the Conflict Resolution dialogue.</html>
- E: Handled by bug report queue: java.lang.IllegalArgumentException: {Node id=7833673085 version=1 MVD lat=33.83957734941691,lon=35.485231780985636} is already deleted
- E: Handled by bug report queue: java.lang.IllegalArgumentException: {Node id=7833673085 version=1 MVD lat=33.83957734941691,lon=35.485231780985636} is already deleted
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=839481937 version=1 MVT nodes=[{Node id=7833673087 version=1 V lat=33.8394809,lon=35.4852874}, {Node id=7833673085 version=1 MVD lat=33.83957734941691,lon=35.485231780985636}]} (changed by the following commands: [Sequence: Conflict Resolution], [Sequence: Conflict Resolution])


=== REPORTED CRASH DATA ===
sequence_information:
 - sequence_name: Sequence: Delete
 - sequence_command: Change nodes of ‎building‎ (2 nodes)
 - sequence_index: 0
 - sequence_commands: [org.openstreetmap.josm.command.ChangeNodesCommand;org.openstreetmap.josm.command.DeleteCommand]
 - sequence_commands_descriptions: [Change nodes of ‎building‎ (2 nodes);Delete node 7833673086 ‎(33.8394952, 35.4851853)]

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (18) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Deleted node referenced: {Way id=839481937 version=1 MVT nodes=[{Node id=7833673087 version=1 V lat=33.8394809,lon=35.4852874}, {Node id=7833673085 version=1 MVD lat=33.83957734941691,lon=35.485231780985636}]} (changed by the following commands: [Sequence: Conflict Resolution], [Sequence: Conflict Resolution])
	at org.openstreetmap.josm.data.osm.Way.checkNodes(Way.java:537)
	at org.openstreetmap.josm.data.osm.Way.fireNodesChanged(Way.java:555)
	at org.openstreetmap.josm.data.osm.Way.setNodes(Way.java:66)
	at org.openstreetmap.josm.command.ChangeNodesCommand.modifyWay(ChangeNodesCommand.java:45)
	at org.openstreetmap.josm.command.AbstractNodesCommand.executeCommand(AbstractNodesCommand.java:55)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:112)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:300)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:354)
	at org.openstreetmap.josm.actions.mapmode.DeleteAction.doActionPerformed(DeleteAction.java:164)
	at org.openstreetmap.josm.actions.DeleteAction.actionPerformed(DeleteAction.java:73)
	at javax.swing.SwingUtilities.notifyAction(Unknown Source)
	at javax.swing.JComponent.processKeyBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireBinding(Unknown Source)
	at javax.swing.KeyboardManager.fireKeyboardAction(Unknown Source)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(Unknown Source)
	at javax.swing.JComponent.processKeyBindings(Unknown Source)
	at javax.swing.JComponent.processKeyEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.KeyboardFocusManager.redispatchEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(Unknown Source)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 2 weeks ago by Don-vip

Keywords: conflict added
Summary: Trying to delete node or way outside downloaded areaDataIntegrityProblemException: Deleted node referenced - Trying to delete node or way outside downloaded area

comment:2 Changed 2 weeks ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19438.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.