Modify

Opened 3 months ago

Closed 9 days ago

#19629 closed defect (fixed)

Error on startup: "JavaFX is not available. Please install OpenJFX through your package manager"

Reported by: historic_bruno Owned by: taylor.smock
Priority: normal Milestone:
Component: Plugin mapillary Version:
Keywords: template_report, javafx, fedora, linux Cc:

Description

I get this error on JOSM startup since the most recent update of Java/OpenJFX on Fedora 32. Possibly related: #19580.

What steps will reproduce the problem?

  1. Start JOSM with javafx-unixoid plugin installed (from e.g. Mapillary plugin), and openjfx-8.0.202-8.b07.fc31.i686.

What is the expected result?

JOSM starts normally.

What happens instead?

Receive the above error, and an option to disable or keep the plugin. (Keeping it doesn't seem to interfere with the Mapillary plugin functionality)

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-07-30 12:44:04 +0200 (Thu, 30 Jul 2020)
Build-Date:2020-07-31 01:30:49
Revision:16812
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16812 en) Linux Fedora 32 (Workstation Edition)
Memory Usage: 1249 MB / 7282 MB (706 MB allocated, but free)
Java version: 1.8.0_262-b10, Red Hat, Inc, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1600x900 (scaling 1.0x1.0)
Maximum Screen Size: 1600x900
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Java package: java-1.8.0-openjdk:x86_64-1.8.0.262.b10
apache-commons-compress: apache-commons-compress:noarch-1.19
apache-commons-jcs-core: apache-commons-jcs-core:noarch-2.2
apache-commons-logging: apache-commons-logging:noarch-1.2
jsonp: jsonp:noarch-1.0.4
metadata-extractor2: metadata-extractor2:noarch-2.10.1
svgsalamander: svgsalamander:noarch-1.1.2

Plugins:
+ Mapillary (1.5.23)
+ OpeningHoursEditor (35414)
+ apache-commons (35362)
+ apache-http (35092)
+ ejml (35313)
+ geotools (35169)
+ imagery_offset_db (35405)
+ javafx-unixoid (35458)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ measurement (35405)
+ opendata (35513)
+ openqa (0.1.10)
+ utilsplugin2 (35487)

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1

Last errors/warnings:
- E: JavaFX is not available
- W: Disable plugin - JavaFX is not available. Please install OpenJFX through your package manager.

Attachments (0)

Change History (3)

comment:1 Changed 3 months ago by taylor.smock

Component: CorePlugin mapillary
Keywords: javafx fedora linux added
Owner: changed from team to taylor.smock

I'll try to remember to release an experimental Mapillary build tonight without the JavaFX dependency. At that point, you would be able to remove the javafx plugin.

I run Fedora 32 at home as well, and I've never seen this, but several other people have. Since I haven't been able to reproduce, I cannot fix it.

It doesn't affect the Mapillary plugin in any noticeable way -- the only thing that is missing is having a date picker UI (see #19591 for an RFC on implementing a DatePicker interface in JOSM, to be used by JOSM and plugins like Mapillary).

I probably won't promote it to a stable release until I've tested it more (it contains code from a GSOC student, and while my testing has produced any major issues, it still needs more testing).

comment:2 Changed 3 months ago by historic_bruno

One thing to note is that I upgraded from Fedora 31.

Thanks for your work and the quick response :)

comment:3 Changed 9 days ago by taylor.smock

Resolution: fixed
Status: newclosed

Closing since the Mapillary plugin no longer depends upon JavaFX.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain taylor.smock.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.