Modify

Opened 2 months ago

Closed 8 weeks ago

#19570 closed defect (fixed)

Reduce priority of building=hangar warning due to unavoidable false positives

Reported by: mkoniecz Owned by: team
Priority: minor Milestone: 20.08
Component: Core validator Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Validate airplane museum on a former airport

What is the expected result?

No spurious warnings.

What happens instead?

"building=hangar outside of aeroway, use building=barn or building=industrial or building=warehouse instead (3)"

Please provide any additional information below. Attach a screenshot if possible.

https://www.openstreetmap.org/way/60681466

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-30 19:13:42 +0200 (Tue, 30 Jun 2020)
Revision:16731
Build-Date:2020-07-01 01:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16731 en_GB) Linux Ubuntu 20.04 LTS
Memory Usage: 667 MB / 976 MB (121 MB allocated, but free)
Java version: 11.0.7+10-post-Ubuntu-3ubuntu1, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 16x16, 32x32 -> 32x32
Java package: openjdk-11-jre:amd64-11.0.7+10-3ubuntu1
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (35500)
+ measurement (35405)
+ reverter (35499)
+ todo (30306)

Last errors/warnings:
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- E: Failed to upload note to server: 2 264 455
- E: org.openstreetmap.josm.io.OsmTransferException: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- E: Notes failed to upload: Note 2 264 455 failed: java.net.SocketException: Unexpected end of file from server
- E: org.openstreetmap.josm.io.OsmTransferException: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- E: Network exception - <html>Failed to open a connection to the remote server<br>'https://api.openstreetmap.org/api/0.6/'.<br>Please check your internet connection.</html>
- W: java.net.SocketException: Unexpected end of file from server. Cause: java.net.SocketException: Unexpected end of file from server
- E: Communication with OSM server failed - null

Attachments (0)

Change History (5)

comment:1 Changed 2 months ago by skyper

+1

A hanger on a former, but now closed, airport is still a "building=hanger" even if it is used as theater, concert hall or warehouse. Do not think this test is much useful, atm, and it can easy lead to incorrect changes of building=*.

comment:2 Changed 2 months ago by Klumbumbus

Milestone: 20.07

It was once added due to:

Many misuses of building=hangar insteaf of building=barn because it's the same word in French

see #10391. Looking at https://overpass-turbo.eu/s/Wlx this is still true. Lots of buildings are not hangars.

However I too think the warning is not so useful for the rest of the world. I suggest to move it to wiki:/Rules/FranceSpecificRules.

comment:3 Changed 2 months ago by Klumbumbus

Milestone: 20.0720.08

comment:5 Changed 8 weeks ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 16830/josm:

fix #19570, see #10391 - Move hangar outside aeroway warning to external France specific rules

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.