Modify

Opened 3 months ago

Closed 12 days ago

#19506 closed defect (fixed)

Validator: duplicate warning node connecting building and highway

Reported by: Famlam Owned by: team
Priority: normal Milestone: 20.10
Component: Core validator Version: tested
Keywords: validator Cc:

Description

What steps will reproduce the problem?

Validate attached file (part of Rotterdam)

What is the expected result?

Single warning for overlapping platform and building, for each node involved

What happens instead?

Duplicate warnings for most of the nodes

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-30 19:13:42 +0200 (Tue, 30 Jun 2020)
Build-Date:2020-07-01 01:30:51
Revision:16731
Relative:URL: ^/trunk

Identification: JOSM/1.5 (16731 nl) Windows 10 64-Bit
OS Build number: Windows 10 Home 2004 (19041)
Memory Usage: 797 MB / 1820 MB (423 MB allocated, but free)
Java version: 1.8.0_251-b08, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080 (scaling 1.0x1.0)
Maximum Screen Size: 1920x1080
Best cursor sizes: 16x16 -> 32x32, 32x32 -> 32x32
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35414)
+ imagery_offset_db (35405)
+ pt_assistant (2.1.10-80-g7d9bba3)
+ tageditor (35258)
+ turnlanes-tagging (283)
+ undelete (35499)
+ utilsplugin2 (35487)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1

Attachments (1)

JOSM duplicate warning.osm (697.6 KB) - added by Famlam 3 months ago.

Download all attachments as: .zip

Change History (6)

Changed 3 months ago by Famlam

Attachment: JOSM duplicate warning.osm added

comment:1 Changed 2 weeks ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 17088/josm:

fix #19506 - Avoid duplicate warnings on nodes connecting building and highway

comment:2 Changed 2 weeks ago by Klumbumbus

Milestone: 20.10

comment:3 Changed 2 weeks ago by Klumbumbus

Resolution: fixed
Status: closedreopened

I checked the attached file only after the commit.
I guess the touching areas of building=* and highway=platform should not at all raise a warning?

comment:4 in reply to:  3 Changed 2 weeks ago by Famlam

Replying to Klumbumbus:

I guess the touching areas of building=* and highway=platform should not at all raise a warning?

I'd say it should raise a warning. The building is actually the subway entrance, whereas the platform is a tram platform. I'd personally only connect them at the spots where it's actually an entrance to the building. But I guess this case is up for discussion, since they do physically connect. I also see the point of people who do connect them everywhere and put entrance=yes at the entrances. (This specific case is however a bit messy with the current imagery, as i.e. the roofs partially overlap as well, so I left them untouched as I couldn't improve things well enough).
I guess area mapping (thus including platforms) will always be a tricky case...

comment:5 Changed 12 days ago by Klumbumbus

Resolution: fixed
Status: reopenedclosed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.