Modify

Opened 5 weeks ago

Closed 5 weeks ago

Last modified 4 weeks ago

#19483 closed defect (wontfix)

unknown protocol: tms

Reported by: ambior@… Owned by: team
Priority: critical Milestone: 20.07
Component: Core remotecontrol Version: tested
Keywords: regression tms Cc: simon04

Description

After installing 2020-07-02: Stable release 16731 i get the error message "error:unknown process: tms
Printscreen attached.

Attachments (2)

Error JOSM.pdf (141.9 KB) - added by anonymous 5 weeks ago.
Unknown protocol tms.pdf (104.7 KB) - added by ambior@… 5 weeks ago.
Another printscreen

Download all attachments as: .zip

Change History (37)

Changed 5 weeks ago by anonymous

Attachment: Error JOSM.pdf added

comment:1 Changed 5 weeks ago by ambior@…

The error message is: unknown protocol:tms

Changed 5 weeks ago by ambior@…

Attachment: Unknown protocol tms.pdf added

Another printscreen

comment:2 Changed 5 weeks ago by Klumbumbus

Summary: Error after update to 16731unknown protocol:tms

It seems the URL of the imagery you are using is wrong or you didn't add it as tms.

comment:3 Changed 5 weeks ago by Klumbumbus

Owner: changed from team to ambior@…
Status: newneedinfo

Thanks for your report, however your ticket is incomplete and therefore not helpful in its current form.

Please add all needed information according to this list:

  • The required parts of the Status Report from your JOSM.
  • Describe what behaviour you expected.
  • Describe what did happen instead.
  • Describe if and how the issue is reproducible.
  • Add any relevant information like error messages or screenshots.

To ensure that all technical relevant information is contained, create new tickets by clicking in JOSMs Main Menu on Helpsource:trunk/resources/images/bug.png Report Bug.


comment:4 Changed 5 weeks ago by anonymous

I didn't change anything..and i can not change it...it is usually automatically loaded in Hot. I have been working all day and the past 2 years that way. Only after the update it functions no longer.
What else do you need to know? Try yourself on one of the HOT projects like for instance: https://tasks.hotosm.org/projects/8949

comment:5 Changed 5 weeks ago by Klumbumbus

Cc: simon04 added
Component: CoreCore remotecontrol
Owner: changed from ambior@… to team
Priority: normalcritical
Status: needinfonew
Version: latesttested

@simon: I think adding imagery via remote control broke in r16589 or r16587. When generating the layer the tms: is kept in the URL which makes it invalid.

2020-07-03 20:47:31.234 INFORMATION: RemoteControl received: GET /version?jsonp=checkJOSM HTTP/1.1
2020-07-03 20:47:35.095 INFORMATION: RemoteControl received: GET /version?jsonp=checkJOSM HTTP/1.1
2020-07-03 20:47:35.345 INFORMATION: RemoteControl received: GET /load_data?new_layer=true&layer_name=Boundary%20for%20task%3A%20139%20of%20TM%20Project%20%238949%20-%20Do%20not%20edit%20or%20upload&data=%3C%3Fxml%20version%3D%221.0%22%20encoding%3D%22utf8%22%3F%3E%3Cosm%20generator%3D%22JOSM%22%20upload%3D%22never%22%20version%3D%220.6%22%3E%3C%2Fosm%3E HTTP/1.1
2020-07-03 20:47:35.404 INFORMATION: Switching map mode from (none) to SelectAction
2020-07-03 20:47:35.548 INFORMATION: RemoteControl received: GET /import?new_layer=false&url=https%3A%2F%2Ftasking-manager-tm4-production-api.hotosm.org%2Fapi%2Fv2%2Fprojects%2F8949%2Ftasks%2Fqueries%2Fxml%2F%3Ftasks%3D139 HTTP/1.1
2020-07-03 20:47:35.658 INFORMATION: RemoteControl received: GET /imagery?title=tms%3Ahttps%3A%2F%2Fservices.digitalglobe.com%2Fearthservice%2Ftmsaccess%2Ftms%2F1.0.0%2FDigitalGlobe%3AImageryTileService%40EPSG%3A3857%40jpg%2F%7Bz%7D%2F%7Bx%7D%2F%7B-y%7D.jpg%3FconnectId%3D71a837e4-2609-4496-b5ea-5f0e4fdb020d&type=tms&url=tms%3Ahttps%3A%2F%2Fservices.digitalglobe.com%2Fearthservice%2Ftmsaccess%2Ftms%2F1.0.0%2FDigitalGlobe%3AImageryTileService%40EPSG%3A3857%40jpg%2F%7Bz%7D%2F%7Bx%7D%2F%7B-y%7D.jpg%3FconnectId%3D71a837e4-2609-4496-b5ea-5f0e4fdb020d HTTP/1.1
2020-07-03 20:47:35.658 WARNUNG: Unknown remote control parameter title, skipping it
2020-07-03 20:47:35.673 INFORMATION: AbstractTileSourceLayer: estimated visible tiles: 48, estimated cache size: 192
2020-07-03 20:47:35.688 INFORMATION: AbstractTileSourceLayer: estimated visible tiles: 48, estimated cache size: 192
2020-07-03 20:47:35.688 INFORMATION: AbstractTileSourceLayer: estimated visible tiles: 48, estimated cache size: 192
2020-07-03 20:47:35.688 INFORMATION: Allocate for tile source layer: 48 MB of memory. Available: 1.690 MB.
2020-07-03 20:47:35.688 WARNUNG: java.net.MalformedURLException: unknown protocol: tms
2020-07-03 20:47:35.688 WARNUNG: java.net.MalformedURLException: unknown protocol: tms
2020-07-03 20:47:35.688 WARNUNG: java.net.MalformedURLException: unknown protocol: tms
2020-07-03 20:47:35.688 WARNUNG: java.net.MalformedURLException: unknown protocol: tms
2020-07-03 20:47:35.693 WARNUNG: java.net.MalformedURLException: unknown protocol: tms
2020-07-03 20:47:35.693 WARNUNG: java.net.MalformedURLException: unknown protocol: tms

Last edited 5 weeks ago by Klumbumbus (previous) (diff)

comment:6 Changed 5 weeks ago by Klumbumbus

Summary: unknown protocol:tmsunknown protocol: tms

comment:7 Changed 5 weeks ago by anonymous

Do i get it right from the previous message that the reason has been found. If so, any idea when this will be solved? Thank you.

comment:8 Changed 5 weeks ago by Klumbumbus

Until this is fixed take the custom tms URL from the bottom of the tasking manager website and add it manually in JOSM via imagery preferences wiki:/Help/Preferences/Imagery

comment:9 Changed 5 weeks ago by Klumbumbus

Milestone: 20.07

I wonder why we don't get more bug reports. I expected we need a hotfix.

comment:10 Changed 5 weeks ago by Klumbumbus

Keywords: regression added

comment:11 Changed 5 weeks ago by ambior@…

Not all projects have a TMS + i mentioned the problem on the same moment on Slack and some tested after update on projects with tms and found the same problem...Thank you for taking care of.

comment:12 in reply to:  11 Changed 5 weeks ago by Klumbumbus

Replying to ambior@…:

Not all projects have a TMS

If it is a WMS then add a custom WMS. If it is a WMTS then add a custom WMTS. If none is given use one of the JOSM internal imageries.

comment:13 Changed 5 weeks ago by ambior@…

Sorry, i am a user. Don't know what you mean with WMS.... But thanks. For the time being i will select the image manually.

comment:14 Changed 5 weeks ago by simon04

Adding an imagery using /imagery?url=tms:http… was an undocumented and never official feature, see the documentation Help/RemoteControlCommands#imagery and the output of http://localhost:8111/ (when running JOSM with remote control enabled).

comment:15 in reply to:  14 ; Changed 5 weeks ago by Klumbumbus

Replying to simon04:

Adding an imagery using /imagery?url=tms:http… was an undocumented and never official feature

OK, do you want to add compatibility or should we create issues at https://github.com/hotosm/tasking-manager/ and https://github.com/hotosm/osm-tasking-manager2 to adapt the tasking managers?

the output of http://localhost:8111/ (when running JOSM with remote control enabled).

"type" should not be listed there as optional parameter though.

comment:16 in reply to:  15 Changed 5 weeks ago by Klumbumbus

Replying to Klumbumbus:

"type" should not be listed there as optional parameter though.

Or the default value documented if the type parameter is missing.

comment:17 Changed 5 weeks ago by simon04

Resolution: fixed
Status: newclosed

In 16734/josm:

fix #19483 - Remote control /imagery: parse extended URL (parse imagery type from URL)

comment:18 Changed 5 weeks ago by simon04

Updated documentation: Help/RemoteControlCommands

comment:19 in reply to:  15 Changed 5 weeks ago by simon04

Replying to Klumbumbus:

OK, do you want to add compatibility

Yes, since the undocumented behaviour was around for years (maybe since 2012 or 2010).

comment:20 Changed 5 weeks ago by Klumbumbus

You forgot the colon?

comment:22 Changed 5 weeks ago by Klumbumbus

Milestone: 20.0720.06

Great, lets release a hotfix tomorrow.

comment:23 in reply to:  22 Changed 5 weeks ago by stoecker

Resolution: fixed
Status: closedreopened

I'm not convinced this is a good idea. We'll have to support such bad API in future if we document it now. I'd rather say contact HOT and tell them to fix their server.

comment:24 Changed 5 weeks ago by simon04

Actually it's the same URL format that we display in Help/Preferences/Imagery.

comment:25 in reply to:  24 ; Changed 5 weeks ago by stoecker

Replying to simon04:

Actually it's the same URL format that we display in Help/Preferences/Imagery.

Yes. But this is JOSM internal and even in JOSM mainly deprecated.

comment:26 in reply to:  25 Changed 5 weeks ago by stoecker

Replying to stoecker:

Replying to simon04:

Actually it's the same URL format that we display in Help/Preferences/Imagery.

Yes. But this is JOSM internal and even in JOSM mainly deprecated.

P.S. A long time ago this was the TMS input format. Now it is legacy (I'm pretty sure it was legacy already before RemoteControl allowed adding imagery).

comment:27 Changed 5 weeks ago by stoecker

I removed the documentation.

comment:28 Changed 5 weeks ago by stoecker

Milestone: 20.0620.07

No hotfix.

comment:29 Changed 5 weeks ago by stoecker

Resolution: fixed
Status: reopenedclosed

In 16735/josm:

fix #19483 - don't support undocumented behaviour

comment:31 Changed 5 weeks ago by simon04

Resolution: fixedwontfix

comment:32 Changed 5 weeks ago by stoecker

In 16736/josm:

see #19483 - fix tests

comment:33 Changed 5 weeks ago by stoecker

In 16739/josm:

see #19483 - typo

comment:34 Changed 4 weeks ago by skyper

Keywords: tms added

comment:35 Changed 4 weeks ago by Klumbumbus

Ticket #19522 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.