Modify

Opened 4 days ago

Closed 4 days ago

Last modified 4 days ago

#19455 closed defect (fixed)

Validation issue: sport=curling

Reported by: bugs@… Owned by: team
Priority: normal Milestone: 20.06
Component: Core validator Version:
Keywords: template_report Cc:

Description (last modified by Klumbumbus)

What steps will reproduce the problem?

  1. Tag object with sport=curling
  2. Check validation errors

What is the expected result?

Sport=curling should be accepted https://wiki.openstreetmap.org/wiki/Tag:sport%3Dcurling

What happens instead?

Value 'curling' for key 'sport' is unknown, maybe one of [cycling, surfing]
Test: Tag checker
Java: org.openstreetmap.josm.data.validation.tests.TagChecker

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-02 08:27:29 +0200 (Tue, 02 Jun 2020)
Revision:16538
Build-Date:2020-06-02 11:11:35
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16538 en) Linux Ubuntu 20.04 LTS
Memory Usage: 2644 MB / 4096 MB (1522 MB allocated, but free)
Java version: 11.0.7+10-post-Ubuntu-3ubuntu1, Ubuntu, OpenJDK 64-Bit Server VM
Look and Feel: javax.swing.plaf.metal.MetalLookAndFeel
Screen: :0.0 3840x2160
Maximum Screen Size: 3840x2160
Java package: openjdk-11-jre:amd64-11.0.7+10-3ubuntu1
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
fonts-noto: fonts-noto:all-20200323-1
VM arguments: [--add-modules=java.scripting,java.sql, -Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.23)
+ MicrosoftStreetside (35248)
+ QuickLabel (18)
+ SimplifyArea (35405)
+ apache-commons (35362)
+ apache-http (35092)
+ buildings_tools (35474)
+ colorscheme (35405)
+ conflation (0.6.5)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ geochat (35405)
+ javafx-unixoid (35458)
+ jna (35092)
+ jts (35122)
+ measurement (35405)
+ reverter (35474)
+ tageditor (35258)
+ todo (30306)
+ turnlanes-tagging (283)
+ undelete (35474)
+ utilsplugin2 (35476)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1

Validator rules:
+ https://raw.githubusercontent.com/stefan-a-bauer/josm-validators/master/mtb.validator.mapcss

Last errors/warnings:
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-ffmpeg-57.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-ffmpeg-58.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-57.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-ffmpeg-56.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: java.lang.UnsatisfiedLinkError: <josm.userdata>/plugins/javafx/libavplugin-56.so: libgstreamer-lite.so: cannot open shared object file: No such file or directory
- E: Error header: Version mismatch: Provided 2, server had: 3 of Way 777883398
- E: Conflicts detected - <html>Uploading <strong>failed</strong> because the server has a newer version of one<br>of your nodes, ways, or relations.<br>The conflict is caused by the <strong>way</strong> with id <strong>777,883,398</strong>,<br>the server has version 3, your version is 2.<br><br>Click <strong>Synchronize way 777,883,398 only</strong> to synchronize the conflicting primitive only.<br>Click <strong>Synchronize entire dataset</strong> to synchronize the entire local dataset with the server.<br>Click <strong>Cancel</strong> to abort and continue editing.<br></html>
- E: Handled by bug report queue: java.lang.IllegalStateException: Called endChange before beginChange
- E: org.openstreetmap.josm.io.OsmApiException: ResponseCode=500
- E: Internal Server Error - <html>The OSM server<br>'https://api.openstreetmap.org/api/0.6/'<br>reported an internal server error.<br>This is most likely a temporary problem. Please try again later.</html>

Attachments (1)

Screenshot_20200629_101514.png (61.1 KB) - added by bugs.mdarwin.ca 4 days ago.
Validation errors screenshot

Download all attachments as: .zip

Change History (5)

Changed 4 days ago by bugs.mdarwin.ca

Validation errors screenshot

comment:1 Changed 4 days ago by Klumbumbus

Component: CoreCore validator
Description: modified (diff)

comment:2 Changed 4 days ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 16729/josm:

fix #19455 - ignore sport=curling for now

comment:3 Changed 4 days ago by Klumbumbus

Milestone: 20.06

comment:4 Changed 4 days ago by Klumbumbus

Follow up in #19457

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.