Modify

Opened 13 days ago

Closed 12 days ago

#19441 closed defect (wontfix)

Impossible to search by negative element id

Reported by: blackboxlogic@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Open JOSM
  2. Add an element (or many elements)
  3. Try to find one of them by its element ID (which is negative)
  4. Search for id:-1234, every element gets selected
  5. Search for id:"-1234", get error: "Search Expression is not valid: Range of primitive ids expected"

What is the expected result?

I expect searching for id:-1234 will select the element with id -1234

What happens instead?

Searching for id:-1234 seems to select every element
Searching for id:"-1234" produces error: "Search Expression is not valid: Range of primitive ids expected"

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-04-06 02:17:07 +0200 (Mon, 06 Apr 2020)
Revision:16239
Build-Date:2020-04-06 00:18:43
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16239 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1909 (18363)
Memory Usage: 2048 MB / 2048 MB (861 MB allocated, but free)
Java version: 13.0.2+8, AdoptOpenJDK, OpenJDK 64-Bit Server VM
Screen: \Display0 3840x2160
Maximum Screen Size: 3840x2160
Program arguments: [%UserProfile%\Desktop\Maine_E911_Roads-shp\Maine_E911_Roads.osm]
Dataset consistency test: No problems found

Plugins:
+ apache-commons (35362)
+ apache-http (35092)
+ ejml (35313)
+ geotools (35169)
+ javafx-windows (35375)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ measurement (35405)
+ opendata (35405)
+ pbf (35446)
+ poly (35248)
+ todo (30306)
+ touchscreenhelper (35248)
+ undelete (35474)
+ utilsplugin2 (35476)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- %UserProfile%\Desktop\Render a Field as Text.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1

Last errors/warnings:
- W: extended font config - overriding 'filename.Mongolian_Baiti=monbaiti.ttf' with 'MONBAITI.TTF'
- W: java.util.zip.ZipException: zip END header not found
- W: PluginException: : org.openstreetmap.josm.plugins.PluginException: Invalid jar file '<josm.pref>\plugins\javafx-windows.jar.new'
- W: Failed to scan file 'javafx-windows.jar.new' for plugin information. Skipping.
- W: Failed to install plugin '<josm.pref>\plugins\javafx-windows.jar' from temporary download file '<josm.pref>\plugins\javafx-windows.jar.new'. zip END header not found: java.util.zip.ZipException: zip END header not found
- E: Skipping to the next rule, because of an error:
- E: org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.ParseException: Encountered " "|z" "|z "" at line 32, column 16.

Attachments (0)

Change History (2)

comment:1 Changed 12 days ago by skyper

You can not search for internal JOSM ids so far, e.g. all new objects have id:0, atm.

comment:2 Changed 12 days ago by stoecker

Resolution: wontfix
Status: newclosed

There is no such thing as a negative element ID. Negative IDs are only used in the JOSM fileformat and they aren't fixed in any way but dynamic (even if we tried to minimize impact of changing IDs when saving).

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.