Modify

Opened 4 weeks ago

Closed 4 weeks ago

#19385 closed defect (fixed)

pdfimport crash on importing pdf

Reported by: kevin-b-er@… Owned by: team
Priority: normal Milestone:
Component: Plugin pdfimport Version: tested
Keywords: template_report logging ivy Cc:

Description

What steps will reproduce the problem?

  1. Try to use Imagery > Import PDF file
  2. Crash as PDF starts to import.

What is the expected result?

PDF imports

What happens instead?

JOSM reports a crash in the plugin the import stops

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-06-02 08:27:29 +0200 (Tue, 02 Jun 2020)
Revision:16538
Build-Date:2020-06-02 11:11:35
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16538 en) Windows 10 64-Bit
OS Build number: Windows 10 Pro 2004 (19041)
Memory Usage: 222 MB / 4080 MB (130 MB allocated, but free)
Java version: 14.0.1+7, Oracle Corporation, OpenJDK 64-Bit Server VM
Look and Feel: com.sun.java.swing.plaf.windows.WindowsLookAndFeel
Screen: \Display0 1920x1080, \Display1 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ pdfimport (35448)

Last errors/warnings:
- W: extended font config - overriding 'filename.Myanmar_Text=mmrtext.ttf' with 'MMRTEXT.TTF'
- W: extended font config - overriding 'filename.Mongolian_Baiti=monbaiti.ttf' with 'MONBAITI.TTF'
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory. Cause: java.lang.ClassNotFoundException: org.apache.commons.logging.LogFactory
- W: Warning - <html>JOSM could not find information about the following plugin:<ul><li>pdfimport</li></ul>The plugin is not going to be loaded.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: Thread-3 (62)
java.lang.NoClassDefFoundError: org/apache/commons/logging/LogFactory
	at org.apache.pdfbox.util.PDFStreamEngine.<clinit>(PDFStreamEngine.java:70)
	at org.openstreetmap.josm.plugins.pdfimport.LoadPdfDialog.loadPDF(LoadPdfDialog.java:500)
	at org.openstreetmap.josm.plugins.pdfimport.LoadPdfDialog.access$800(LoadPdfDialog.java:41)
	at org.openstreetmap.josm.plugins.pdfimport.LoadPdfDialog$3.run(LoadPdfDialog.java:251)
	at org.openstreetmap.josm.plugins.pdfimport.LoadPdfDialog$11.run(LoadPdfDialog.java:449)
	at java.base/java.lang.Thread.run(Thread.java:832)
Caused by: java.lang.ClassNotFoundException: org.apache.commons.logging.LogFactory
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:435)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:589)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:522)
	... 6 more

Note that the version of JOSM was the one that was downloaded on 14-Jun-2020 and was acquired from the download page as "josm-tested.jar (version 16538)" Java is from the same date's OpenJDK download.

Attachments (0)

Change History (1)

comment:1 Changed 4 weeks ago by simon04

Keywords: logging ivy added
Resolution: fixed
Status: newclosed

Regression of r16397 (removal of commons-logging).

Fixed in [o35494:35495]. Please update your plugins one Plugins contains the version 35494.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.