Modify

Opened 11 months ago

Closed 8 months ago

#19359 closed defect (invalid)

Javafx / Mapillary fails to work os macOS on Java 14

Reported by: Stereo Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin javafx Version:
Keywords: template_report Cc: taylor.smock

Description

What steps will reproduce the problem?

  1. Install a Java 14 build with the Mapillary and javafx-osx plugins
  2. Download an area

What is the expected result?

Mapillary images can be displayed as usual

What happens instead?

  • Panels on the right are grey. Toggling the layers panel makes them show up
  • Mapillary images can't be displayed

Please provide any additional information below. Attach a screenshot if possible.

Revision:16569
Is-Local-Build:true
Build-Date:2020-06-07 23:35:35

Identification: JOSM/1.5 (16569 SVN en_GB) Mac OS X 10.15.5
OS Build number: Mac OS X 10.15.5 (19F101)
Memory Usage: 666 MB / 8192 MB (109 MB allocated, but free)
Java version: 14.0.1+7, Oracle Corporation, OpenJDK 64-Bit Server VM
Look and Feel: com.apple.laf.AquaLookAndFeel
Screen: Display 69733632 1680x1050
Maximum Screen Size: 1680x1050
VM arguments: [-Djava.library.path=${HOME}/Documents/code/josm/appimageoutput/JOSM.app/Contents/app:${HOME}/Documents/code/josm/appimageoutput/JOSM.app/Contents/MacOS, -Djava.launcher.path=${HOME}/Documents/code/josm/appimageoutput/JOSM.app/Contents/MacOS]
Dataset consistency test: No problems found

Plugins:
+ AddrInterpolation (35405)
+ CommandLine (35405)
+ Create_grid_of_ways (35405)
+ ImportImagePlugin (35248)
+ Mapillary (1.5.23)
+ MovementAlert (1511141840)
+ OpeningHoursEditor (35414)
+ PicLayer (35405)
+ RelationDissolve (0.2.0)
+ alignways (35474)
+ apache-commons (35362)
+ apache-http (35092)
+ areaselector (359)
+ austriaaddresshelper (57)
+ buildings_tools (35474)
+ changeset-viewer (22)
+ conflation (0.6.5)
+ continuosDownload (91)
+ contourmerge (v0.1.6)
+ ejml (35313)
+ geotools (35169)
+ gridify (1588746833)
+ http2 (35427)
+ imagery-xml-bounds (35313)
+ javafx-osx (35375)
+ jaxb (35092)
+ jna (35092)
+ jogl (1.2.3)
+ jts (35122)
+ log4j (35092)
+ opendata (35405)
+ openqa (0.1.9)
+ poly (35248)
+ public_transport (35405)
+ reltoolbox (35405)
+ reverter (35487)
+ splinex (35454)
+ terracer (35327)
+ todo (30306)
+ undelete (35474)
+ utilsplugin2 (35487)
+ wikipedia (1.1.4)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BicycleJunction&preset&zip=1
+ http://osmtools.de/josm/steps.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historic_Stone&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&preset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Towers&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Golf_Course&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/PublicTransportOneClick&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Heritage&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Historical_Objects&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/public_bookcase&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Stolpersteine&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://gitlab.com/k127/josm-presets/raw/master/diplomatic.xml
+ https://josm.openstreetmap.de/josmfile?page=Presets/Playground_Equipment&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lit&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Modified&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Power&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PowerMapping&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/BesideTheRoad_Speed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/TreeCrownDiameter&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&style&zip=1
- https://github.com/simon04/coloured-addresses.mapcss/raw/master/dist/coloured-addresses.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Suburb&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Cycleways&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&style&zip=1
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PTStops&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleRoofTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SimpleBuildingTags&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/HiDPISupport&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NumberedCycleNodeNetworks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NumberedWalkingNodeNetworks&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/AddressValidator&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/NewHighwayColors&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/iD&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Potlach2_access&zip=1

Validator rules:
+ http://www.openrailwaymap.org/validator/openrailwaymap.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/GermanySpecific&zip=1
+ http://www.openrailwaymap.org/validator/de-openrailwaymap.validator.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Rules/MissingWeekdays&zip=1
+ https://raw.githubusercontent.com/nlehuby/transport_mapcss/master/transport.validator.mapcss

Last errors/warnings:
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/images?bbox=6.1367044%2C49.5728744%2C6.1581396%2C49.5842112&client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&_next_page_token=eyJhZnRlciI6WzE1OTAxNjYxMzIwMDAsIm95elNqMm1ad0hJWUlaUHh3MzRka2ciXX0%3D!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/image_detections?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&bbox=6.1453936%2C49.575732%2C6.1535161%2C49.5800279&layers=trafficsigns&sort_by=key!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/images?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&_next_page_token=eyJhZnRlciI6WzE1NjgyMjI1ODcwMDAsIlJCVnBLM0FjcUNiTjFJOGc4QXl0SHciXX0%3D&bbox=6.1453936%2C49.575732%2C6.1535161%2C49.5800279!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/image_detections?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&bbox=6.1463431%2C49.5762682%2C6.1524988%2C49.5795238&layers=trafficsigns&sort_by=key!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/images?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&bbox=6.1463431%2C49.5762682%2C6.1524988%2C49.5795238!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException

Attachments (0)

Change History (8)

comment:1 Changed 11 months ago by Stereo

Disabling JavaFX in the Mapillary preferences solves the grey panel, but images still can't be displayed.

Last errors/warnings:
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/image_detections?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&bbox=6.1461036%2C49.5758687%2C6.150739%2C49.5782249&layers=trafficsigns&sort_by=key!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/images?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&bbox=6.1365354%2C49.5730265%2C6.1578343%2C49.5838522!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/image_detections?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&bbox=6.1365354%2C49.5730265%2C6.1578343%2C49.5838522&layers=trafficsigns&sort_by=key!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/images?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&bbox=6.1381137%2C49.5734939%2C6.1566555%2C49.5829182!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/image_detections?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&bbox=6.1381137%2C49.5734939%2C6.1566555%2C49.5829182&layers=trafficsigns&sort_by=key!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException

comment:2 in reply to:  1 Changed 11 months ago by GhostFoxSledgehammer

Replying to Stereo:

Disabling JavaFX in the Mapillary preferences solves the grey panel, but images still can't be displayed.

I don't know about JavaFX issue but Images are probably not being downloaded, so this may be due to servers being down or a connection issue. Is this still happening?

comment:3 Changed 11 months ago by Stereo

The same URLs worked in my browser, and the error message didn't indicate a server being down or a connection issue, so I can't blame the network or server for that.

comment:4 Changed 11 months ago by skyper

Cc: taylor.smoke added

comment:5 Changed 11 months ago by taylor.smock

Cc: taylor.smock added; taylor.smoke removed

comment:6 Changed 11 months ago by taylor.smock

@Stereo: I was unable to reproduce the URL InterruptedException issue. Is that recurring reliably? If so, what is the actual download bbox? I used 49.5758687;6.1461036;49.5782249;6.150739 for osm-download.bounds. (Tunnel de Howald)

The grey panels are a known issue, and I've traced it back to a call in the JDK -- I haven't had the time to delve further into the issue, but up to that point, everything looks "ok".

I've just had way too many issues with JavaFX, unfortunately. I'm planning on removing JavaFX as a dependency for Mapillary, but I have to either code a date picker or use a library (I'm looking at one of the Java date pickers written for swing, and when I make a decision, I'll probably create a plugin that wraps that library).

comment:7 Changed 10 months ago by Stereo

Hey Taylor, sorry for taking a while to try this again.

Yeah, I can reproduce this pretty reliably on a recent macOS build like https://files.skowron.eu/JOSM.zip:

- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/images?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&bbox=6.1162614%2C49.5939739%2C6.1181547%2C49.5948576!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException
- W: Could not read from URL https://a.mapillary.com/v3/image_detections?client_id=UTZhSnNFdGpxSEFFREUwb01GYzlXZzpjNGViMzQxMTIzMjY0MjZm&bbox=6.1162614%2C49.5939739%2C6.1181547%2C49.5948576&layers=trafficsigns&sort_by=key!: java.io.IOException: java.lang.InterruptedException. Cause: java.lang.InterruptedException

On JavaFX : https://openjdk.java.net/jeps/343, which we will use in the future, says that it won't be supported, so I think your date picker idea is good.

comment:8 Changed 8 months ago by taylor.smock

Resolution: invalid
Status: newclosed

I'm resolving this to invalid since Mapillary no longer uses javafx.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.