Modify

Opened 5 weeks ago

Closed 5 weeks ago

Last modified 5 weeks ago

#19339 closed enhancement (duplicate)

Validator complains about Su,PH

Reported by: jengelh@… Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: opening_hours holiday Cc:

Description

JOSM validator outputs for way 222036947, which has set
opening_hours="Jun: Mo-Sa 08:00-18:30; Jun: Su,PH 09:00-18:00"

TestError [tester=org.openstreetmap.josm.data.validation.tests.OpeningHourTest@51242aa6, code=2901, message=Opening hours syntax]
"Holiday after weekday at line 1, column 36"

Please improve this error message. Why is it a problem to have PH share the exact hours of a named weekday like Su?

Attachments (0)

Change History (3)

comment:1 Changed 5 weeks ago by skyper

Keywords: opening_hours holiday added
Resolution: duplicate
Status: newclosed
Type: defectenhancement

Closed as duplicate of #18899.
In a strict way, PH needs to be before <weekday>. The setting for a more relaxed validation is missing so far.

comment:2 in reply to:  1 ; Changed 5 weeks ago by Klumbumbus

Replying to skyper:

In a strict way, PH needs to be before <weekday>.

Is this a new rule? Even osmwiki:/Key:opening_hours lists as example: Mo-Su,PH 15:00-03:00; easter -2 days off

comment:3 in reply to:  2 Changed 5 weeks ago by skyper

Replying to Klumbumbus:

Replying to skyper:

In a strict way, PH needs to be before <weekday>.

Is this a new rule? Even osmwiki:/Key:opening_hours lists as example: Mo-Su,PH 15:00-03:00; easter -2 days off

No, it is a very old rule. We are just used to tag with the "relaxed" evaluation which is usually documented.

Your example above shows the other case, too, time span over midnight, which leads to a similar warning.

00:00-03:00,15:00-24:00; easter -2 days off would be the correct example in strict mode. If you want to add the days: PH,Mo-Su 00:00-03:00,15:00-24:00; easter -2 days off

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.