Modify

Opened 11 months ago

Closed 6 months ago

Last modified 6 months ago

#18899 closed enhancement (fixed)

option to specify the strictness of OpeningHoursParser

Reported by: skyper Owned by: team
Priority: normal Milestone: 20.08
Component: Core validator Version:
Keywords: template_report opening_hours Cc: SimonPoole

Description (last modified by skyper)

OpeningHoursParser has two different level of strictness for certain rules but there is no option to choose between them. In fact, atm only strict mode is used.

E.g.

  • Holiday after weekday for Mo-Fr 09:00-12:00; Sa,Su,PH off
  • Opening hours syntax - End time earlier than start time for Mo-Fr 05:15-00:30; Sa 07:30-01:30; Su,PH off

See https://github.com/simonpoole/OpeningHoursParser/issues/39, https://github.com/simonpoole/OpeningHoursParser/issues/40 and https://github.com/simonpoole/OpeningHoursParser/issues/5

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-03-09 01:20:59 +0100 (Mon, 09 Mar 2020)
Revision:16102
Build-Date:2020-03-09 02:30:51
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (1)

2020-08-03-194513.png (51.8 KB) - added by simon04 6 months ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 11 months ago by skyper

Description: modified (diff)

comment:2 Changed 11 months ago by skyper

Description: modified (diff)

comment:3 Changed 11 months ago by Don-vip

Cc: SimonPoole added

comment:4 Changed 10 months ago by Don-vip

Summary: option to specifify the strictness of OpeningHoursParseroption to specify the strictness of OpeningHoursParser

comment:5 Changed 8 months ago by skyper

Ticket #19339 has been marked as a duplicate of this ticket.

comment:6 Changed 6 months ago by simon04

Resolution: fixed
Status: newclosed

In 16832/josm:

fix #18899 - OpeningHoursParser: allow to specify strictness in preferences

Changed 6 months ago by simon04

Attachment: 2020-08-03-194513.png added

comment:7 Changed 6 months ago by simon04

Milestone: 20.08


Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.