Modify

#19303 closed defect (duplicate)

Mapillary plugin not working

Reported by: d.a.solow@… Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-04-06 02:17:07 +0200 (Mon, 06 Apr 2020)
Revision:16239
Build-Date:2020-04-06 00:18:43
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16239 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1903 (18362)
Memory Usage: 672 MB / 2048 MB (336 MB allocated, but free)
Java version: 11.0.6+10-LTS, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Screen: \Display0 3840x2160
Maximum Screen Size: 3840x2160
VM arguments: [--add-modules=java.scripting,java.sql, --add-exports=java.desktop/com.apple.eawt=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.spi=ALL-UNNAMED, --add-exports=java.desktop/com.sun.imageio.plugins.jpeg=ALL-UNNAMED, --add-exports=javafx.graphics/com.sun.javafx.application=ALL-UNNAMED, --add-exports=jdk.deploy/com.sun.deploy.config=ALL-UNNAMED, --add-opens=java.base/java.lang=ALL-UNNAMED, --add-opens=java.base/java.nio=ALL-UNNAMED, --add-opens=java.base/jdk.internal.loader=ALL-UNNAMED, --add-opens=java.base/jdk.internal.ref=ALL-UNNAMED, --add-opens=java.desktop/javax.imageio.spi=ALL-UNNAMED, --add-opens=java.desktop/javax.swing.text.html=ALL-UNNAMED, --add-opens=java.prefs/java.util.prefs=ALL-UNNAMED, -Djava.util.Arrays.useLegacyMergeSort=true, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop,jdk.jsobject, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-reads=java.base=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop,ALL-UNNAMED, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop,ALL-UNNAMED, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop]
Dataset consistency test: No problems found

Plugins:
+ Mapillary (1.5.22)
+ apache-commons (35362)
+ apache-http (35092)
+ buildings_tools (35405)
+ javafx-windows (35375)
+ jna (35092)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/COVID-19&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/INT-1-preset.xml
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/US.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/WifiHotspots&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/Presets_Hafen.xml

Last errors/warnings:
- E: Region [TMS_BLOCK_v2] Failure getting from disk, key = OpenStreetMap Carto (Standard):https://{switch:a,b,c}.tile.openstreetmap.org/{zoom}/{x}/{y}.png/15/9681/12329
- E: Region [TMS_BLOCK_v2] Failure getting from disk, key = OpenStreetMap Carto (Standard):https://{switch:a,b,c}.tile.openstreetmap.org/{zoom}/{x}/{y}.png/15/9680/12329
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: jdk/swing/interop/SwingInterOpUtils. Cause: java.lang.ClassNotFoundException: jdk.swing.interop.SwingInterOpUtils
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: jdk/swing/interop/SwingInterOpUtils
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: jdk/swing/interop/SwingInterOpUtils
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: jdk/swing/interop/SwingInterOpUtils
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: jdk/swing/interop/SwingInterOpUtils
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: jdk/swing/interop/SwingInterOpUtils
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: jdk/swing/interop/SwingInterOpUtils
- W: Warning - <html>JOSM could not find information about the following plugins:<ul><li>apache-commons</li><li>Mapillary</li><li>buildings_tools</li><li>javafx-windows</li><li>jna</li><li>apache-http</li></ul>The plugins are not going to be loaded.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: JavaFX Application Thread (147) of JOSM
java.lang.NoClassDefFoundError: jdk/swing/interop/SwingInterOpUtils
	at com.sun.javafx.embed.swing.newimpl.JFXPanelInteropN.postEvent(JFXPanelInteropN.java:36)
	at javafx.embed.swing.JFXPanel.invokeOnClientEDT(JFXPanel.java:930)
	at javafx.embed.swing.JFXPanel$HostContainer.setEmbeddedScene(JFXPanel.java:972)
	at com.sun.javafx.tk.quantum.EmbeddedScene.setStage(EmbeddedScene.java:122)
	at com.sun.javafx.tk.quantum.GlassStage.setScene(GlassStage.java:94)
	at com.sun.javafx.tk.quantum.EmbeddedStage.setScene(EmbeddedStage.java:62)
	at javafx.stage.Window$12.invalidated(Window.java:1085)
	at javafx.beans.property.BooleanPropertyBase.markInvalid(BooleanPropertyBase.java:110)
	at javafx.beans.property.BooleanPropertyBase.set(BooleanPropertyBase.java:145)
	at javafx.stage.Window.setShowing(Window.java:1174)
	at javafx.stage.Window.show(Window.java:1189)
	at com.sun.javafx.stage.EmbeddedWindow.show(EmbeddedWindow.java:71)
	at javafx.embed.swing.JFXPanel.setSceneImpl(JFXPanel.java:326)
	at javafx.embed.swing.JFXPanel.setScene(JFXPanel.java:296)
	at org.openstreetmap.josm.plugins.javafx.gui.JavaFxWrapper.initFX(JavaFxWrapper.java:71)
	at com.sun.javafx.application.PlatformImpl.lambda$runLater$10(PlatformImpl.java:428)
	at java.base/java.security.AccessController.doPrivileged(Native Method)
	at com.sun.javafx.application.PlatformImpl.lambda$runLater$11(PlatformImpl.java:427)
	at com.sun.glass.ui.InvokeLaterDispatcher$Future.run(InvokeLaterDispatcher.java:96)
	at com.sun.glass.ui.win.WinApplication._runLoop(Native Method)
	at com.sun.glass.ui.win.WinApplication.lambda$runLoop$3(WinApplication.java:174)
	at java.base/java.lang.Thread.run(Thread.java:834)

Attachments (0)

Change History (1)

comment:1 Changed 18 months ago by taylor.smock

Resolution: duplicate
Status: newclosed

Closed as duplicate of #19044.
I've known about this issue for awhile. I just haven't found a way to get it working with OpenWebStart.

As a workaround, you can either use Oracle Java 8 (I don't recommend this) or use the .jar file downloaded from the website with Java 11+.

Sorry about this,
Taylor

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.