Modify

Opened 3 months ago

Closed 2 months ago

Last modified 3 weeks ago

#19240 closed defect (fixed)

NPE in MultipolygonCache.clear

Reported by: simon04 Owned by: team
Priority: minor Milestone: 20.06
Component: Core Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Start JOSM via IDE

I seem to have won the race condition lottery. Couldn't reproduce.

Please provide any additional information below. Attach a screenshot if possible.

Revision:16408
Is-Local-Build:true
Build-Date:2020-05-14 22:57:11

Identification: JOSM/1.5 (16408 SVN en) Linux Arch Linux
Memory Usage: 210 MB / 3972 MB (134 MB allocated, but free)
Java version: 14+36, AdoptOpenJDK, OpenJDK 64-Bit Server VM
Screen: :0.0 3840x2160
Maximum Screen Size: 3840x2160
Program arguments: [--set=expert=true, --set=iso.dates=true, --set=debug.edt-checker.enable=true, --set=tls.add-missing-certificates=false]

Plugins:
+ apache-commons (35362)
+ pdfimport (35448)
2020-05-14 23:25:46.140 SEVERE: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.NullPointerException. Cause: java.util.concurrent.ExecutionException: java.lang.NullPointerException. Cause: java.lang.NullPointerException
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:89)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:905)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:705)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.base/java.lang.reflect.Method.invoke(Method.java:564)
	at com.intellij.uiDesigner.snapShooter.SnapShooter.main(SnapShooter.java:58)
Caused by: java.util.concurrent.ExecutionException: java.lang.NullPointerException
	at java.base/java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.base/java.util.concurrent.FutureTask.get(FutureTask.java:191)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:78)
	... 8 more
Caused by: java.lang.NullPointerException
	at java.base/java.util.concurrent.ConcurrentHashMap.replaceNode(ConcurrentHashMap.java:1111)
	at java.base/java.util.concurrent.ConcurrentHashMap.remove(ConcurrentHashMap.java:1102)
	at org.openstreetmap.josm.data.osm.visitor.paint.relations.MultipolygonCache.clear(MultipolygonCache.java:110)
	at org.openstreetmap.josm.tools.Territories.initializeInternalData(Territories.java:169)
	at org.openstreetmap.josm.tools.Territories.initialize(Territories.java:123)
	at org.openstreetmap.josm.gui.MainInitialization.lambda$parallelInitializationTasks$6(MainInitialization.java:114)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:11)
	at java.base/java.util.concurrent.FutureTask.run$$$capture(FutureTask.java:264)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1130)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:630)
	at java.base/java.lang.Thread.run(Thread.java:832)

Attachments (1)

19240.patch (1.0 KB) - added by GerdP 3 months ago.
do we need more than this?

Download all attachments as: .zip

Change History (9)

Changed 3 months ago by GerdP

Attachment: 19240.patch added

do we need more than this?

comment:2 Changed 2 months ago by simon04

Ticket #19344 has been marked as a duplicate of this ticket.

comment:3 Changed 2 months ago by simon04

Milestone: 20.06

comment:4 Changed 2 months ago by simon04

Let's give it a try!

comment:5 Changed 2 months ago by GerdP

Resolution: fixed
Status: newclosed

In 16552/josm:

fix #19240: NPE in MultipolygonCache.clear

  • synchronize initializeInternalData()
  • avoid to call MultipolygonCache.clear() with null

comment:6 Changed 2 months ago by Klumbumbus

On Jenkins it turned the NPE into a awt.HeadlessException.

comment:7 Changed 2 months ago by GerdP

https://josm.openstreetmap.de/jenkins/job/JOSM-Integration/4749/jdk=JDK8/testReport/junit/org.openstreetmap.josm.tools/TerritoriesTestIT/testUtilityClass/

Yes, but I think that's a completely different issue. Is it intended that the postprocessor installed by the sds plugin is called in this situation?

comment:8 Changed 3 weeks ago by simon04

Ticket #19477 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.