Modify

Opened 7 months ago

Closed 7 months ago

Last modified 6 months ago

#19237 closed enhancement (fixed)

Add more icons to text box context menu

Reported by: skyper Owned by: team
Priority: trivial Milestone: 20.05
Component: Core Version:
Keywords: template_report text box context menu icon Cc:

Description

What steps will reproduce the problem?

  1. Open a tagging preset with text or combo box
  2. Right click on the text box

What is the expected result?

A menu with at least five icons

What happens instead?

Only two icons present

Please provide any additional information below. Attach a screenshot if possible.

This is the default text box context menu used in several places.
We already have more icons in JOSM which just have to be added in source. See text box context menu where I already added the icons.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-05-13 15:24:14 +0200 (Wed, 13 May 2020)
Revision:16407
Build-Date:2020-05-14 01:30:47
URL:https://josm.openstreetmap.de/svn/trunk

Attachments (0)

Change History (6)

comment:1 Changed 7 months ago by simon04

Resolution: fixed
Status: newclosed

In 16409/josm:

fix #19237 - Add more icons to text box context menu

resources/images/cut.svg taken from https://commons.wikimedia.org/wiki/File:Gnome-edit-cut.svg

Remove TextContextualPopupMenu#iconCache since ImageProvider uses caching as well.

comment:3 Changed 6 months ago by simon04

It seems that source:trunk/scripts/geticons.pl has to be adapted.

comment:4 Changed 6 months ago by stoecker

A special case like this is easier solved when you add /* ICON */ in front of the icon strings which are used in non-standard functions. The script should only detect the common cases.

P.S. With hidden path there is also a /* ICON(preferences/) */ form.

comment:5 Changed 6 months ago by simon04

In 16420/josm:

see #19237 - Add /*ICON*/ markers

comment:6 Changed 6 months ago by simon04

Milestone: 20.05

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.