Modify

Opened 7 weeks ago

Closed 6 days ago

#19088 closed defect (duplicate)

NoClassDefFoundError: java/sql/Time

Reported by: heinrich.wegener@… Owned by: jBeata
Priority: normal Milestone:
Component: Plugin openstreetcam Version:
Keywords: template_report java11 Cc:

Description

What steps will reproduce the problem?

  1. PlugIn OpenStreetPhoto added
  2. restart
  3. ERROR

What is the expected result?

no error

What happens instead?

error

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-04-06 02:17:07 +0200 (Mon, 06 Apr 2020)
Revision:16239
Build-Date:2020-04-06 00:18:43
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (16239 en) Linux Ubuntu 18.04.4 LTS
Memory Usage: 230 MB / 2048 MB (85 MB allocated, but free)
Java version: 11.0.6+10-post-Ubuntu-1ubuntu118.04.1, Ubuntu, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900
Maximum Screen Size: 1600x900
Java package: openjdk-11-jre:amd64-11.0.6+10-1ubuntu1~18.04.1
WebStart package: icedtea-netx:amd64-1.8-0ubuntu8~18.04
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-20ubuntu0.1
libcommons-compress-java: libcommons-compress-java:all-1.18-1~18.04
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20171026-2
liboauth-signpost-java: liboauth-signpost-java:all-1.2.1.2-1.5
VM arguments: [--add-reads=java.base=ALL-UNNAMED,java.desktop, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,jdk.jsobject, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop, -Dicedtea-web.bin.name=javaws, -Dicedtea-web.bin.location=/usr/lib/icedtea-web/bin/javaws]

Plugins:
+ OpenStreetCam (307)
+ apache-commons (35362)
+ photo_geotagging (35405)
+ photoadjust (35405)

Last errors/warnings:
- E: Handled by bug report queue: java.lang.NoClassDefFoundError: java/sql/Time. Cause: java.lang.ClassNotFoundException: java.sql.Time


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: pool-1-thread-1 (49)
java.lang.NoClassDefFoundError: java/sql/Time
	at com.google.gson.Gson.<init>(Gson.java:241)
	at com.google.gson.GsonBuilder.create(GsonBuilder.java:545)
	at org.openstreetmap.josm.plugins.openstreetcam.service.photo.OpenStreetCamService.createGson(OpenStreetCamService.java:56)
	at org.openstreetmap.josm.plugins.openstreetcam.service.BaseService.<init>(BaseService.java:40)
	at org.openstreetmap.josm.plugins.openstreetcam.service.photo.OpenStreetCamService.<init>(OpenStreetCamService.java:46)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.SearchServiceHandler.<init>(SearchServiceHandler.java:58)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.ServiceHandler.<init>(ServiceHandler.java:48)
	at org.openstreetmap.josm.plugins.openstreetcam.handler.ServiceHandler.<clinit>(ServiceHandler.java:53)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.<init>(DetectionTypeContent.java:31)
	at org.openstreetmap.josm.plugins.openstreetcam.gui.details.filter.DetectionTypeContent.<clinit>(DetectionTypeContent.java:27)
	at org.openstreetmap.josm.plugins.openstreetcam.OpenStreetCamPlugin.lambda$new$0(OpenStreetCamPlugin.java:82)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ClassNotFoundException: java.sql.Time
	at java.base/java.net.URLClassLoader.findClass(URLClassLoader.java:471)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:588)
	at org.openstreetmap.josm.plugins.PluginClassLoader.loadClass(PluginClassLoader.java:73)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
	... 14 more

Attachments (0)

Change History (3)

comment:1 Changed 7 weeks ago by skyper

Component: CorePlugin openstreetcam
Owner: changed from team to jBeata
Summary: PlugIn OpenStreetPhoto added -> restart -> ERRORNoClassDefFoundError: java/sql/Time

comment:2 Changed 6 weeks ago by simon04

Keywords: java11 added

Relates to r15167.

comment:3 Changed 6 days ago by Klumbumbus

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17673.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jBeata.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.