Modify

Opened 10 years ago

Closed 10 years ago

#1888 closed defect (worksforme)

crash when trying to change colours

Reported by: safado Owned by: framm
Priority: major Milestone:
Component: unspecified Version: latest
Keywords: Cc:

Description

Hi,

It seems to be my error day... :)

(I have deleted my completed .josm preferences directory and started from the scratch without the openstreetbugs plug-in)

I wanted to personalise the coulours and opened "preferences" -->clicked "colours" (german version: "Farben") --> clicked on the line "background" (german version: "Hintergrund"). At this time the following error showed up:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1181
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1181
Last Changed Date: 2008-12-26 00:34:48 +0100 (Fri, 26 Dec 2008)

java.lang.NullPointerException

at org.openstreetmap.josm.tools.ColorHelper.color2html(ColorHelper.java:33)
at org.openstreetmap.josm.gui.preferences.ColorPreference$2.getTableCellRendererComponent(ColorPreference.java:116)
at javax.swing.JTable$AccessibleJTable.getAccessibleChild(JTable.java:5334)
at javax.swing.JTable$AccessibleJTable.getAccessibleAt(JTable.java:5713)
at javax.swing.JTable$AccessibleJTable.valueChanged(JTable.java:5236)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:187)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:167)
at javax.swing.DefaultListSelectionModel.fireValueChanged(DefaultListSelectionModel.java:214)
at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:408)
at javax.swing.DefaultListSelectionModel.changeSelection(DefaultListSelectionModel.java:417)
at javax.swing.DefaultListSelectionModel.setSelectionInterval(DefaultListSelectionModel.java:441)
at javax.swing.JTable.changeSelectionModel(JTable.java:1634)
at javax.swing.JTable.changeSelection(JTable.java:1680)
at javax.swing.plaf.basic.BasicTableUI$Handler.makeSelectionChange(BasicTableUI.java:1012)
at javax.swing.plaf.basic.BasicTableUI$Handler.adjustFocusAndSelection(BasicTableUI.java:968)
at javax.swing.plaf.basic.BasicTableUI$Handler.mousePressed(BasicTableUI.java:922)
at javax.swing.plaf.basic.BasicTableUI$MouseInputHandler.mousePressed(BasicTableUI.java:752)
at apple.laf.CUIAquaTable$MouseInputHandler.mousePressed(CUIAquaTable.java:73)
at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:222)
at java.awt.AWTEventMulticaster.mousePressed(AWTEventMulticaster.java:221)
at java.awt.Component.processMouseEvent(Component.java:5599)
at javax.swing.JComponent.processMouseEvent(JComponent.java:3135)
at java.awt.Component.processEvent(Component.java:5367)
at java.awt.Container.processEvent(Container.java:2010)
at java.awt.Component.dispatchEventImpl(Component.java:4068)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4256)
at java.awt.LightweightDispatcher.processMouseEvent(Container.java:3933)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3866)
at java.awt.Container.dispatchEventImpl(Container.java:2054)
at java.awt.Window.dispatchEventImpl(Window.java:1801)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:180)
at java.awt.Dialog$1.run(Dialog.java:535)
at java.awt.Dialog$2.run(Dialog.java:565)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:563)
at java.awt.Component.show(Component.java:1302)
at java.awt.Component.setVisible(Component.java:1255)
at org.openstreetmap.josm.actions.PreferencesAction.actionPerformed(PreferencesAction.java:73)
at org.openstreetmap.josm.tools.PlatformHookOsx.invoke(PlatformHookOsx.java:52)
at $Proxy0.handlePreferences(Unknown Source)
at com.apple.eawt.Application$5.run(Application.java:438)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

Once more: have fun!
safado

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by safado

The error seems only to occur when you click on the column "Farben" and not when clicking on the column "Name".

comment:2 Changed 10 years ago by stoecker

Sorry. Cannot reproduce this. Everything I tried works fine.

The version 1180 did a big break, so this is not really your problem :-) Thought above problem must have another reason.

comment:3 Changed 10 years ago by anonymous

Resolution: worksforme
Status: newclosed

No answer. Closing.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.