Modify

Opened 10 years ago

Closed 10 years ago

#1887 closed defect (worksforme)

crash when loading gpx file

Reported by: safado Owned by: framm
Priority: major Milestone:
Component: unspecified Version: latest
Keywords: Cc:

Description

Right after clicking ok on the gpx file loading dialog this error message showed up:

Path: trunk
URL: http://josm.openstreetmap.de/svn/trunk
Repository Root: http://josm.openstreetmap.de/svn
Repository UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Revision: 1181
Node Kind: directory
Last Changed Author: stoecker
Last Changed Rev: 1181
Last Changed Date: 2008-12-26 00:34:48 +0100 (Fri, 26 Dec 2008)

java.lang.NullPointerException

at org.openstreetmap.josm.plugins.osb.OsbPlugin.layerAdded(OsbPlugin.java:216)
at org.openstreetmap.josm.gui.MapView.addLayer(MapView.java:166)
at org.openstreetmap.josm.Main.addLayer(Main.java:349)
at org.openstreetmap.josm.actions.NewAction.actionPerformed(NewAction.java:22)
at org.openstreetmap.josm.Main.editLayer(Main.java:356)
at org.openstreetmap.josm.gui.MapView.zoomToEditLayerBoundingBox(MapView.java:387)
at org.openstreetmap.josm.gui.MapView$1.componentResized(MapView.java:89)
at java.awt.Component.processComponentEvent(Component.java:5428)
at java.awt.Component.processEvent(Component.java:5382)
at java.awt.Container.processEvent(Container.java:2010)
at java.awt.Component.dispatchEventImpl(Component.java:4068)
at java.awt.Container.dispatchEventImpl(Container.java:2068)
at java.awt.Component.dispatchEvent(Component.java:3903)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:463)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:180)
at java.awt.Dialog$1.run(Dialog.java:535)
at java.awt.Dialog$2.run(Dialog.java:565)
at java.security.AccessController.doPrivileged(Native Method)
at java.awt.Dialog.show(Dialog.java:563)
at javax.swing.JOptionPane.showOptionDialog(JOptionPane.java:843)
at javax.swing.JOptionPane.showConfirmDialog(JOptionPane.java:771)
at javax.swing.JOptionPane.showConfirmDialog(JOptionPane.java:734)
at javax.swing.JOptionPane.showConfirmDialog(JOptionPane.java:696)
at org.openstreetmap.josm.tools.BugReportExceptionHandler.uncaughtException(BugReportExceptionHandler.java:63)
at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:983)
at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:978)
at apple.awt.CToolkit$EventQueueExceptionHandler.handle(CToolkit.java:87)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:585)
at java.awt.EventDispatchThread.handleException(EventDispatchThread.java:382)
at java.awt.EventDispatchThread.processException(EventDispatchThread.java:288)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:280)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

Thanks and have fun,
safado

Attachments (0)

Change History (3)

comment:1 Changed 10 years ago by safado

After clicking "ok" on the error report screen a new screen showed up and informed me that the error was originating from the "openstreetbugs" plug-in. As I have updated to the newest plugin in before I guess it is still ok to have the error reported. My apologies if I should be mistaken. safado

comment:2 Changed 10 years ago by stoecker

Sorry. Could not reproduce. Please add better description (and if possible try redownloading all plugins).

comment:3 Changed 10 years ago by anonymous

Resolution: worksforme
Status: newclosed

No answer. Closing.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain framm.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.