Modify

Opened 9 months ago

Closed 9 months ago

#18858 closed defect (fixed)

data/projection/custom-epsg file is not included in local jar

Reported by: joerg.schulze@… Owned by: Don-vip
Priority: critical Milestone: 20.03
Component: Core Version: latest
Keywords: template_report build regression projection Cc:

Description

What steps will reproduce the problem?

  1. Start the Application

What is the expected result?

Show MainWindow

What happens instead?

MessageBox (Exception) appears

Please provide any additional information below. Attach a screenshot if possible.

Revision:16030
Is-Local-Build:true
Build-Date:2020-03-04 13:34:29

Identification: JOSM/1.5 (16030 SVN de) Linux Arch Linux
Memory Usage: 2048 MB / 30688 MB (2005 MB allocated, but free)
Java version: 10.0.2+13, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 3840x2160
Maximum Screen Size: 3840x2160
VM arguments: [-Djosm.restart=true]
Program arguments: [--debug]

Last errors/warnings:
- E: Handled by bug report queue: java.lang.ExceptionInInitializerError. Ursache: org.openstreetmap.josm.tools.JosmRuntimeException: java.io.IOException: Das Öffnen eines Eingabestroms für die Resource 'resource://data/projection/custom-epsg' ist fehlgeschlagen.. Ursache: java.io.IOException: Das Öffnen eines Eingabestroms für die Resource 'resource://data/projection/custom-epsg' ist fehlgeschlagen.


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
java.lang.ExceptionInInitializerError
	at org.openstreetmap.josm.gui.preferences.projection.ProjectionPreference.registerProjectionChoice(ProjectionPreference.java:262)
	at org.openstreetmap.josm.gui.preferences.projection.ProjectionPreference.registerProjectionChoice(ProjectionPreference.java:284)
	at org.openstreetmap.josm.gui.preferences.projection.ProjectionPreference.<clinit>(ProjectionPreference.java:83)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:898)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:703)
Caused by: org.openstreetmap.josm.tools.JosmRuntimeException: java.io.IOException: Das Öffnen eines Eingabestroms für die Resource 'resource://data/projection/custom-epsg' ist fehlgeschlagen.
	at org.openstreetmap.josm.data.projection.Projections.<clinit>(Projections.java:175)
	... 6 more
Caused by: java.io.IOException: Das Öffnen eines Eingabestroms für die Resource 'resource://data/projection/custom-epsg' ist fehlgeschlagen.
	at org.openstreetmap.josm.io.CachedFile.lambda$getInputStream$0(CachedFile.java:231)
	at java.base/java.util.Optional.orElseThrow(Optional.java:397)
	at org.openstreetmap.josm.io.CachedFile.getInputStream(CachedFile.java:231)
	at org.openstreetmap.josm.io.CachedFile.getContentReader(CachedFile.java:258)
	at org.openstreetmap.josm.data.projection.Projections.loadProjectionDefinitions(Projections.java:301)
	at org.openstreetmap.josm.data.projection.Projections.<clinit>(Projections.java:170)
	... 6 more

Attachments (0)

Change History (10)

comment:1 Changed 9 months ago by GerdP

see #18845, please try

ant clean dist 

comment:2 Changed 9 months ago by GerdP

I can reproduce the problem unless a manual removement of the \core\data directory.

comment:3 Changed 9 months ago by Klumbumbus

I get the same error even after ant clean dist. I have no \core\data directory anymore. (IIRC I deleted it manually as the svn update removed it from the repository but didn't delete it.)

comment:4 Changed 9 months ago by GerdP

Ah, yes, I can reproduce it also now. In Eclipse the missing file is build in core\bin\data\projection\custom-epsg.
But ant epsg doesn't create it.

comment:5 Changed 9 months ago by Klumbumbus

Now I understand your comment:2. With can you meant can't? :)

comment:6 Changed 9 months ago by GerdP

I am pretty sure that the program worked once I removed the directory and ran ant clean dist again, but it no longer works and the missing file is not generated during the build.

comment:7 Changed 9 months ago by GerdP

Seems this works

ant clean dist
ant dist

I assume there is a timing problem.

comment:8 Changed 9 months ago by Don-vip

Keywords: build regression projection added
Milestone: 20.03
Owner: changed from team to Don-vip
Priority: normalcritical
Status: newassigned

comment:9 Changed 9 months ago by Don-vip

Summary: Beim Start der Anwendung ( "josm --debug" ) tritt Exception aufdata/projection/custom-epsg file is not included in local jar

comment:10 Changed 9 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 16036/josm:

see #18845, fix #18858 - fix ant build

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.