Modify

Opened 3 months ago

Closed 3 months ago

#18844 closed defect (duplicate)

Bug on start

Reported by: antonmenov@… Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. Start the program

What is the expected result?

Program starts

What happens instead?

Error window

Please provide any additional information below. Attach a screenshot if possible.

Maybe plug-ins?

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-03-02 00:54:04 +0100 (Mon, 02 Mar 2020)
Revision:15994
Build-Date:2020-03-02 02:31:01
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15994 en_GB) Windows 10 64-Bit
OS Build number: Windows 10 Home 1909 (18363)
Memory Usage: 480 MB / 1908 MB (258 MB allocated, but free)
Java version: 13.0.1+9, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080

Plugins:
+ ImproveOsm (195)
+ ImproveWay
+ OpeningHoursEditor
+ RoadSigns
+ auto_tools
+ mapwithai
+ tageditor
+ turnlanes-tagging
+ utilsplugin2

Tagging presets:
+ https://github.com/kendzi/Simple3dBuildingsPreset/releases/download/0.9_2018-05-08/s3db-preset.zip
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_preset_JOSM/master/EE.zip

Map paint styles:
+ https://raw.githubusercontent.com/yopaseopor/traffic_signs_style_JOSM/master/Styles_Traffic_signs_EUR_OR.zip
+ https://josm.openstreetmap.de/josmfile?page=Styles/MapWithAI&zip=1

Last errors/warnings:
- W: extended font config - overriding 'filename.Kalinga=kalinga.ttf' with 'KALINGA.TTF'
- W: extended font config - overriding 'filename.Iskoola_Pota=iskpota.ttf' with 'ISKPOTA.TTF'
- W: extended font config - overriding 'filename.Shruti=shruti.ttf' with 'SHRUTI.TTF'
- W: extended font config - overriding 'filename.Raavi=raavi.ttf' with 'RAAVI.TTF'
- W: extended font config - overriding 'filename.Gautami=gautami.ttf' with 'GAUTAMI.TTF'
- W: extended font config - overriding 'filename.Vrinda=vrinda.ttf' with 'VRINDA.TTF'
- W: extended font config - overriding 'filename.Kartika=kartika.ttf' with 'KARTIKA.TTF'
- W: extended font config - overriding 'filename.Latha=latha.ttf' with 'LATHA.TTF'
- W: Failed to parse external taginfo data at https://josm.openstreetmap.de/remote/geofabrik-index-v1-nogeom.json: Invalid token=EOF at (line no=6119, column no=2252, offset=359085). Expected tokens are: [CURLYOPEN, SQUAREOPEN, STRING, NUMBER, TRUE, FALSE, NULL]
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException. Cause: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException. Cause: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException. Cause: java.lang.ClassNotFoundException: ch.poole.openinghoursparser.ParseException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:89)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:903)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:703)
Caused by: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException
	at java.base/java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.base/java.util.concurrent.FutureTask.get(FutureTask.java:191)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:78)
	... 3 more
Caused by: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException
	at java.base/java.lang.Class.getDeclaredConstructors0(Native Method)
	at java.base/java.lang.Class.privateGetDeclaredConstructors(Class.java:3138)
	at java.base/java.lang.Class.getConstructor0(Class.java:3343)
	at java.base/java.lang.Class.getConstructor(Class.java:2152)
	at org.openstreetmap.josm.data.validation.OsmValidator.addTest(OsmValidator.java:161)
	at org.openstreetmap.josm.data.validation.OsmValidator.<clinit>(OsmValidator.java:186)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:11)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:830)
Caused by: java.lang.ClassNotFoundException: ch.poole.openinghoursparser.ParseException
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:602)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
	... 12 more

Attachments (0)

Change History (1)

comment:1 Changed 3 months ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18833.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.