Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#18833 closed defect (fixed)

JOSM fails to start: NoClassDefFoundError: ch/poole/openinghoursparser

Reported by: EdzeronK Owned by: team
Priority: blocker Milestone: 20.03
Component: Core Version:
Keywords: template_report openinghoursparser regression build Cc:

Description

What steps will reproduce the problem?

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-03-02 00:54:04 +0100 (Mon, 02 Mar 2020)
Revision:15994
Build-Date:2020-03-02 02:31:01
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15994 fr) Linux Debian GNU/Linux 10 (buster)
Memory Usage: 545 MB / 3998 MB (310 MB allocated, but free)
Java version: 11.0.6+10-post-Debian-1deb10u1, Debian, OpenJDK 64-Bit Server VM
Screen: :0.0 2560x1440
Maximum Screen Size: 2560x1440
Java package: openjdk-11-jre:amd64-11.0.6+10-1~deb10u1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-22
libcommons-compress-java: libcommons-compress-java:all-1.18-2
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20181227-1
VM arguments: [-Djosm.restart=true, -Djosm.dir.name=JOSM-latest, -Djava.net.useSystemProxies=true]

Plugins:
+ OpeningHoursEditor
+ apache-commons
+ cadastre-fr
+ changeset-viewer
+ contourmerge
+ ejml
+ epci-fr (35092)
+ geotools
+ jaxb (35092)
+ jts
+ opendata
+ print
+ reverter
+ turnrestrictions
+ utilsplugin2

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/public_bookcase&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Crafts&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/PublicTransportV2&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Incline&zip=1

Validator rules:
- https://github.com/Jungle-Bus/transport_mapcss/raw/gh-pages/transport.validator.zip
+ https://josm.openstreetmap.de/josmfile?page=Rules/SuspisciousSwimming_Pool&zip=1

Last errors/warnings:
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException. Cause : java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException. Cause : java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException. Cause : java.lang.ClassNotFoundException: ch.poole.openinghoursparser.ParseException


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:89)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:903)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:703)
Caused by: java.util.concurrent.ExecutionException: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException
	at java.base/java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.base/java.util.concurrent.FutureTask.get(FutureTask.java:191)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:78)
	... 3 more
Caused by: java.lang.NoClassDefFoundError: ch/poole/openinghoursparser/ParseException
	at java.base/java.lang.Class.getDeclaredConstructors0(Native Method)
	at java.base/java.lang.Class.privateGetDeclaredConstructors(Class.java:3137)
	at java.base/java.lang.Class.getConstructor0(Class.java:3342)
	at java.base/java.lang.Class.getConstructor(Class.java:2151)
	at org.openstreetmap.josm.data.validation.OsmValidator.addTest(OsmValidator.java:161)
	at org.openstreetmap.josm.data.validation.OsmValidator.<clinit>(OsmValidator.java:186)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:11)
	at java.base/java.util.concurrent.FutureTask.run(FutureTask.java:264)
	at java.base/java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1128)
	at java.base/java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:628)
	at java.base/java.lang.Thread.run(Thread.java:834)
Caused by: java.lang.ClassNotFoundException: ch.poole.openinghoursparser.ParseException
	at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:581)
	at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
	at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
	... 12 more

Attachments (0)

Change History (9)

comment:1 Changed 3 months ago by skyper

Component: CoreCore validator
Priority: normalblocker

There should have been no nightly builds as Donvip wrote on 18140#comment:23.

Please, stay with yesterdays nightly (r15969).

Last edited 3 months ago by skyper (previous) (diff)

comment:2 Changed 3 months ago by skyper

Component: Core validatorCore
Keywords: openinghoursparser added

comment:3 Changed 3 months ago by skyper

Ticket #18839 has been marked as a duplicate of this ticket.

comment:4 Changed 3 months ago by skyper

Ticket #18836 has been marked as a duplicate of this ticket.

comment:5 Changed 3 months ago by skyper

Ticket #18840 has been marked as a duplicate of this ticket.

comment:6 Changed 3 months ago by simon04

Summary: Error from start session JOSMJOSM fails to start: NoClassDefFoundError: ch/poole/openinghoursparser

comment:7 Changed 3 months ago by simon04

Ticket #18844 has been marked as a duplicate of this ticket.

comment:8 Changed 3 months ago by skyper

Resolution: fixed
Status: newclosed

fixed with r16002

comment:9 Changed 3 months ago by Don-vip

Keywords: regression build added
Milestone: 20.03

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.