Modify

Opened 3 months ago

Last modified 3 months ago

#18814 new defect

[Patch] Unique strings for msgid (was: Avoid the translation of strings never shown to any user)

Reported by: Hb--- Owned by: stoecker
Priority: trivial Milestone:
Component: Core Version: latest
Keywords: i18n Cc:

Description

Currently some strings are marked for translation which will never be shown to any user. They should be taken away from the translation workload.

In #9110 the translation of plural forms was discussed and fixed with r6507. Afterwards the focus shifted and it was noticed that the unneeded singular forms were grammatically wrong. The correct, but unneeded strings were then placed with r6679.

Planned solution:

  1. Replace the unneeded singular strings with their plural partners. Modern translation software will recognize these as Non-unique segments aka duplicates. So only one translation is needed.

The effect of this can be seen on the source string You are about to combine {0} objects, but the following tags are used conflictingly:<br/>{1}If these objects are combined, the resulting object may have unwanted tags.<br/>If you want to continue, you are shown a dialog to fix the conflicting tags.<br/><br/>Do you want to continue?
This string is a duplicate of two plural forms

  1. Comment in java source to inform about the equal strings. This comment is scraped daily from the source and placed as comment in the translation source files.

The already present comments are like
for correct i18n of plural forms - see #9110
or
I18n: plural form for objects, but value < 2 not possible!
with the later one being closer to the solution.

Unneeded strings:

Combine {0} way

Merge {0} node

You are about to launch {0} browser window.<br>This may both clutter your screen with browser windows<br>and take some time to finish.

Dupe into {0} node

You moved more than {0} element. Moving a large number of elements is often an error.
Really move them?

Split way {0} into {1} part

Remove "{0}" for {1} object

Set {0}={1} for {2} object

Deleted {0} tags for {1} object

Set {0} tags for {1} object

You are about to combine {1} object, which is part of {0} relation:<br/>{2}Combining these objects may break this relation. If you are unsure, please cancel this operation.<br/>If you want to continue, you are shown a dialog to decide how to adapt the relation.<br/><br/>Do you want to continue?

You are about to open <b>{0}</b> different relation editor simultaneously.<br/>Do you want to continue?

Attachments (1)

CombinePrimitiveResolverDialog.patch (1.5 KB) - added by Hb--- 3 months ago.

Download all attachments as: .zip

Change History (4)

comment:1 Changed 3 months ago by stoecker

Resolution: invalid
Status: assignedclosed

PLease learn a bit more about I18n and the translation system used by JOSM before requesting such changes and commenting a lot of tickets.

Changed 3 months ago by Hb---

comment:2 in reply to:  1 Changed 3 months ago by Hb---

Resolution: invalid
Status: closedreopened
Summary: Avoid the translation of strings never shown to any user[Patch] Unique strings for msgid (was: Avoid the translation of strings never shown to any user)

Replying to stoecker:

... commenting a lot of tickets.

The comments are partly withdrawn with 18596 (your comment).

Replying to stoecker from ticket/18643

Can you please stop to ask for changes which violate our guidelines.

The points you claim are now written down in the guidelines: DevelopersGuide/StyleGuide Diff 36-34

I18n always has to have full strings independent from the possibly used numbers in the code, ...

The patch to achieve this is attached.

comment:3 Changed 3 months ago by Hb---

Owner: changed from Hb--- to stoecker
Status: reopenednew

Modify Ticket

Change Properties
Set your email in Preferences
Action
as new The owner will remain stoecker.
as The resolution will be set.
to The owner will be changed from stoecker to the specified user.
The owner will change to Hb---
as duplicate The resolution will be set to duplicate.The specified ticket will be cross-referenced with this ticket
The owner will be changed from stoecker to anonymous.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.