Modify

Opened 3 months ago

Closed 3 months ago

Last modified 3 months ago

#18759 closed defect (fixed)

AssertionError when launching JOSM

Reported by: nkamapper Owned by: simon04
Priority: normal Milestone: 20.02
Component: Core mappaint Version:
Keywords: template_report regression mapcss zoom range Cc: simon04

Description

What steps will reproduce the problem?

  1. Launching JOSM, both Web Start and MacOS package

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-23 19:11:30 +0100 (Sun, 23 Feb 2020)
Build-Date:2020-02-23 19:47:25
Revision:15915
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15915 en_GB) Mac OS X 10.15.3
OS Build number: Mac OS X 10.15.3 (19D76)
Memory Usage: 599 MB / 1820 MB (206 MB allocated, but free)
Java version: 1.8.0_241-b07, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 69732864 1440x900
Maximum Screen Size: 1440x900
VM arguments: [-Djava.library.path=/private/var/folders/gw/1x4vl20s0f7_fqtqdj_z7t740000gn/T/AppTranslocation/C90C2B94-88CA-4633-9A02-46AFD7F509C6/d/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DApplicationDirectory=${HOME}/Applications, -DAutosavedInformationDirectory=${HOME}/Library/Autosave Information, -DDesktopDirectory=${HOME}/Desktop, -DDownloadsDirectory=${HOME}/Downloads, -DMoviesDirectory=${HOME}/Movies, -DMusicDirectory=${HOME}/Music, -DPicturesDirectory=${HOME}/Pictures, -DSharedPublicDirectory=${HOME}/Public, -DSystemLibraryDirectory=/Library, -DSystemApplicationSupportDirectory=/Library/Application Support, -DSystemCachesDirectory=/Library/Caches, -DSystemApplicationDirectory=/Applications, -DSystemUserDirectory=/Users, -DUserHome=${HOME}, -DSandboxEnabled=true, -DLaunchModifierFlags=0, -DLaunchModifierFlagCapsLock=false, -DLaunchModifierFlagShift=false, -DLaunchModifierFlagControl=false, -DLaunchModifierFlagOption=false, -DLaunchModifierFlagCommand=false, -DLaunchModifierFlagNumericPad=false, -DLaunchModifierFlagHelp=false, -DLaunchModifierFlagFunction=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]

Plugins:
+ PicLayer
+ SeaChart
+ SeaMapEditor
+ apache-commons
+ conflation
+ ejml
+ geotools
+ imagery-xml-bounds
+ jaxb (35092)
+ jts
+ opendata
+ reverter
+ todo
+ utilsplugin2

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1
+ https://raw.githubusercontent.com/OpenNauticalChart/josm/master/INT-1-preset.xml

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://raw.githubusercontent.com/OpenSeaMap/josm/master/INT1_Seamark.mapcss
- http://osm.wzh.be/josm/entur_1.0.mapcss

Last errors/warnings:
- E: Failed to locate image 'https://www.riksantikvaren.no/extension/riksantikvaren/design/internetsite/images/logo_na.png'
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.AssertionError. Cause: java.util.concurrent.ExecutionException: java.lang.AssertionError. Cause: java.lang.AssertionError


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: main (1)
org.openstreetmap.josm.tools.JosmRuntimeException: java.util.concurrent.ExecutionException: java.lang.AssertionError
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:89)
	at org.openstreetmap.josm.gui.MainApplication.mainJOSM(MainApplication.java:903)
	at org.openstreetmap.josm.gui.MainApplication$3.processArguments(MainApplication.java:276)
	at org.openstreetmap.josm.gui.MainApplication.main(MainApplication.java:703)
Caused by: java.util.concurrent.ExecutionException: java.lang.AssertionError
	at java.util.concurrent.FutureTask.report(FutureTask.java:122)
	at java.util.concurrent.FutureTask.get(FutureTask.java:192)
	at org.openstreetmap.josm.spi.lifecycle.Lifecycle.initialize(Lifecycle.java:78)
	... 3 more
Caused by: java.lang.AssertionError
	at org.openstreetmap.josm.gui.mappaint.mapcss.Selector$OptimizedGeneralSelector.fromLevel(Selector.java:725)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.zoom(MapCSSParser.java:1191)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.selector(MapCSSParser.java:1102)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.child_selector(MapCSSParser.java:950)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.selectors(MapCSSParser.java:937)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.rule(MapCSSParser.java:905)
	at org.openstreetmap.josm.gui.mappaint.mapcss.parsergen.MapCSSParser.sheet(MapCSSParser.java:889)
	at org.openstreetmap.josm.gui.mappaint.mapcss.MapCSSStyleSource.loadStyleSource(MapCSSStyleSource.java:439)
	at org.openstreetmap.josm.gui.mappaint.MapPaintStyles.readFromPreferences(MapPaintStyles.java:293)
	at org.openstreetmap.josm.gui.preferences.map.MapPaintPreference.initialize(MapPaintPreference.java:187)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:33)
	at org.openstreetmap.josm.spi.lifecycle.InitializationTask.call(InitializationTask.java:11)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

Attachments (0)

Change History (9)

comment:1 Changed 3 months ago by GerdP

Cc: simon04 added

regression from r15910?

comment:2 Changed 3 months ago by simon04

http://osm.wzh.be/josm/entur_1.0.mapcss contains an invalid zoom range |z16-15.

Previously, this glitch has been reported on the console and loading continued. Due to (now) inadequate AssertionError, this triggers a report-bug-dialog.

comment:3 in reply to:  1 Changed 3 months ago by simon04

Keywords: regression mapcss zoom added

Replying to GerdP:

regression from r15910?

Yes

comment:4 Changed 3 months ago by simon04

Owner: changed from team to simon04
Status: newassigned

comment:5 Changed 3 months ago by Don-vip

Component: CoreCore mappaint
Keywords: range added
Milestone: 20.03

comment:6 Changed 3 months ago by simon04

Resolution: fixed
Status: assignedclosed

In 15925/josm:

fix #18759 - AssertionError on invalid MapCSS zoom range

comment:7 Changed 3 months ago by simon04

With r15925, the JOSM starts up and reports the invalid range to the console:

2020-02-24 21:47:50.416 WARNING: Failed to load Mappaint styles from 'http://osm.wzh.be/josm/entur_1.0.mapcss'. Exception was: java.lang.IllegalArgumentException: Invalid range: 238.8657133911758-238.8657133911758
2020-02-24 21:47:50.419 SEVERE: java.lang.IllegalArgumentException: Invalid range: 238.8657133911758-238.8657133911758
2020-02-24 21:47:50.421 WARNING: Initializing map style http://osm.wzh.be/josm/entur_1.0.mapcss completed in 49 ms (1 errors, 0 warnings)

The reported numbers are due to the transformation Selector.OptimizedGeneralSelector#level2scale.

comment:8 Changed 3 months ago by skyper

no milestone ?

comment:9 Changed 3 months ago by Klumbumbus

Milestone: 20.0320.02

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain simon04.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.