Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#18753 closed defect (duplicate)

OpeningHourTest.ENGINE uses/wastes 10 MB of heap memory

Reported by: simon04 Owned by: team
Priority: normal Milestone:
Component: Core validator Version:
Keywords: opening_hours webservice remote nashorn Cc: Don-vip, ypid23, stoecker

Description

After OpeningHourTest#initialize, the retained size of OpeningHourTest.ENGINE is 10_497_152 bytes. As suggested in ticket:18140#comment:2, we could deploy and make use of a webservice for validating opening_hours

Revision:15912
Is-Local-Build:true
Build-Date:2020-02-23 13:47:40

Identification: JOSM/1.5 (15912 SVN de) Linux Arch Linux
Memory Usage: 360 MB / 3972 MB (133 MB allocated, but free)
Java version: 11.0.6+10, Oracle Corporation, OpenJDK 64-Bit Server VM
Screen: :0.0 3840x2160
Maximum Screen Size: 3840x2160

Attachments (0)

Change History (9)

comment:1 Changed 2 years ago by Don-vip

Cc: stoecker added
Keywords: nashorn added

Maybe we could do both: embed OpeningHoursParser as described in #18140, so that we keep a low-memory & offline validator. And also provide a web service running opening_hours.js. This way, we will still provide a way to detect issues reported by opening_hours.js and not by OpeningHoursParser.

comment:2 Changed 2 years ago by Don-vip

Milestone: 20.03

comment:4 Changed 2 years ago by stoecker

Parsing the opening hours data should not need an online API. It is not complex enough to verify that. What speaks against the Java implementation?

comment:5 in reply to:  4 Changed 2 years ago by Don-vip

Replying to stoecker:

Parsing the opening hours data should not need an online API. It is not complex enough to verify that. What speaks against the Java implementation?

At least "wd", see #18140. But I haven't tested it yet, so there could be more.

comment:6 in reply to:  4 Changed 2 years ago by simon04

Replying to stoecker:

What speaks against the Java implementation?

According to #18140, the reported errors are not as helpful opening_hours.js:

<simonpoole> I really need to have a look at generating more descriptive error messages in my parser and add an evaluator but its a month ot two work I suspect

We'd loose the detailed error messages plus the autofix.

comment:7 Changed 2 years ago by simon04

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18140.

comment:8 Changed 2 years ago by simon04

Let's keep the discussion together in one issue (here we've been discussing the Java implementation and in #18140 the JavaScript servlet).

comment:9 Changed 2 years ago by Don-vip

Milestone: 20.03

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.