Modify

Opened 10 months ago

Closed 9 months ago

Last modified 9 months ago

#18744 closed defect (fixed)

"Join Overlapping Areas" shows confusing dialogs when merging inner and outer ways of a multipolygon

Reported by: GerdP Owned by: team
Priority: normal Milestone: 20.03
Component: Core Version:
Keywords: template_report Cc:

Description (last modified by GerdP)

What steps will reproduce the problem?

  1. Load attached sample 18744-sample.osm
  2. select all ways and press Shift+J to "join overlapping areas"

What is the expected result?

A notification that this is not supported, maybe "Cannot join inner and outer ways of a multipolygon"

What happens instead?

Conflict dialog pops up, asking which ways should be kept. Depending on the selection the dialog pops up again, maybe followed by a third popup asking for confirmation that a new way can be deleted.

Please provide any additional information below. Attach a screenshot if possible.

Build-Date:2020-02-21 09:22:50
Revision:15887
Is-Local-Build:true

Identification: JOSM/1.5 (15887 SVN en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1903 (18362)
Memory Usage: 841 MB / 1820 MB (153 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
VM arguments: [-agentlib:jdwp=transport=dt_socket,suspend=y,address=localhost:58005, -ea, -Dfile.encoding=UTF-8]
Program arguments: [--debug]

Plugins:
+ OpeningHoursEditor (35250)
+ PolygonCutOut (v0.7)
+ apache-commons (35092)
+ buildings_tools (35248)
+ continuosDownload (91)
+ ejml (35122)
+ geotools (35169)
+ jaxb (35092)
+ jts (35122)
+ merge-overlap (35248)
+ o5m (35248)
+ opendata (35330)
+ pbf (35248)
+ poly (35248)
+ reverter (35313)
+ undelete (35313)
+ utilsplugin2 (35248)

Last errors/warnings:
- W: 1 problems occurred during upload/save

Attachments (5)

18744-sample.osm (4.5 KB) - added by GerdP 10 months ago.
popup1.PNG (27.9 KB) - added by GerdP 10 months ago.
popup2.PNG (194.8 KB) - added by GerdP 10 months ago.
popup3.PNG (10.9 KB) - added by GerdP 10 months ago.
18744-sample_extended.osm (5.0 KB) - added by skyper 10 months ago.
extended sample

Download all attachments as: .zip

Change History (10)

Changed 10 months ago by GerdP

Attachment: 18744-sample.osm added

Changed 10 months ago by GerdP

Attachment: popup1.PNG added

Changed 10 months ago by GerdP

Attachment: popup2.PNG added

Changed 10 months ago by GerdP

Attachment: popup3.PNG added

comment:1 Changed 10 months ago by GerdP

The three popups:



The result is complete garbarge and there is probably no way to avoid that unless user presses Cancel early enough. Pressing Cancel in the last popup is never a good idea.

comment:2 Changed 10 months ago by GerdP

Description: modified (diff)

Changed 10 months ago by skyper

Attachment: 18744-sample_extended.osm added

extended sample

comment:3 Changed 10 months ago by skyper

Have fun with a bit more complicated example file. Just select all ways.

Why is a new relation created ?

The problems with the conflicts are because an old state of the members is used in the dialog. I remember there are/were similar problems with roles when a way direction is changed during Combine Ways.

Since the change to checkboxes instead of popup menu for "Keep" and "Remove" JOSM does not set any, automatically, which might be a big challenge to negotiate for inexperienced users.

comment:4 Changed 9 months ago by GerdP

Resolution: fixed
Status: newclosed

In 16048/josm:

fix #18744: "Join Overlapping Areas" shows confusing dialogs when merging inner and outer ways of a multipolygon
Refuse to join ways when one is an outer way and at least one is an inner way of the same multipolygon relation

comment:5 Changed 9 months ago by Don-vip

Milestone: 20.03

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.