Modify

Opened 3 months ago

Closed 3 months ago

#18732 closed defect (duplicate)

JOSM-crash with Contour-Merge

Reported by: jumat@… Owned by: Gubaer
Priority: normal Milestone:
Component: Plugin contourmerge Version:
Keywords: template_report Cc:

Description

What steps will reproduce the problem?

  1. try to merge landuse-contours

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-01 01:10:57 +0100 (Sat, 01 Feb 2020)
Build-Date:2020-02-01 00:12:46
Revision:15806
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15806 de) Mac OS X 10.14.6
OS Build number: Mac OS X 10.14.6 (18G3020)
Memory Usage: 893 MB / 1820 MB (605 MB allocated, but free)
Java version: 1.8.0_211-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: Display 685389249 1920x1200
Maximum Screen Size: 1920x1200
VM arguments: [-Djava.library.path=/private/var/folders/fc/bv6j_0k50dq0vwz0_0nn3dq00000gn/T/AppTranslocation/0A7C77B9-DEB2-4E33-9CFD-C0B4CB29DDF7/d/JOSM.app/Contents/MacOS, -DLibraryDirectory=${HOME}/Library, -DDocumentsDirectory=${HOME}/Documents, -DApplicationSupportDirectory=${HOME}/Library/Application Support, -DCachesDirectory=${HOME}/Library/Caches, -DApplicationDirectory=${HOME}/Applications, -DAutosavedInformationDirectory=${HOME}/Library/Autosave Information, -DDesktopDirectory=${HOME}/Desktop, -DDownloadsDirectory=${HOME}/Downloads, -DMoviesDirectory=${HOME}/Movies, -DMusicDirectory=${HOME}/Music, -DPicturesDirectory=${HOME}/Pictures, -DSharedPublicDirectory=${HOME}/Public, -DSystemLibraryDirectory=/Library, -DSystemApplicationSupportDirectory=/Library/Application Support, -DSystemCachesDirectory=/Library/Caches, -DSystemApplicationDirectory=/Applications, -DSystemUserDirectory=/Users, -DUserHome=${HOME}, -DSandboxEnabled=true, -DLaunchModifierFlags=0, -DLaunchModifierFlagCapsLock=false, -DLaunchModifierFlagShift=false, -DLaunchModifierFlagControl=false, -DLaunchModifierFlagOption=false, -DLaunchModifierFlagCommand=false, -DLaunchModifierFlagNumericPad=false, -DLaunchModifierFlagHelp=false, -DLaunchModifierFlagFunction=false, -Dapple.laf.useScreenMenuBar=true, -Dcom.apple.macos.use-file-dialog-packages=true, -Dcom.apple.macos.useScreenMenuBar=true, -Dcom.apple.mrj.application.apple.menu.about.name=JOSM, -Dcom.apple.smallTabs=true]
Dataset consistency test: No problems found

Plugins:
+ FastDraw (35256)
+ austriaaddresshelper (57)
+ buildings_tools (35248)
+ continuosDownload (91)
+ contourmerge (v0.1.5)
+ utilsplugin2 (35248)

Map paint styles:
+ https://pasharm.github.io/New_basic_style_for_JOSM/New_basic_style.mapcss

Validator rules:
+ resource://data/validator/power.mapcss

Last errors/warnings:
- W: Hinzufügen von resource://data/validator/power.mapcss zum Merkmalsprüfer fehlgeschlagen
- W: java.io.IOException: Das Öffnen eines Eingabestroms für die Resource 'resource://data/validator/power.mapcss' ist fehlgeschlagen.
- W: Unable to convert property color to type class java.awt.Color: found # of type class java.lang.String!
- W: Unable to convert property color to type class java.awt.Color: found # of type class java.lang.String!
- W: Unable to convert property color to type class java.awt.Color: found # of type class java.lang.String!
- W: Unable to convert property color to type class java.awt.Color: found # of type class java.lang.String!
- W: Unable to convert property color to type class java.awt.Color: found # of type class java.lang.String!
- W: Unable to convert property color to type class java.awt.Color: found # of type class java.lang.String!
- E: Handled by bug report queue: java.lang.IllegalArgumentException: {Node id=2386205774 version=1 MVD lat=47.0158603,lon=15.8249811} is already deleted
- W: Achtung - <html>JOSM konnte keine Informationen über die folgenden Erweiterungen finden:<ul><li>continuosDownload</li><li>utilsplugin2</li><li>buildings_tools</li><li>austriaaddresshelper</li><li>FastDraw</li><li>contourmerge</li></ul>Diese Erweiterungen werden nicht geladen.</html>


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: {Node id=2386205774 version=1 MVD lat=47.0158603,lon=15.8249811} is already deleted
	at org.openstreetmap.josm.command.DeleteCommand.executeCommand(DeleteCommand.java:191)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:79)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:300)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:354)
	at org.openstreetmap.josm.plugins.contourmerge.ContourMergeMode.lambda$onDrop$9(ContourMergeMode.java:286)
	at java.util.Optional.ifPresent(Optional.java:159)
	at org.openstreetmap.josm.plugins.contourmerge.ContourMergeMode.onDrop(ContourMergeMode.java:277)
	at org.openstreetmap.josm.plugins.contourmerge.ContourMergeMode.mouseReleased(ContourMergeMode.java:114)
	at java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:290)
	at java.awt.Component.processMouseEvent(Component.java:6539)
	at javax.swing.JComponent.processMouseEvent(JComponent.java:3324)
	at java.awt.Component.processEvent(Component.java:6304)
	at java.awt.Container.processEvent(Container.java:2239)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4904)
	at java.awt.LightweightDispatcher.processMouseEvent(Container.java:4535)
	at java.awt.LightweightDispatcher.dispatchEvent(Container.java:4476)
	at java.awt.Container.dispatchEventImpl(Container.java:2283)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84)
	at java.awt.EventQueue$4.run(EventQueue.java:733)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (1)

fehlerhafte_sitzung.joz (157.1 KB) - added by jumat@… 3 months ago.
faulty session

Download all attachments as: .zip

Change History (8)

Changed 3 months ago by jumat@…

Attachment: fehlerhafte_sitzung.joz added

faulty session

comment:1 Changed 3 months ago by GerdP

Please update the contourmerge plugin.

comment:2 Changed 3 months ago by GerdP

Component: CorePlugin contourmerge
Owner: changed from team to Gubaer

comment:3 Changed 3 months ago by jumat@…

Done. Thanks for this hint. I hope, the problem is solved now.

comment:4 Changed 3 months ago by GerdP

Maybe not, but the duplicate nodes problem should be solved.
This one seems to be a duplicate of #18600

comment:5 Changed 3 months ago by jumat@…

In Fact, it's not solved yet. I have tried out the new release of contour-merge right now and duplicate nodes are still there.

comment:6 Changed 3 months ago by GerdP

It worked for me in a quick test. Please open a new ticket for that or reopen #18365 and describe the details how to reproduce.

comment:7 Changed 3 months ago by Don-vip

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18600.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Gubaer.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.