Modify

Opened 4 months ago

Closed 4 months ago

#18715 closed defect (duplicate)

Crash after pressing F11 for full screen

Reported by: Hb--- Owned by: team
Priority: normal Milestone:
Component: Core Version:
Keywords: template_report Cc:

Description

I'm not able to reproduce this.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-13 16:11:24 +0100 (Thu, 13 Feb 2020)
Build-Date:2020-02-14 02:31:03
Revision:15850
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15850 en_AU) Windows 7 64-Bit
OS Build number: Windows 7 Professional (7601)
Memory Usage: 955 MB / 3604 MB (140 MB allocated, but free)
Java version: 1.8.0_212-b03, AdoptOpenJDK, OpenJDK 64-Bit Server VM
Screen: \Display0 1280x1024
Maximum Screen Size: 1280x1024
Dataset consistency test: No problems found

Plugins:
+ buildings_tools (35248)

Last errors/warnings:
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0017/224801/favicon.ico'
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Listener was not registered before: LayerChangeAdapter [org.openstreetmap.josm.gui.history.VersionTable$ChangesetInfoAction@3734eab4]


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: Listener was not registered before: LayerChangeAdapter [org.openstreetmap.josm.gui.history.VersionTable$ChangesetInfoAction@3734eab4]
	at org.openstreetmap.josm.gui.layer.LayerManager.removeLayerChangeListener(LayerManager.java:433)
	at org.openstreetmap.josm.actions.JosmAction.destroy(JosmAction.java:275)
	at org.openstreetmap.josm.gui.history.VersionTable$VersionTablePopupMenu.destroy(VersionTable.java:258)
	at org.openstreetmap.josm.gui.history.VersionTable.destroy(VersionTable.java:110)
	at org.openstreetmap.josm.gui.util.GuiHelper.destroyComponents(GuiHelper.java:664)
	at org.openstreetmap.josm.gui.util.GuiHelper.destroyComponents(GuiHelper.java:660)
	at org.openstreetmap.josm.gui.util.GuiHelper.destroyComponents(GuiHelper.java:660)
	at org.openstreetmap.josm.gui.util.GuiHelper.destroyComponents(GuiHelper.java:660)
	at org.openstreetmap.josm.gui.util.GuiHelper.destroyComponents(GuiHelper.java:660)
	at org.openstreetmap.josm.gui.util.GuiHelper.destroyComponents(GuiHelper.java:660)
	at org.openstreetmap.josm.gui.util.GuiHelper.destroyComponents(GuiHelper.java:660)
	at org.openstreetmap.josm.gui.util.GuiHelper.destroyComponents(GuiHelper.java:660)
	at org.openstreetmap.josm.gui.util.GuiHelper.destroyComponents(GuiHelper.java:660)
	at org.openstreetmap.josm.gui.util.GuiHelper.destroyComponents(GuiHelper.java:660)
	at org.openstreetmap.josm.gui.history.HistoryBrowserDialog.dispose(HistoryBrowserDialog.java:199)
	at java.awt.Window.disposeImpl(Window.java:1157)
	at java.awt.Window$1DisposeAction.run(Window.java:1185)
	at java.awt.Window.doDispose(Window.java:1206)
	at java.awt.Window.dispose(Window.java:1147)
	at org.openstreetmap.josm.actions.FullscreenToggleAction.setMode(FullscreenToggleAction.java:84)
	at org.openstreetmap.josm.actions.FullscreenToggleAction.actionPerformed(FullscreenToggleAction.java:58)
	at javax.swing.SwingUtilities.notifyAction(SwingUtilities.java:1668)
	at javax.swing.JComponent.processKeyBinding(JComponent.java:2882)
	at javax.swing.KeyboardManager.fireBinding(KeyboardManager.java:307)
	at javax.swing.KeyboardManager.fireKeyboardAction(KeyboardManager.java:263)
	at javax.swing.JComponent.processKeyBindingsForAllComponents(JComponent.java:2974)
	at javax.swing.JComponent.processKeyBindings(JComponent.java:2966)
	at javax.swing.JComponent.processKeyEvent(JComponent.java:2845)
	at java.awt.Component.processEvent(Component.java:6316)
	at java.awt.Container.processEvent(Container.java:2239)
	at java.awt.Component.dispatchEventImpl(Component.java:4889)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.KeyboardFocusManager.redispatchEvent(KeyboardFocusManager.java:1954)
	at java.awt.DefaultKeyboardFocusManager.dispatchKeyEvent(DefaultKeyboardFocusManager.java:834)
	at java.awt.DefaultKeyboardFocusManager.preDispatchKeyEvent(DefaultKeyboardFocusManager.java:1102)
	at java.awt.DefaultKeyboardFocusManager.typeAheadAssertions(DefaultKeyboardFocusManager.java:973)
	at java.awt.DefaultKeyboardFocusManager.dispatchEvent(DefaultKeyboardFocusManager.java:799)
	at java.awt.Component.dispatchEventImpl(Component.java:4760)
	at java.awt.Container.dispatchEventImpl(Container.java:2297)
	at java.awt.Window.dispatchEventImpl(Window.java:2746)
	at java.awt.Component.dispatchEvent(Component.java:4711)
	at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:760)
	at java.awt.EventQueue.access$500(EventQueue.java:97)
	at java.awt.EventQueue$3.run(EventQueue.java:709)
	at java.awt.EventQueue$3.run(EventQueue.java:703)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:84)
	at java.awt.EventQueue$4.run(EventQueue.java:733)
	at java.awt.EventQueue$4.run(EventQueue.java:731)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:74)
	at java.awt.EventQueue.dispatchEvent(EventQueue.java:730)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:205)
	at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
	at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Attachments (0)

Change History (1)

comment:1 Changed 4 months ago by GerdP

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18680.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.