Modify

Opened 2 years ago

Closed 21 months ago

#18704 closed defect (duplicate)

Freeze upon deleting and re-opening Mapillary imagery layer

Reported by: Traaker_L Owned by: jpietri
Priority: critical Milestone:
Component: Plugin mapillary Version: tested
Keywords: template_report Cc:

Description (last modified by Traaker_L)

What steps will reproduce the problem?

  1. Open the Mapillary imagery layer from the Mapillary plugin.
  2. Do some editing.
  3. Delete the Mapillary imagery layer.
  4. Re load the Mapillary imagery layer.

What is the expected result?

The Mapillary layer appears in the editor

What happens instead?

The editor freezes completely after the "Downloading Mapillary images --- Select mode" message appears in the bottom-left corner. The Mapillary Images layer appears in the Layers list, but no images appear in the layer itself.

Please provide any additional information below. Attach a screenshot if possible.

Closing the Mapillary Imagery panel completely seems to prevent the crash. The crash still occurs if the Mapillary Image window is collapsed and present in the side bar with the other panels and not closed completely.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-01 01:10:57 +0100 (Sat, 01 Feb 2020)
Revision:15806
Build-Date:2020-02-01 00:12:46
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15806 en) Mac OS X 10.14.6
OS Build number: Mac OS X 10.14.6 (18G103)
Memory Usage: 1167 MB / 2048 MB (308 MB allocated, but free)
Java version: 11.0.5+10-LTS, Azul Systems, Inc., OpenJDK 64-Bit Server VM
Screen: Display 188945226 1920x1080, Display 69955240 2048x1152
Maximum Screen Size: 2048x1152
VM arguments: [--add-reads=java.base=ALL-UNNAMED,java.desktop, --add-reads=java.desktop=ALL-UNNAMED,java.naming, --add-reads=java.naming=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/javax.jnlp=ALL-UNNAMED,java.desktop, --add-exports=java.base/com.sun.net.ssl.internal.ssl=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.action=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.provider=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.util=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.validator=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.security.x509=ALL-UNNAMED,java.desktop, --add-exports=java.base/jdk.internal.util.jar=ALL-UNNAMED,java.desktop, --add-exports=java.base/sun.net.www.protocol.http=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.awt.X11=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,java.desktop, --add-exports=java.desktop/sun.applet=ALL-UNNAMED,jdk.jsobject, --add-exports=java.naming/com.sun.jndi.toolkit.url=ALL-UNNAMED,java.desktop]
Dataset consistency test: No problems found

Plugins:
+ EasyPresets (1537621333)
+ Mapillary (1.5.20)
+ apache-commons (35092)
+ apache-http (35092)
+ auto_tools (73)
+ buildings_tools (35248)
+ graphview (35313)
+ intersection (0.0.7)
+ jna (35092)
+ osm-obj-info (56)
+ rex (53)
+ turnrestrictions (35313)
+ utilsplugin2 (35248)

Tagging presets:
+ https://raw.githubusercontent.com/osmlab/name-suggestion-index/master/dist/name-suggestions.presets.xml

Map paint styles:
+ https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Kaart-Styles.mapcss
+ https://raw.githubusercontent.com/KaartGroup/Kaart-Styles/master/Overlapping%20Ways.mapcss
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1

Validator rules:
+ https://raw.githubusercontent.com/KaartGroup/KaartValidator/master/kaart.clingstone.validator.mapcss
- https://raw.githubusercontent.com/KaartGroup/KaartValidator/master/kaart.dwarf.validator.mapcss

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Region [userProfile_BLOCK_v2]  Problem verifying disk.
- W: Region [userProfile_BLOCK_v2] Resetting cache
- W: Could not read from URL https://a.mapillary.com/v3/image_detections?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=101.6978645%2C3.102978%2C101.7051172%2C3.1130483&layers=trafficsigns&sort_by=key!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/image_detections?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&bbox=101.6978645%2C3.102978%2C101.7051172%2C3.1130483&layers=trafficsigns&sort_by=key
- W: Could not read from URL https://a.mapillary.com/v3/image_detections?layers=trafficsigns&client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&_next_page_token=eyJpZCI6IjFBTm9RMjFEaXREUGtYdlZCUEJQN1EiLCJhZnRlciI6WyIxQTV1SVBscEU0Q0RNaEFxQzFYUHlKIl0sIm9mZnNldCI6MX0%3D&sort_by=key&bbox=101.6946888%2C3.0991213%2C101.7051172%2C3.1130483!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/image_detections?layers=trafficsigns&client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&_next_page_token=eyJpZCI6IjFBTm9RMjFEaXREUGtYdlZCUEJQN1EiLCJhZnRlciI6WyIxQTV1SVBscEU0Q0RNaEFxQzFYUHlKIl0sIm9mZnNldCI6MX0%3D&sort_by=key&bbox=101.6946888%2C3.0991213%2C101.7051172%2C3.1130483
- W: Unable to delete archived backup file <josm.userdata>/autosave/deleted_layers/Data Layer 3_20200211_142640930.osm
- W: Could not read from URL https://a.mapillary.com/v3/image_detections?layers=trafficsigns&client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&sort_by=key&_next_page_token=eyJhZnRlciI6WyI0R3ExZ0d1SHFUdlZwalVudmpYMWVZIl0sIm9mZnNldCI6MH0%3D&bbox=101.7091513%2C3.1318602%2C101.7190647%2C3.1400019!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/image_detections?layers=trafficsigns&client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&sort_by=key&_next_page_token=eyJhZnRlciI6WyI0R3ExZ0d1SHFUdlZwalVudmpYMWVZIl0sIm9mZnNldCI6MH0%3D&bbox=101.7091513%2C3.1318602%2C101.7190647%2C3.1400019
- W: Could not read from URL https://a.mapillary.com/v3/images?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&_next_page_token=eyJhZnRlciI6WzE1NzkyMzYxNDEwOTAsIjEzMUh3cE91WnRBcnI5dmJ3SUg1UFkiXX0%3D&bbox=101.7091513%2C3.1318602%2C101.7190647%2C3.1400019!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/images?client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&_next_page_token=eyJhZnRlciI6WzE1NzkyMzYxNDEwOTAsIjEzMUh3cE91WnRBcnI5dmJ3SUg1UFkiXX0%3D&bbox=101.7091513%2C3.1318602%2C101.7190647%2C3.1400019
- W: Could not read from URL https://a.mapillary.com/v3/image_detections?layers=trafficsigns&client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&_next_page_token=eyJhZnRlciI6WyJQZUpNRjl3NkdQNG41MHZCYlhWQ2NLIl0sIm9mZnNldCI6MH0%3D&sort_by=key&bbox=101.7091942%2C3.1331886%2C101.7182493%2C3.1399162!: java.io.IOException: Server returned HTTP response code: 504 for URL: https://a.mapillary.com/v3/image_detections?layers=trafficsigns&client_id=T1Fzd20xZjdtR0s1VDk5OFNIOXpYdzoxNDYyOGRkYzUyYTFiMzgz&_next_page_token=eyJhZnRlciI6WyJQZUpNRjl3NkdQNG41MHZCYlhWQ2NLIl0sIm9mZnNldCI6MH0%3D&sort_by=key&bbox=101.7091942%2C3.1331886%2C101.7182493%2C3.1399162

Attachments (0)

Change History (7)

comment:1 Changed 2 years ago by Traaker_L

Summary: Crash upon deleting and re-opening Mapillary imagery layerFreeze upon deleting and re-opening Mapillary imagery layer

comment:2 Changed 2 years ago by Traaker_L

Component: CorePlugin mapillary
Owner: changed from team to jpietri

comment:3 Changed 2 years ago by Don-vip

Priority: normalcritical

comment:4 Changed 2 years ago by Traaker_L

Description: modified (diff)

Added more info on the possible cause of the crash

comment:5 Changed 2 years ago by skyper

Ticket #18743 has been marked as a duplicate of this ticket.

comment:6 Changed 21 months ago by taylor.smock

I think I fixed this in ​https://github.com/JOSM/Mapillary/commit/e1710fce8a5a5656d646a7a162554b540fa1fb4b , so Mapillary v1.5.21+ (April 07, 2020) should have the fix. (I think this is a duplicate of #17971).

@Traaker_L: Can you still reproduce this?

comment:7 Changed 21 months ago by taylor.smock

Resolution: duplicate
Status: newclosed

Closed as duplicate of #17971.
I'm closing #17971, #18656, and #18704. I'm confident enough that the problem is actually fixed, and none of the ticket reports have indicated that it is still a problem.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain jpietri.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.