Modify

Opened 22 months ago

Closed 17 months ago

Last modified 16 months ago

#18698 closed enhancement (fixed)

[Patch] Request: Add (motor_)vehicle combo to highway=path preset

Reported by: AnkEric Owned by: team
Priority: normal Milestone: 20.07
Component: Internal preset Version:
Keywords: highway path motor vehicle access Cc:

Description

In Closed ticket https://josm.openstreetmap.de/ticket/18642 you have also implemented:
"Add vehicle combo to highway=track preset"
Oké, nice! Appreciated. I get more than I have asked for.

But than I would like to suggest to not only Add vehicle combo to highway=track, but also (and - imo - even more important) to highway=path preset.

Most annoying (to me) a highway=path is added on OSM without any access restriction.
Therefore (default access): bicycle/mofa/moped=yes is implied. Sometimes this is correct, sometimes not. So my GPS might be directing me - on bicycle - over a path which is in fact a "footway".
Sometimes this is "resolved" the wrong - IMO - way: [highway=path] + [access=no] + [foot=yes].
Because this is "less work" than [highway=path] + [bicycle=no] + [moped=no] + [mofa=no] + [horse=no] and better than [highway=path] + [bicycle=no] ?
Next mapper might change to: [highway=footway] + [access=no] + [foot=yes].
Next mapper might change to: [highway=footway] + [access=no] (since "foot=yes" is "needless").
And now we have a path with no access at all.
Which was "resolved" by Reverting ALL thousands of footways in the Netherlands where "foot=yes" was removed by hundreds of "Undiscussed Mechanical Edits".
And now JOSM Validator is is bothering me with tens of warnings for each of my Changesets: "unnecessary tag - foot=yes|designated is unnecessary for highway=footway|pedestrian".
JOSM Validator is - of course - correct. Does [highway=footway] + [foot=no] exist in "on the ground"? No! IMO!
And I don't dare to resolve; -))

Correct would have been initial mapping as: [highway=path] + [vehicle=no].
And a JOSM preset might help... a little...

/ AnkEric

Attachments (3)

josm_path_access_update.patch (11.2 KB) - added by skyper 18 months ago.
patch
josm_path_access_update_v2.patch (19.5 KB) - added by skyper 17 months ago.
version 2 with values_sort="false"
josm_path_access_update_v3.patch (25.3 KB) - added by skyper 17 months ago.
version 3 adding more access tags to highway=*way and path

Download all attachments as: .zip

Change History (20)

comment:1 Changed 22 months ago by AnkEric

Component: External presetInternal preset

comment:2 Changed 22 months ago by skyper

Keywords: path vehicle access added
Summary: Request: Add vehicle combo to highway=track presetRequest: Add (motor_)vehicle combo to highway=path preset

vehicle=* plus motor_vehicle=* should be added. Additionally, the link to "road restriction"-preset is nice, too.

Some transport modes from path are missing in "road restriction"-preset, namely:

  • wheelchair=*
  • ski=*
  • snowmobile=*

Considering splitting the "road restriction"-preset into two parts by extracting the transport modes into an own preset and adding links between both, is another idea.

comment:3 Changed 22 months ago by AnkEric

Thanks Skyper for your Additions.

Except for [tracktype=grade<x>] and [agricultural=*], what is (should be) different for path and track presets? Track preset is very complete, use (almost) the same preset for path as being similar?

comment:4 Changed 22 months ago by Don-vip

Keywords: highway motor added

comment:5 Changed 18 months ago by skyper

Please, find attached patch file) which adds missing access keys to "Road Restriction" preset and adds preset links from path to the "Road Restriction" preset.

comment:6 Changed 18 months ago by skyper

Summary: Request: Add (motor_)vehicle combo to highway=path preset[Patch] Request: Add (motor_)vehicle combo to highway=path preset

Changed 18 months ago by skyper

patch

Changed 17 months ago by skyper

version 2 with values_sort="false"

comment:7 Changed 17 months ago by skyper

I had forgotten to add values_sort="false". Please, find updated patch version 2.

comment:8 Changed 17 months ago by skyper

To solve #17750 it would be nice to split the access part of into a new preset "Access Restrictions" and have preset links between these two presets.

Changed 17 months ago by skyper

version 3 adding more access tags to highway=*way and path

comment:9 Changed 17 months ago by skyper

I did even add more tags to highway=path and highway=bridle/cycle/footway and add labels about implied tags, see version 3

Next step, would be to split the "Road Restrictions" preset and use little more chunks.

comment:10 Changed 17 months ago by Klumbumbus

In 16742/josm:

see #18698 - add more access tags (patch by skyper, modified)

comment:11 Changed 17 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 16743/josm:

fix #18698 - split Road Restrictions preset in Road Restrictions and Access Restrictions

comment:12 Changed 17 months ago by Klumbumbus

Milestone: 20.07

comment:13 in reply to:  11 Changed 17 months ago by skyper

Replying to Klumbumbus:

In 16743/josm:

fix #18698 - split Road Restrictions preset in Road Restrictions and Access Restrictions

Thanks no I can work on #17750.

comment:14 Changed 17 months ago by Klumbumbus

OK, please don't go wild with chunks :)

The patch header works fine now.

comment:15 in reply to:  14 Changed 17 months ago by skyper

Replying to Klumbumbus:

OK, please don't go wild with chunks :)

Yeah, will stay calm, like the one above.

The patch header works fine now.

Thanks, for the respond.

comment:16 Changed 17 months ago by Klumbumbus

In 16749/josm:

see #18698 - remove new tags from ignore list

comment:17 Changed 16 months ago by Klumbumbus

Ticket #17960 has been marked as a duplicate of this ticket.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.