Modify

Opened 4 months ago

Closed 4 months ago

#18681 closed defect (duplicate)

IAE: Parameter 'data' must not be null

Reported by: naoliv Owned by: team
Priority: normal Milestone:
Component: Plugin merge-overlap Version:
Keywords: template_report Cc:

Description

Use this example, select both areas, Merge overlap, at the dialog asking for the value select all; the plugin crashes.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-02-06 01:03:07 +0100 (Thu, 06 Feb 2020)
Revision:15820
Build-Date:2020-02-06 02:30:54
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15820 en) Linux Debian GNU/Linux bullseye/sid
Memory Usage: 534 MB / 6144 MB (90 MB allocated, but free)
Java version: 13.0.2+8-Debian-1, Debian, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900, :0.1 1280x1024
Maximum Screen Size: 1600x1024
Java ATK Wrapper package: libatk-wrapper-java:all-0.37.1-1
libcommons-compress-java: libcommons-compress-java:all-1.19-1
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:-
liboauth-signpost-java: liboauth-signpost-java:all-1.2.1.2-3
VM arguments: [-Dawt.useSystemAAFontSettings=gasp]
Program arguments: [--language=en]
Dataset consistency test: No problems found

Plugins:
+ FixAddresses (35248)
+ OpeningHoursEditor (35250)
+ PicLayer (35313)
+ SimplifyArea (35313)
+ apache-commons (35092)
+ apache-http (35092)
+ buildings_tools (35248)
+ ejml (35122)
+ geotools (35169)
+ http2 (35248)
+ jaxb (35092)
+ jna (35092)
+ jts (35122)
+ log4j (35092)
+ mbtiles (v2.5.0)
+ measurement (35248)
+ merge-overlap (35248)
+ opendata (35313)
+ poly (35248)
+ reverter (35313)
+ tageditor (35258)
+ todo (30306)
+ turnlanes-tagging (283)
+ turnrestrictions (35313)
+ undelete (35313)
+ utilsplugin2 (35248)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/Healthcare&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Surface-DataEntry&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Noname&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&style&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- <josm.pref>/styles/indoor.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/LayerChecker&zip=1
+ /arquivos/git/osm-gambi/fixme.mapcss
- /tmp/estilo.mapcss

Validator rules:
+ /arquivos/git/validador-josm/Rules_Brazilian-Specific.validator.mapcss
+ /arquivos/git/validador-josm/staging.validator.mapcss
- <josm.pref>/validator/indoorhelper.validator.mapcss
+ /arquivos/git/osm-gambi/local.validator.mapcss
+ /arquivos/git/validador-josm/nome-ruas-numeros.validator.mapcss

Last errors/warnings:
- W: Failed to load Mappaint styles from '/tmp/estilo.mapcss'. Exception was: java.nio.file.NoSuchFileException: /tmp/estilo.mapcss
- E: java.nio.file.NoSuchFileException: /tmp/estilo.mapcss
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: java.lang.IllegalArgumentException: Parameter 'data' must not be null


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
java.lang.IllegalArgumentException: Parameter 'data' must not be null
	at org.openstreetmap.josm.tools.CheckParameterUtil.ensureParameterNotNull(CheckParameterUtil.java:69)
	at org.openstreetmap.josm.command.Command.<init>(Command.java:138)
	at org.openstreetmap.josm.command.ChangePropertyCommand.<init>(ChangePropertyCommand.java:108)
	at org.openstreetmap.josm.command.ChangePropertyCommand.<init>(ChangePropertyCommand.java:123)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolver.buildTagChangeCommand(CombinePrimitiveResolver.java:68)
	at org.openstreetmap.josm.gui.conflict.tags.CombinePrimitiveResolverDialog.buildTagChangeCommand(CombinePrimitiveResolverDialog.java:280)
	at mergeoverlap.hack.MyCombinePrimitiveResolverDialog.buildWayResolutionCommands(MyCombinePrimitiveResolverDialog.java:104)
	at mergeoverlap.MergeOverlapAction.combineWaysWorker(MergeOverlapAction.java:395)
	at mergeoverlap.MergeOverlapAction.actionPerformed(MergeOverlapAction.java:208)
	at java.desktop/javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1967)
	at java.desktop/javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2308)
	at java.desktop/javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:405)
	at java.desktop/javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:262)
	at java.desktop/javax.swing.AbstractButton.doClick(AbstractButton.java:369)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1020)
	at java.desktop/javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1064)
	at java.desktop/java.awt.AWTEventMulticaster.mouseReleased(AWTEventMulticaster.java:297)
	at java.desktop/java.awt.Component.processMouseEvent(Component.java:6636)
	at java.desktop/javax.swing.JComponent.processMouseEvent(JComponent.java:3342)
	at java.desktop/java.awt.Component.processEvent(Component.java:6401)
	at java.desktop/java.awt.Container.processEvent(Container.java:2263)
	at java.desktop/java.awt.Component.dispatchEventImpl(Component.java:5012)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2321)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4844)
	at java.desktop/java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4918)
	at java.desktop/java.awt.LightweightDispatcher.processMouseEvent(Container.java:4547)
	at java.desktop/java.awt.LightweightDispatcher.dispatchEvent(Container.java:4488)
	at java.desktop/java.awt.Container.dispatchEventImpl(Container.java:2307)
	at java.desktop/java.awt.Window.dispatchEventImpl(Window.java:2762)
	at java.desktop/java.awt.Component.dispatchEvent(Component.java:4844)
	at java.desktop/java.awt.EventQueue.dispatchEventImpl(EventQueue.java:772)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:721)
	at java.desktop/java.awt.EventQueue$4.run(EventQueue.java:715)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:95)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:745)
	at java.desktop/java.awt.EventQueue$5.run(EventQueue.java:743)
	at java.base/java.security.AccessController.doPrivileged(AccessController.java:391)
	at java.base/java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:85)
	at java.desktop/java.awt.EventQueue.dispatchEvent(EventQueue.java:742)
	at java.desktop/java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:203)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:124)
	at java.desktop/java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:113)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:109)
	at java.desktop/java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
	at java.desktop/java.awt.EventDispatchThread.run(EventDispatchThread.java:90)

Attachments (0)

Change History (1)

comment:1 Changed 4 months ago by naoliv

Resolution: duplicate
Status: newclosed

Closed as duplicate of #18593.
Why don't I look the previous tickets...

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.