Modify

Opened 9 months ago

Closed 9 months ago

#18635 closed defect (fixed)

Unknown property value - some more keys to ignore

Reported by: skyper Owned by: team
Priority: normal Milestone: 20.01
Component: Core validator Version: latest
Keywords: template_report unknown property value Cc:

Description

What steps will reproduce the problem?

  1. Have an object with duration=00:10 or interval=00:10
  2. run validator

What is the expected result?

No warning

What happens instead?

Unknown property value - Value '00:10' for key is unknown, maybe '10:30' is meant? (1)

Please provide any additional information below. Attach a screenshot if possible.

Own checks are needed but this one does not work. Please, exclude the keys from checking.

Same is true for :lanes keys. There are already own test and with the LaneAttributes preset installed I get: Value 'not_left|not_right|' for key 'change:lanes' is unknown, maybe 'not_left|not_right' is meant? (1) with change:lanes=not_left|not_right| which leads to misunderstandings and might damage the tagging.
Please do not propose to delete | in this warning.

Thanks

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-28 00:39:43 +0100 (Tue, 28 Jan 2020)
Revision:15791
Build-Date:2020-01-28 02:30:55
URL:https://josm.openstreetmap.de/svn/trunk

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1

Attachments (0)

Change History (2)

comment:1 Changed 9 months ago by Klumbumbus

Milestone: 20.01

comment:2 Changed 9 months ago by Klumbumbus

Resolution: fixed
Status: newclosed

In 15792/josm:

fix #18635 - ignore duration, interval, change:lanes, change:lanes:forward and change:lanes:backward in "value looks like..." validator test

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.