Modify

Opened 5 months ago

Closed 5 months ago

#18548 closed defect (duplicate)

JOSM top menu, mainly Imagery layer is very slow

Reported by: mapping@… Owned by: team
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report australia Cc:

Description

What steps will reproduce the problem?

  1. start JOSM
  2. download map
  3. enable images layer

What is the expected result?

Imagery menu should open without delay

What happens instead?

3-5 seconds delay after menu Imagery has been clicked.

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-02 22:34:59 +0100 (Thu, 02 Jan 2020)
Revision:15628
Build-Date:2020-01-02 21:52:31
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15628 en_AU) Linux Ubuntu 19.10
Memory Usage: 446 MB / 1918 MB (63 MB allocated, but free)
Java version: 11.0.5+10-post-Ubuntu-0ubuntu1.1, Private Build, OpenJDK 64-Bit Server VM
Screen: :0.0 1600x900
Maximum Screen Size: 1600x900
Java package: openjdk-11-jre:amd64-11.0.5+10-0ubuntu1.1
Java ATK Wrapper package: libatk-wrapper-java:all-0.35.0-3
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20181227-1
VM arguments: [-Djosm.restart=true, -Djava.net.useSystemProxies=true]
Dataset consistency test: No problems found

Plugins:
+ DirectDownload (35248)
+ Mapillary (1.5.20)
+ OpenStreetCam (280)
+ apache-commons (35092)
+ apache-http (35092)
+ buildings_tools (35248)
+ conflation (0.6.4)
+ jna (35092)
+ jts (35122)
+ rex (53)
+ scripting (30796)
+ tageditor (35258)
+ terracer (35248)
+ turnlanes-tagging (283)
+ turnrestrictions (35248)
+ utilsplugin2 (35248)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/Bus_lanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/BuildingPreset&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Presets/LaneAttributes&zip=1

Map paint styles:
+ https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/BesideTheRoad_Speed&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/SlovakiaBicycleRoutes&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Maxspeed&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/ParkingLanes&zip=1
+ https://josm.openstreetmap.de/josmfile?page=Styles/Schools&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Sidewalks&zip=1
+ ${HOME}/Software/osm-nsw-address-import/src/elemstyles.mapcss

Last errors/warnings:
- W: Failed to load https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico, use cached file and retry next time: java.io.IOException: The requested URL https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico was not found
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico'
- W: Failed to load https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico, use cached file and retry next time: java.io.IOException: The requested URL https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico was not found
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico'
- W: Failed to load https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico, use cached file and retry next time: java.io.IOException: The requested URL https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico was not found
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico'
- W: Failed to load https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico, use cached file and retry next time: java.io.IOException: The requested URL https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico was not found
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico'
- W: Failed to load https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico, use cached file and retry next time: java.io.IOException: The requested URL https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico was not found
- E: Failed to locate image 'https://www.spatial.nsw.gov.au/__data/assets/file/0010/210520/favicon.ico'

Attachments (0)

Change History (2)

comment:1 Changed 5 months ago by Don-vip

Component: CoreCore imagery
Milestone: 20.01

comment:2 Changed 5 months ago by Don-vip

Keywords: australia added
Milestone: 20.01
Resolution: duplicate
Status: newclosed

Closed as duplicate of #18534.
australian icon links changed recently, see https://github.com/osmlab/editor-layer-index/pull/759/files
The JOSM code issue has already been fixed in #18534.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.