Modify

#18536 closed defect (fixed)

DLS Imagery Orthophoto Cyprus

Reported by: rybikov-sergei@… Owned by: team
Priority: normal Milestone:
Component: External imagery source Version:
Keywords: template_report cyprus Cc: stoecker

Description

What steps will reproduce the problem?

  1. Good day.You edited the page https://josm.openstreetmap.de/wiki/Maps/Cyprus#DLSImageryOrthophoto201410cmWMS , so I came to you. Now it is impossible to connect to the page of images of Cyprus, gives an error 403-Forbidden: Access is denied using HTTP. (https://eservices.dls.moi.gov.cy/arcgis/services/BASEMAPS/Imagery_Orthophoto_2014_10cm/MapServer/WmsServer?FORMAT=image/png&TRANSPARENT=TRUE&VERSION=1.1.1&SERVICE=WMS&REQUEST=GetMap&LAYERS=0&STYLES=&SRS={proj}&WIDTH={width}&HEIGHT={height}&BBOX={bbox}) . But the link https://josm.openstreetmap.de/mapsview?entry=DLS%20Imagery%20Orthophoto%202014%2010cm%WMZ28WMS%29 shows an orthophoto. What’s wrong with JOSM? Thanks for help.

What is the expected result?

What happens instead?

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2020-01-02 22:34:59 +0100 (Thu, 02 Jan 2020)
Build-Date:2020-01-02 21:52:31
Revision:15628
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15628 ru) Windows 7 64-Bit
OS Build number: Windows 7 Home Basic (7601)
Memory Usage: 958 MB / 1820 MB (631 MB allocated, but free)
Java version: 1.8.0_191-b12, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ CommandLine (35248)
+ EasyPresets (1537621333)
+ OpeningHoursEditor (35250)
+ PicLayer (35248)
+ buildings_tools (35248)
+ editgpx (35248)
+ ejml (35122)
+ imagery_offset_db (35248)
+ jts (35122)
+ log4j (35092)
+ reltoolbox (35248)
+ reverter (35248)
+ tageditor (35258)
+ turnlanes-tagging (283)
+ turnrestrictions (35248)
+ utilsplugin2 (35248)

Tagging presets:
+ https://josm.openstreetmap.de/josmfile?page=Presets/NewTags&zip=1
+ http://textual.ru/irs.xml
+ https://raw.githubusercontent.com/ruosm-presets/literan-moscow/master/russian_shops.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Lane_and_Road_Attributes&zip=1
+ C:\Program Files (x86)\JOSM\shops_russia_moscow_region.xml

Last errors/warnings:
- W: [WAY] Lake: Could not get presets icon presets/water.png
- E: Не удалось найти изображение «presets/river.png»
- W: [WAY] River: Could not get presets icon presets/river.png
- E: Не удалось найти изображение «presets/river.png»
- W: [WAY] Stream: Could not get presets icon presets/river.png
- E: Не удалось найти изображение «presets/landuse.png»
- W: [WAY] Forest: Could not get presets icon presets/landuse.png
- E: Не удалось найти изображение «presets/landuse_water.png»
- W: [WAY] Wetland: Could not get presets icon presets/landuse_water.png
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (1)

2020.01.08_11-16-21.jpg (1.4 MB) - added by rybikov-sergei@… 11 months ago.
Screnshot on JOSM

Download all attachments as: .zip

Change History (9)

Changed 11 months ago by rybikov-sergei@…

Attachment: 2020.01.08_11-16-21.jpg added

Screnshot on JOSM

comment:1 Changed 11 months ago by Don-vip

Component: CoreExternal imagery source
Keywords: cyprus added

comment:2 Changed 11 months ago by Don-vip

Cc: stoecker added

I wonder if there is an IP-based or country-based restriction. The tiles can be accessed from German-based JOSM server, but I can't display them from my French connection neither.

comment:3 in reply to:  2 Changed 11 months ago by stoecker

Replying to Don-vip:

I wonder if there is an IP-based or country-based restriction. The tiles can be accessed from German-based JOSM server, but I can't display them from my French connection neither.

You cannot use JOSM or the mapsview link? Because mapsview also goes over the local connection. From the issue description it looks more like an HTTP-Header based block, e.g. by user agent.

comment:4 Changed 11 months ago by Don-vip

JOSM. Yep, probably just the user-agent.

comment:5 Changed 11 months ago by stoecker

Could someone ask them to not block JOSM? Probably it's a generic block, as Java is often used by Bots and SiteScrapers.

comment:6 Changed 11 months ago by Don-vip

I've sent this message using their contact form:

Hello,
We cannot access your WMS server providing your orthophoto (https://eservices.dls.moi.gov.cy/arcgis/services/BASEMAPS/Imagery_Orthophoto_2014_10cm/MapServer/WmsServer?) from JOSM, the Java OpenStreetMap editor.
We face the following error when accessing it:
403 - Forbidden: Access is denied using HTTP.
Please use https://eservices.dls.moi.gov.cy to access the site.
But we are accessing it in https, so I don't understand the error.
Is there some kind of blocking/restriction, or is it a bug?
Best regards,

Last edited 11 months ago by Don-vip (previous) (diff)

comment:7 Changed 11 months ago by Don-vip

Forgot about #18227

comment:8 Changed 11 months ago by Don-vip

Resolution: fixed
Status: newclosed

No clear license and server does not work. Removed in https://josm.openstreetmap.de/wiki/Maps/Cyprus?action=diff&version=13&old_version=12

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.