Modify

Opened 10 months ago

Closed 6 days ago

#18413 closed defect (irreproducible)

No download area after merge selection

Reported by: skyper Owned by: team
Priority: normal Milestone:
Component: Core Version: latest
Keywords: template_report download area merge selection Cc:

Description

What steps will reproduce the problem?

  1. download a node (node/5768358504) (layer 1)
  2. create a new layer (layer 2)
  3. select node in previous layer (layer 1)
  4. merge selection to empty layer (layer 2)

What is the expected result?

Download area is shown. In my case no area.

What happens instead?

No download area calculated

Please provide any additional information below. Attach a screenshot if possible.

Relative:URL: ^/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-12-11 01:40:30 +0100 (Wed, 11 Dec 2019)
Revision:15582
Build-Date:2019-12-11 02:30:55
URL:https://josm.openstreetmap.de/svn/trunk

Identification: JOSM/1.5 (15582 en) Linux Debian GNU/Linux 10 (buster)
Memory Usage: 349 MB / 964 MB (151 MB allocated, but free)
Java version: 11.0.5+10-post-Debian-1deb10u1, Debian, OpenJDK 64-Bit Server VM
Java package: openjdk-11-jre:amd64-11.0.5+10-1~deb10u1
Java ATK Wrapper package: libatk-wrapper-java:all-0.33.3-22
libcommons-compress-java: libcommons-compress-java:all-1.18-2
libcommons-logging-java: libcommons-logging-java:all-1.2-2
fonts-noto: fonts-noto:all-20181227-1
Dataset consistency test: No problems found

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.

Attachments (0)

Change History (4)

comment:1 Changed 10 months ago by Don-vip

Resolution: invalid
Status: newclosed

If you download a node, you obviously don't download an area.

comment:2 in reply to:  1 Changed 10 months ago by skyper

Resolution: invalid
Status: closedreopened

Replying to Don-vip:

If you download a node, you obviously don't download an area.

That is the point. Everything should be outside of download area.

Sorry, my report was to short, once again.

It does not matter how many objects you download and merge also the object type can be node and/or way.
The problem is not the rendering of the download area but the missing information about download area as validator and some important warnings rely on this info.

Merge selection should be treated similar/same as an overpass query as we have no chance to be sure that the data in this area is complete.

comment:3 Changed 6 days ago by GerdP

I have noo idea what change you want.

comment:4 in reply to:  3 Changed 6 days ago by skyper

Resolution: irreproducible
Status: reopenedclosed

Replying to GerdP:

I have noo idea what change you want.

I can not reproduce either. Seems to be work as expected.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.