Modify

Opened 4 months ago

Closed 4 months ago

#18386 closed defect (fixed)

DataIntegrityProblemException in parallel way mode

Reported by: GerdP Owned by: team
Priority: normal Milestone: 19.12
Component: Core Version:
Keywords: template_report Cc: ris

Description

What steps will reproduce the problem?

  1. Load brandenburg-simple.osm from #18368
  2. Split both ways where they overlap so that you have 6 ways
  3. Remove one of the overlapping ways
  4. Select all ways
  5. Switch to "Make parallel copies of ways" mode (Shift+P
  6. Try to draw

What is the expected result?

A parallel way should appear

What happens instead?

Bug report

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-12-01 23:10:15 +0100 (Sun, 01 Dec 2019)
Build-Date:2019-12-02 02:30:57
Revision:15553
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15553 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1903 (18362)
Memory Usage: 934 MB / 4551 MB (300 MB allocated, but free)
Java version: 1.8.0_221-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ OpeningHoursEditor (35242)
+ apache-commons (35092)
+ buildings_tools (35171)
+ continuosDownload (82)
+ ejml (35122)
+ geotools (35169)
+ jaxb (35014)
+ jts (35122)
+ merge-overlap (35072)
+ o5m (34908)
+ opendata (35179)
+ pbf (35033)
+ poly (34991)
+ reverter (35226)
+ undelete (34977)
+ utilsplugin2 (35238)

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Unable to add primitive {Node id=-122728 version=0 MV lat=52.55051305295,lon=13.09798864018} to the dataset because it is already included
- E: Handled by bug report queue: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Unable to add primitive {Node id=-122747 version=0 MV lat=52.55051305295,lon=13.09798864018} to the dataset because it is already included


=== REPORTED CRASH DATA ===
BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (17) of main
org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Unable to add primitive {Node id=-122728 version=0 MV lat=52.55051305295,lon=13.09798864018} to the dataset because it is already included
	at org.openstreetmap.josm.data.osm.DataSet.addPrimitive(DataSet.java:476)
	at org.openstreetmap.josm.command.AddCommand.executeCommand(AddCommand.java:54)
	at org.openstreetmap.josm.command.SequenceCommand.executeCommand(SequenceCommand.java:79)
	at org.openstreetmap.josm.data.UndoRedoHandler.addNoRedraw(UndoRedoHandler.java:301)
	at org.openstreetmap.josm.data.UndoRedoHandler.add(UndoRedoHandler.java:355)
	at org.openstreetmap.josm.actions.mapmode.ParallelWays.commit(ParallelWays.java:188)
	at org.openstreetmap.josm.actions.mapmode.ParallelWayAction.initParallelWays(ParallelWayAction.java:524)
	at org.openstreetmap.josm.actions.mapmode.ParallelWayAction.mouseDragged(ParallelWayAction.java:379)
	at java.awt.AWTEventMulticaster.mouseDragged(Unknown Source)
	at java.awt.Component.processMouseMotionEvent(Unknown Source)
	at javax.swing.JComponent.processMouseMotionEvent(Unknown Source)
	at java.awt.Component.processEvent(Unknown Source)
	at java.awt.Container.processEvent(Unknown Source)
	at java.awt.Component.dispatchEventImpl(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
	at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
	at java.awt.Container.dispatchEventImpl(Unknown Source)
	at java.awt.Window.dispatchEventImpl(Unknown Source)
	at java.awt.Component.dispatchEvent(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.awt.EventQueue$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (5)

comment:1 Changed 4 months ago by GerdP

Resolution: fixed
Status: newclosed

In 15557/josm:

fix #18386: DataIntegrityProblemException in parallel way mode

comment:2 Changed 4 months ago by GerdP

Milestone: 19.12

comment:4 Changed 4 months ago by GerdP

No idea why this test fails now. It doesn't fail on my machine and I see no relationship to the change in r15557.
Was anything changed on the server?

comment:5 Changed 4 months ago by GerdP

Cc: ris added
Resolution: fixed
Status: reopenedclosed

Test worked again after a "no-change" in r15559.
Seems to be a problem in the setup of the unit test, see also #18204.
I have no idea where to fix this, but I think it should be discussed in #18204.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.