Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#18292 closed defect (fixed)

[PATCH] JOSM Remote Control is missing all the options

Reported by: taylor.smock Owned by: team
Priority: major Milestone: 19.11
Component: Core remotecontrol Version:
Keywords: regression Cc:

Description

If the RequestProcessor class is not called before preferences are opened, then the static list for the panel isn't built.

This fix moves the initialization parts into a static method initialize, which is called by both the RequestProcessor and getPermissionPrefs (but only if the PREF list is empty).

Attachments (1)

18292.patch (3.8 KB) - added by taylor.smock 2 years ago.
Initialize pref list for remote control (by manually calling RequestProcessor)

Download all attachments as: .zip

Change History (5)

Changed 2 years ago by taylor.smock

Attachment: 18292.patch added

Initialize pref list for remote control (by manually calling RequestProcessor)

comment:1 Changed 2 years ago by Don-vip

Milestone: 19.11

Is it a regression of your previous patch?

comment:2 Changed 2 years ago by Don-vip

Resolution: fixed
Status: newclosed

In 15507/josm:

fix #18292 - Initialize pref list for remote control (patch by taylor.smock)

comment:3 Changed 2 years ago by taylor.smock

Its a regression caused by my previous patch. I don't believe that it is due to a difference between my patch and your modified patch, since it looked like the only difference was your use of Optional.ofNullable instead of if (obj != null).

I didn't notice this since I have a plugin that called RequestHandler in initialization, which initialized the static fields.

comment:4 Changed 2 years ago by Don-vip

Keywords: regression added

OK, thanks.

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.