Modify

Opened 2 months ago

Closed 2 months ago

#18225 closed defect (fixed)

Fails to open EDIGEO file

Reported by: frodrigo Owned by: Don-vip
Priority: normal Milestone:
Component: Plugin cadastre-fr Version:
Keywords: edigeo Cc:

Description

Any EDIGEO file on tar.bz2 or uncompressed gave the same exception

2019-10-14 14:17:40.125 INFOS: Open file: /tmp/y/edigeo-220210000D01.tar.bz2 (139083 bytes)
2019-10-14 14:17:40.282 INFOS: Auteur: CDIF de Centre des Impots Foncier
2019-10-14 14:17:40.283 INFOS: Destinataire: Export PCI-Vecteur, version 3.5.2 (standard 2012)
2019-10-14 14:17:40.283 INFOS: Date: 2017-03-10
2019-10-14 14:17:40.283 INFOS: Informations: Echange issu du plan cadastral informatisé
2019-10-14 14:17:40.283 INFOS: Nom: ED0D01
2019-10-14 14:17:40.284 INFOS: Projection: LAMB93
2019-10-14 14:17:40.541 GRAVE: java.lang.NullPointerException
java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciReader.lambda$static$3(EdigeoPciReader.java:46)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.EdigeoFileVEC.fill(EdigeoFileVEC.java:573)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.EdigeoFileVEC.fill(EdigeoFileVEC.java:53)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.EdigeoFileTHF$Lot.lambda$fill$12(EdigeoFileTHF.java:282)
	at java.util.ArrayList.forEach(ArrayList.java:1257)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.EdigeoFileTHF$Lot.fill(EdigeoFileTHF.java:282)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.EdigeoFileTHF.fill(EdigeoFileTHF.java:494)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciReader.parse(EdigeoPciReader.java:309)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciReader.parseDataSet(EdigeoPciReader.java:274)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciImporter.parseDataSet(EdigeoPciImporter.java:57)
	at org.openstreetmap.josm.gui.io.importexport.OsmImporter.loadLayer(OsmImporter.java:120)
	at org.openstreetmap.josm.gui.io.importexport.OsmImporter.importData(OsmImporter.java:97)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciImporter.importData(EdigeoPciImporter.java:47)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:95)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:367)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:319)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)

2019-10-14 14:17:40.542 GRAVE: org.openstreetmap.josm.io.IllegalDataException: java.io.IOException: java.lang.NullPointerException. Cause : java.io.IOException: java.lang.NullPointerException. Cause : java.lang.NullPointerException
org.openstreetmap.josm.io.IllegalDataException: java.io.IOException: java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciImporter.parseDataSet(EdigeoPciImporter.java:59)
	at org.openstreetmap.josm.gui.io.importexport.OsmImporter.loadLayer(OsmImporter.java:120)
	at org.openstreetmap.josm.gui.io.importexport.OsmImporter.importData(OsmImporter.java:97)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciImporter.importData(EdigeoPciImporter.java:47)
	at org.openstreetmap.josm.gui.io.importexport.FileImporter.importDataHandleExceptions(FileImporter.java:95)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.importData(OpenFileAction.java:367)
	at org.openstreetmap.josm.actions.OpenFileAction$OpenFileTask.realRun(OpenFileAction.java:319)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.doRealRun(PleaseWaitRunnable.java:94)
	at org.openstreetmap.josm.gui.PleaseWaitRunnable.run(PleaseWaitRunnable.java:142)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
	at java.util.concurrent.FutureTask.run(FutureTask.java:266)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.io.IOException: java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciReader.parseDataSet(EdigeoPciReader.java:279)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciImporter.parseDataSet(EdigeoPciImporter.java:57)
	... 13 more
Caused by: java.lang.NullPointerException
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciReader.lambda$static$3(EdigeoPciReader.java:46)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.EdigeoFileVEC.fill(EdigeoFileVEC.java:573)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.EdigeoFileVEC.fill(EdigeoFileVEC.java:53)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.EdigeoFileTHF$Lot.lambda$fill$12(EdigeoFileTHF.java:282)
	at java.util.ArrayList.forEach(ArrayList.java:1257)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.EdigeoFileTHF$Lot.fill(EdigeoFileTHF.java:282)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.EdigeoFileTHF.fill(EdigeoFileTHF.java:494)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciReader.parse(EdigeoPciReader.java:309)
	at org.openstreetmap.josm.plugins.fr.cadastre.edigeo.pci.EdigeoPciReader.parseDataSet(EdigeoPciReader.java:274)
	... 14 more

2019-10-14 14:17:40.546 GRAVE: Erreur - <html>Impossible de lire le fichier 'edigeo-220210000D01.tar.bz2'.<br>Erreur :<br>java.io.IOException: java.lang.NullPointerException</html>

Attachments (1)

edigeo-010010000A01.tar.bz2 (87.6 KB) - added by frodrigo 2 months ago.

Download all attachments as: .zip

Change History (4)

Changed 2 months ago by frodrigo

Attachment: edigeo-010010000A01.tar.bz2 added

comment:1 Changed 2 months ago by frodrigo

comment:2 Changed 2 months ago by Don-vip

Component: CorePlugin cadastre-fr
Owner: changed from team to Don-vip
Status: newassigned

comment:3 Changed 2 months ago by Don-vip

Resolution: fixed
Status: assignedclosed

Fixed in [o35191:35192].

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.