Modify

Opened 2 years ago

Closed 2 years ago

#18171 closed defect (worksforme)

Find almost right angle (RightAngleBuildingTest Class) returns no result in Validation Results

Reported by: pierzen Owned by: team
Priority: normal Milestone:
Component: Core validator Version: tested
Keywords: template_report right angle building Cc:

Description (last modified by Don-vip)

What steps will reproduce the problem?

  1. Assure that «Almost right angle buildings» Option is selected in the JOSM validator preferences
  1. Assure that validator.RightAngleBuilding options are defined
  • validator.RightAngleBuilding.maximumDelta=1
  • validator.RightAngleBuilding.maximumDelta=10
  1. Download building polygons that contain almost right angles (vary from 1 to 10 degrees vs right angle)

Overpass Query
way(id:134821060, 134819184, 134835369, 134835374, 134835376, 134835378, 134835379);
out meta;>; out meta;

Angles list
*Angles near 90 degrees*
id=134821060, angle_list="{89.3,96.6,84.7,89.4,89.3}"

*Angles both near 90 degrees and 180 degrees*
id=134819184, angle_list="{89.5,99,176.8,88.5,85.7,90.2,90.8,89.5}"
id=134835369, angle_list="{178,92.4,89.7,180,89.3,90.7,178}"
id=134835374, angle_list="{88,91,179.8,94.3,89.2,89.2,87,88}"
id=134835376, angle_list="{177.2,94.2,177.6,93.2,86.4,93.2,89.2,90.9,176.5,177.2}"
id=134835378, angle_list="{178.6,89.6,84.8,97,90,178.6}"
id=134835379, angle_list="{174.8,93.7,90.3,91.4,89.8,174.8}"

  1. Press Validation Button in the Validatin Panel

What is the expected result?

The Validation Panel should report these polygons as «Almost right angle» in the «Other» section. Note the id 134821060 contains only angles close to 90 degrees while other polygons also contains angles close to 180 degrees.

If angles closed to 180 degrees are not yet considered, I suggest that there should be an enhancment to consider these angles.

What happens instead?

Nothing is reported. Did appear once for one of the id, but cannot reproduce.

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-08-26 08:55:27 +0200 (Mon, 26 Aug 2019)
Build-Date:2019-08-26 06:57:10
Revision:15322
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15322 en) Windows 10 64-Bit
OS Build number: Windows 10 Home 1903 (18362)
Memory Usage: 700 MB / 1365 MB (295 MB allocated, but free)
Java version: 1.8.0_221-b11, Oracle Corporation, Java HotSpot(TM) 64-Bit Server VM
Screen: \Display0 1366x768
Maximum Screen Size: 1366x768
Dataset consistency test: No problems found

Plugins:
+ apache-commons (34908)
+ ejml (35049)
+ geojson (124)
+ geotools (34908)
+ jaxb (35014)
+ jts (35064)
+ opendata (35102)
+ utilsplugin2 (35098)

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Admin_Boundaries&zip=1
- https://josm.openstreetmap.de/josmfile?page=Styles/Fixme&zip=1
+ https://github.com/hotosm/HDM-JOSM-style/archive/master.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/Highway_Nodes&zip=1
- https://github.com/osmlab/appledata/archive/josm_paint_inline_validation.zip
- https://josm.openstreetmap.de/josmfile?page=Styles/LessObtrusiveNodes&zip=1
- https://github.com/MissingMaps/josm_styles/archive/master.zip
- d:\osm\josm\way_nonodes.mapcss
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_buildings&zip=1

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: Cannot start IPv4 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect
- W: Cannot start IPv6 remotecontrol https server on port 8112: Keystore was tampered with, or password was incorrect

Attachments (0)

Change History (3)

comment:1 Changed 2 years ago by Don-vip

Component: CoreCore validator
Keywords: right angle building added

comment:2 Changed 2 years ago by Don-vip

Description: modified (diff)

comment:3 Changed 2 years ago by Don-vip

Resolution: worksforme
Status: newclosed

Since #18000 the test only operates for ways belonging to the download area. When using overpass download you don't get complete data, so we don't set download bounds in this case. Just make a regular download and you will see results (make sure to also enable information level, it has been downgraded in #16280 until the autofix works correctly)

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.