Modify

Opened 2 years ago

Closed 21 months ago

#17966 closed defect (duplicate)

Plantage en cas d'utilisation simultanée des calques mapbox-building et cadastre-FR

Reported by: py_berrard@… Owned by: team
Priority: normal Milestone:
Component: Core imagery Version:
Keywords: template_report zoom mapbox Cc:

Description

What steps will reproduce the problem?

  1. Ouvrir les tuiles cadastre-FR
  1. Ouvrir le calque mapbox buildings

tms[99]:https://api.mapbox.com/v4/pratikyadav.332dd523/{zoom}/{x}/{y}.png?access_token=pk.eyJ1IjoicHJhdGlreWFkYXYiLCJhIjoiMTA2YWUxNjRkNmFmZGQ4YzAxZWFiNDk0NDM1YjE1YjAifQ.4P6N5dNmA_WQXd3BsJvu5w

  1. Zommer

What is the expected result?

What happens instead?

Plantage

Please provide any additional information below. Attach a screenshot if possible.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-07-10 00:52:47 +0200 (Wed, 10 Jul 2019)
Build-Date:2019-07-10 01:30:51
Revision:15238
Relative:URL: ^/trunk

Identification: JOSM/1.5 (15238 fr) Windows 8.1 64-Bit
OS Build number: Windows 8.1 (9600)
Memory Usage: 514 MB / 989 MB (170 MB allocated, but free)
Java version: 1.8.0_31-b13, Oracle Corporation, Java HotSpot(TM) Client VM
Screen: \Display0 1920x1080
Maximum Screen Size: 1920x1080
Dataset consistency test: No problems found

Plugins:
+ ImportImagePlugin (34908)
+ Mapillary (1.5.18)
+ apache-commons (34908)
+ apache-http (34908)
+ cadastre-fr (34977)
+ ejml (35049)
+ geotools (34908)
+ jaxb (35014)
+ jna (34908)
+ jts (35064)
+ log4j (34908)
+ opendata (34997)
+ photo_geotagging (34908)
+ poly (34991)
+ reverter (34999)
+ tag2link (35043)
+ undelete (34977)
+ utilsplugin2 (34977)

Tagging presets:
+ D:\Pierre-Yves\JOSM\presets\bus_stan.xml
+ D:\Pierre-Yves\JOSM\presets\equipements.xml
+ D:\Pierre-Yves\JOSM\presets\bati_cadastre.xml
+ D:\Pierre-Yves\JOSM\presets\GN Ortho2012.xml

Map paint styles:
- https://josm.openstreetmap.de/josmfile?page=Styles/Coloured_Streets&zip=1
- https://www.dropbox.com/s/qo3ai47fpv241jf/Styles_Fixme_and_Notes.zip?raw=1
- https://github.com/GlassOceanos/indoor-JOSM-style/archive/master.zip

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- E: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-115453 version=0 V nodes=[{Node id=-111633 version=0 V lat=43.113107621632,lon=5.843940304594}, {Node id=-115454 version=0 V lat=43.11320705085234,lon=5.844162758048551}, {Node id=-115455 version=0 V lat=43.1133454798334,lon=5.844442043753839}, {Node id=-115456 version=0 V lat=43.11339423449978,lon=5.844518028076104}, {Node id=-115451 version=0 V lat=43.11340899431651,lon=5.844480548354271}]}
- E: org.openstreetmap.josm.data.osm.DataIntegrityProblemException: Primitive must be part of the dataset: {Way id=-119589 version=0 V nodes=[{Node id=-115769 version=0 V lat=43.113107621632,lon=5.843940304594}, {Node id=-119590 version=0 V lat=43.11320705085234,lon=5.844162758048551}, {Node id=-119591 version=0 V lat=43.1133454798334,lon=5.844442043753839}, {Node id=-119592 version=0 V lat=43.11339423449978,lon=5.844518028076104}, {Node id=-119587 version=0 V lat=43.11340899431651,lon=5.844480548354271}]}
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: tileXYToLatLon returned Coordinate[NaN, NaN]
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: tileXYToLatLon returned Coordinate[NaN, NaN]
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: tileXYToLatLon returned Coordinate[NaN, NaN]
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: tileXYToLatLon returned Coordinate[NaN, NaN]
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: tileXYToLatLon returned Coordinate[NaN, NaN]
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: tileXYToLatLon returned Coordinate[NaN, NaN]
- E: Handled by bug report queue: org.openstreetmap.josm.tools.JosmRuntimeException: tileXYToLatLon returned Coordinate[NaN, NaN]


=== REPORTED CRASH DATA ===
TileCoordinateConverter#getPixelForTile:
 - tileSource: mapbox buildings
 - x: 0
 - y: 0
 - zoom: 24

BugReportExceptionHandler#handleException:
No data collected.

Warning issued by: BugReportExceptionHandler#handleException

=== STACK TRACE ===
Thread: AWT-EventQueue-0 (15) of main
org.openstreetmap.josm.tools.JosmRuntimeException: tileXYToLatLon returned Coordinate[NaN, NaN]
	at org.openstreetmap.josm.gui.layer.imagery.TileCoordinateConverter.getPixelForTile(TileCoordinateConverter.java:87)
	at org.openstreetmap.josm.gui.layer.imagery.TileCoordinateConverter.getPixelForTile(TileCoordinateConverter.java:101)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.paintTileText(AbstractTileSourceLayer.java:1150)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.drawInViewArea(AbstractTileSourceLayer.java:1602)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer.access$2600(AbstractTileSourceLayer.java:143)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer$TileSourcePainter.doPaint(AbstractTileSourceLayer.java:1931)
	at org.openstreetmap.josm.gui.layer.AbstractTileSourceLayer$TileSourcePainter.paint(AbstractTileSourceLayer.java:1925)
	at org.openstreetmap.josm.gui.MapView.paintLayer(MapView.java:469)
	at org.openstreetmap.josm.gui.MapView.drawMapContent(MapView.java:584)
	at org.openstreetmap.josm.gui.MapView.paint(MapView.java:491)
	at javax.swing.JComponent.paintChildren(Unknown Source)
	at javax.swing.JComponent.paint(Unknown Source)
	at javax.swing.JComponent.paintToOffscreen(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paintDoubleBuffered(Unknown Source)
	at javax.swing.RepaintManager$PaintManager.paint(Unknown Source)
	at javax.swing.RepaintManager.paint(Unknown Source)
	at javax.swing.JComponent._paintImmediately(Unknown Source)
	at javax.swing.JComponent.paintImmediately(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at javax.swing.RepaintManager$4.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.paintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.prePaintDirtyRegions(Unknown Source)
	at javax.swing.RepaintManager.access$1300(Unknown Source)
	at javax.swing.RepaintManager$ProcessingRunnable.run(Unknown Source)
	at java.awt.event.InvocationEvent.dispatch(Unknown Source)
	at java.awt.EventQueue.dispatchEventImpl(Unknown Source)
	at java.awt.EventQueue.access$500(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.awt.EventQueue$3.run(Unknown Source)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.security.ProtectionDomain$1.doIntersectionPrivilege(Unknown Source)
	at java.awt.EventQueue.dispatchEvent(Unknown Source)
	at java.awt.EventDispatchThread.pumpOneEventForFilters(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForFilter(Unknown Source)
	at java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
	at java.awt.EventDispatchThread.run(Unknown Source)

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by skyper

Component: CoreCore imagery

comment:2 Changed 21 months ago by Don-vip

Keywords: zoom mapbox added
Resolution: duplicate
Status: newclosed

Closed as duplicate of #18064.
we don't yet support zoom 24

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain team.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.