Modify

Opened 7 days ago

Closed 6 days ago

Last modified 5 days ago

#17910 closed defect (fixed)

Relation editor: Download of incomplete members not possible from cloned relations

Reported by: skyper Owned by: Don-vip
Priority: normal Milestone: 19.08
Component: Core Version: latest
Keywords: template_report relation incomplete download clone Cc:

Description (last modified by skyper)

What steps will reproduce the problem?

  1. open a new, incomplete relation in relation manager by cloning
  2. select some members

What is the expected result?

The button to download selected members is enabled.

What happens instead?

The button to download selected members stays disabled.

Please provide any additional information below. Attach a screenshot if possible.

After closing and reopening the relation manager everything is fine.

URL:https://josm.openstreetmap.de/svn/trunk
Repository:UUID: 0c6e7542-c601-0410-84e7-c038aed88b3b
Last:Changed Date: 2019-07-09 01:01:06 +0200 (Tue, 09 Jul 2019)
Build-Date:2019-07-08 23:02:00
Revision:15237
Relative:URL: ^/trunk

Last errors/warnings:
- W: No configuration settings found.  Using hardcoded default values for all pools.
- W: java.net.SocketTimeoutException: Read timed out

Attachments (0)

Change History (8)

comment:1 Changed 7 days ago by Don-vip

Milestone: 19.06
Owner: changed from team to Don-vip
Status: newassigned

comment:2 Changed 6 days ago by Don-vip

Owner: changed from Don-vip to skyper
Status: assignedneedinfo

Can't reproduce, button is enabled and works for me. Can you please share a video?

comment:3 Changed 6 days ago by skyper

Description: modified (diff)
Keywords: regression removed

Sorry, I was totally of with this one:

It is no regression.
It only happens with new created relations before closing the relation manager for the first time.
I did change the description.

comment:4 Changed 6 days ago by Don-vip

Milestone: 19.0619.07

comment:5 Changed 6 days ago by skyper

Owner: changed from skyper to team
Status: needinfonew

comment:6 Changed 6 days ago by Don-vip

Keywords: incomplete clone added; manager selected removed
Owner: changed from team to Don-vip
Status: newassigned
Summary: Relation manager: Download of selected members not possibleRelation editor: Download of incomplete members not possible from cloned relations

comment:7 Changed 6 days ago by Don-vip

Resolution: fixed
Status: assignedclosed

In 15240/josm:

fix #17910 - Enable download of incomplete members from cloned relations in relation editor

comment:8 Changed 5 days ago by Don-vip

Milestone: 19.0719.08

Milestone renamed

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain Don-vip.
as The resolution will be set.
The resolution will be deleted.

Add Comment


E-mail address and name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.